
Introducing Advanced PCB

Advanced PCB

Protel Designer's ハンドブックのこのセクションではAdvanced PCBを使ったプリン
ト基板設計について説明します。 このセクションではAdvanced PCBの基本的な機
能、基板設計におけるレイアウトやルーティングのテクニック、またプリント基板を
製作する場合の必要な情報を得ることができます。
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PCB エエエエデデデディィィィタタタタ
PCBエディタはAdvanced PCBにおける主要なドキュメント･エディタです。このエデ
ィタによって、ユーザはPCBの設計を行ったり、編集したり、確認したりすることが
できます。また、PCBエディタからプリント基板の製造に必要なファイルを作成する
ことができます。

PCBラララライイイイブブブブララララリリリリーーーーエエエエデデデディィィィタタタタ
PCBライブラリーエディタはAdvanced PCBにおけるもう１つのドキュメント･エディ
タです。コンポーネントのフットプリント(部品形状)ライブラリーを作成、編集、管
理する場合に使います。PCBライブラリー･エディタはPCBエディタと多くの共通の
機能に加えライブラリー管理タスクに対する特別なツールと機能を共有しています。

シシシシェェェェーーーーブブブブ‐‐‐‐ベベベベーーーーススススののののオオオオーーーートトトトルルルルーーーーテテテティィィィンンンンググググ
Advanced PCBで自動配線を行うには、他のAutoroutingサーバー、Advanced Routeが
必要です。Advanced Routeは簡単で使いやすい高性能のシェイプ･ベースのオートル
ータです。

Advanced Routeには従来からのタイム－プローブによる手法に加えて新しいルーティ
ング･テクノロジーが使われています。新しいルーティング･テクノロジーはニューラ
ル･ネット、ニューラル･コスト、ニューラル･シェイプで構成されています。また、
Advanced Routeは従来からの配線アルゴリズムも大きく拡張されています。

Advanced Route には100%自動配線、配線のスピード、熟練した基板設計者のような
配線の品質の3つの目的があります。

デデデデザザザザイイイインンンン能能能能力力力力
Advanced PCBはたくさんの魅力的な機能を持つ完成されたPCBレイアウト環境で
す。このPCBレイアウトシステムはスタンドアロンで使用されます。また、Advanced
Schematic、Advanced SIM、Advanced PLDと結びつけることによって、Advanced
PCBは完全に自動、統合されたエンド-トゥ-エンドのデザインシステムのバックボー
ンになります。

ProtelのEDA/ClientとPCBデザインサーバーは標準的なWindowsユーザー･インター･
フェイスの中で働きます。これまでWindowsアプリケーションを使った経験のある方
は、ProtelのPCBデザイン･サーバーの起動や終了、またエクスプローラやファイルマ
ネージャを使用し、ドキュメントの操作を行うことは容易だと思います。

つまり、本システムは他のWindowのアプリケーションと同様です。しかしながら、
本PCBデザインシステムはPCBのレイアウト設計を目的としたアプリケーションであ
るため、いくつか他のWindowsのアプリケーションと異なる点があることを知ってお
く必要があります。
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PCBのレイアウト設計においては、他の図面作成用のアプリケーションと比較して、
非常に高い精度が要求されます。そのため、プロテルのデザインシステムはフリーハ
ンドで作成できるアプリケーション環境に比べ多くの配置･位置決め用の環境が準備
されています。

もう一つの基本的な違いは、配線機能です。すなわち、トラックセグメントどうし(線
分と線分どうし)の接続やトラックとコンポーネントパッド(トラックと部品のピン)な
どの接続関係をシステムが理解できるという機能です。例えば、このシステムによ
り、トラックからパッドへの接続を保ったままで部品を移動することができます。こ
のような配線に関する機能は、設計のいろいろな段階で使用することになります。

PCBレイアウトは、トップ(部品面)やボトム(半田面)のシグナルレイヤーやシルクスク
リーンレイヤーなどの基板を製作するために使用される、それぞれのフォトツール(各
層毎に作画されるフィルム)に対応するレイヤー毎にデータ作成、表示が行われます。
マニュアル操作でトラックを配置する際は、レイヤーに依存されます。そのため、最
初にレイヤーを選択し、つぎにトラックを配置します。

Advnced PCBでは、各アイテムを正しくレイアウトすることにより簡単な片面基板か
ら複数のインターナルプレーンを持つ多層基板についても作成することができます。

32ビビビビッッッットトトトPCBデデデデザザザザイイイインンンンデデデデーーーータタタタベベベベーーーースススス

Advanced PCBは32ビットのデザイン･データベースを使用し、16枚の信号レイヤーに
加え４枚の電源プレーンまでのスルーホールとSMDデザインを行うことができます。
４枚のメカニカル･ドローイング･レイヤー(電気的属性と無関係のレイヤー)により基
板製造および組み立て図面を作成できます。基板は100インチ（254cm）Ｘ100インチ
のサイズまで扱うことができ、基板上での位置精度は0.001milのグリッド設定で±
0.0005milの精度が得られます。

切り替え可能なメトリック／インペリアル グリッドシステムにより、どの計測システ
ムでも精度のよい作業を行うことができ、設計に応じてすぐに切り替えることができ
ます。

ススススケケケケママママテテテティィィィッッッックククク････キキキキャャャャププププチチチチャャャャととととののののリリリリンンンンクククク

ネットリストベースのデザイン･エントリではすべてサポートされます。スケマティ
ックにより作成されたネットリストをロードすれば、Advanced PCBのオンライン接
続モニタリング(常時、接続情報を監視する機能)やわかりやすいデザインルール、自
動部品配置、マニュアル配線や自動配線、ECO(設計変更の記録)、デザインルールチ
ェック機能などの有効性がわかります。ProtelのAdvanced Schematicサーバとは特別
なリンクがあり、スケマチックシートと基板ファイルとの間で相方向クロスプロービ
ングが可能です。

デデデデザザザザイイイインンンン････ルルルルーーーールルルル

今日の電気設計では、よりシンプルな構造、ならびに基板における電気的特性などの
必要条件を満たすことが課せられています。そのような要求から、個々のネットやコ
ンポーネント、基板上の指定範囲に特定のルールを適用する必要があります。それと
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同時に、クロストークや反射、ネットの長さなどの問題も考慮にいれる必要がありま
す。

これらの要求を解決するため、Advanced PCBには多くのデザインルールが組み込ま
れています。この中には、クリアランスやオブジェクトの配置、平行性、インピーダ
ンスのコントロール、配線の優先順位、配線の位相があります。各ルールは、基板や
ネット、ネットクラス、from-tos(フロムトゥ)、from-toクラス、部品(コンポーネン
ト)、コンポーネントクラス、レイヤー、ユーザ定義領域に適用されます。

オオオオンンンンラララライイイインンンンととととババババッッッッチチチチにににによよよよるるるるデデデデザザザザイイイインンンン････ルルルルーーーールルルル････チチチチェェェェッッッックククク

配線中に、オンラインDRCにより、デザイン･ルール違反が警告されます。一方、バ
ッチDRCでは、ユーザ指定の物理的あるいは論理的デザイン･ルールを簡単に検証で
きます。

自自自自動動動動部部部部品品品品配配配配置置置置

Advanced PCBデザインシステムには、高性能の自動部品配置サーバがあります。こ
の自動配置機能は、AIをベースにした方法で実行されます。これにより、デザインル
ールに沿って、配線の長さや配線密度、部品の配置などすべてを考慮しながら部品の
配置を決定します。

接接接接続続続続情情情情報報報報のののの保保保保持持持持

Advanced PCBの特徴の一つに、エレメント間(パッドやトラックなど)の論理的または
物理的（電気的）接続の表現方法にあります。Advanced PCBはトラックが配置され
たり削除されるなどして変更された接続状態を常時、チェックします。

ググググリリリリッッッッドドドドレレレレスススス････ママママニニニニュュュュアアアアルルルル････ルルルルーーーーテテテティィィィンンンンググググ

コンポーネントパッケージングテクノロジーの変遷により、設計者は、グリッドをベ
ースにした設計環境でマニュアル配線を行うことは困難になってきました。マニュア
ル配線に対する要求に応じていくために、Advanced PCBではトラックをグリッドレ
スで配線できるようにしました。

エレクトリカルグリッド（オブジェクトがのるグリッド）と障害物回避モードと７つ
のトラック配置モードを組み合わせることにより、あらゆるオブジェクトに対し、ル
ール違反をせずに配線することができます。

フフフフレレレレキキキキシシシシブブブブルルルル････セセセセレレレレククククシシシショョョョンンンン

アイテムのグループ単位のセレクションは、レイヤーや物理的接続、基板のエリアを
指定することで行うことができます。各アイテムはセレクションされたグループに対
して追加や削除 (セレクションされたグループからはずす )ができます。また、
Advanced PCBには、QueryWizard(クエリーウィザード)があり、これを使用すれば、
異なるプリミティブの複雑なセレクションを作成したり、標準のオペレータに条件を
与えるなどして使用することができます。
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セレクションは、標準のWindowsエディットメニュー（Cut、Copy、Paste、Clear）
を使用して操作できます。また、各軸に沿って.001度単位で回転することもできま
す。

ググググロロロローーーーババババルルルル編編編編集集集集オオオオププププシシシショョョョンンンン

属性を変更するには、アイテムを直接ダブルクリックしてダイアログボックスを開い
て行います。Advanced PCBでは、あるオブジェクトに対して行われた変更は、ター
ゲットを定義する特定の条件を使用して設計全体に反映されます。例えば、トラック
の幅やトラックのレイヤーを変更する場合、同じ幅やレイヤーのトラックに影響しま
す。このようにグローバル･オプションはその他のデザイン･オブジェクトに影響を与
えます。

リリリリニニニニアアアア、、、、ササササーーーーキキキキュュュュララララーーーーアアアアレレレレイイイイ配配配配置置置置

アレイ配置（Advanced PCBオプション）により、選択した領域を円形の配列や直線
の配列として配置することができます。円形のくり返しは、半径と角度のインクリメ
ントで定義されます。それぞれのくり返しアイテムは、その軸を中心に回転されます

アアアアンンンンドドドドゥゥゥゥととととリリリリドドドドゥゥゥゥ

アンドゥとリドゥプロセスはボードレイアウトの物理的変更に対して機能します。設
計者がおこなった変更はアンドゥにより元に戻すことができます。また、アンドゥに
よる変更は、リドゥにより復帰させることができます。

ココココンンンンポポポポーーーーネネネネンンンントトトトととととラララライイイイブブブブララララリリリリーーーー管管管管理理理理

複数のライブラリを同時に開くことができます。PCBエディタで基板設計を行ってい
る際でもPCBライブラリーエディタを用いてライブラリを開くことができます。スル
ーホールやSMDフットプリントを含む300を越えるコンポーネントパターンが標準の
PCBデザイン･システム･ライブラリには含まれています。ネットワークをインストー
ルすれば、同時に複数のユーザがライブラリにアクセスすることもできます。

また、Advanced PCBには、コンポーネント作成ウィザードがあります。このウィザ
ードは２、３の質問により、簡単な２ピンの抵抗から数百ピンのPGAまでのコンポー
ネント･フットプリントを作成します。

イイイインンンンテテテテリリリリジジジジェェェェンンンントトトト････ポポポポリリリリゴゴゴゴンンンン････ププププレレレレーーーーンンンン

塗りつぶしや格子状のポリゴン･プレーンを任意のレイヤーに配置することができま
す。この時、指定されたネットへの自動接続オプションをもたせることができます。
関連したデザインルールに従いながら自動的にコパーを”注いだり”、配置されたオ
ブジェクトの周囲をラッピングしたりできます。ポリゴンの形は、直線や円弧を用い
て定義でき、ポリゴンを定義した後で、頂点の追加、削除、移動ができます。ポリゴ
ンは、新たな障害物の周辺で何度でも定義しなおすことができます。
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内内内内層層層層ススススププププリリリリッッッットトトト････パパパパワワワワーーーー････ププププレレレレーーーーンンンン

内層パワープレーンを分割して、一つのパワー･プレーン･レイヤーを複数のネットで
共有することができます。分割パワープレーンは、デザインルールチェッカーでサポ
ートされています。

ササササーーーーママママルルルル････リリリリリリリリーーーーフフフフ････ココココンンンントトトトロロロローーーールルルル

ピンがポリゴンまたはパワー･プレーン･レイヤーに接続される場所では、サーマル･
リリーフを用いて、またはダイレクトに接続にすることができます。コンダクター(部
品のピンに接続する際の導体部分(パターン))の幅とエアーギャップをユーザーが定義
することができます。この場合、２または４個のエントリポイントの選択が必要にな
ります。

パパパパッッッッドドドド････ススススタタタタッッッッククククととととパパパパッッッッドドドド････リリリリムムムムーーーーババババルルルル

Advanced PCBのマルチレイヤーパッドはそれぞれの大きさや形状の属性をトップレ
イヤー（部品面）、ミッドレイヤー（1-14）、ボトムレイヤー（半田面）に割り付け
ることができます。ミッドレイヤーに接続されないマルチレイヤーパッドは、図面を
印刷またはプロットする時に、自動的に削除できます。

ブブブブラララライイイインンンンドドドド････ビビビビアアアアととととババババリリリリーーーードドドド････ビビビビアアアア

ビアは、基板全体を通過するものと任意の２層を接続するものがあります。ブライン
ド･ビアとバリードビアを、オートルータまたはマニュアル操作により指定すること
ができます。ビアは、レイヤーの色を用いてどのレイヤーと接続されているかを表し
ます。ブラインド･ビアとバリード･ビアともに、任意の２層のレイヤーを接続するこ
とができます。

円円円円弧弧弧弧

Advanced PCBの円弧（Arcs）の配置解像度は.001度です。信号の接続情報を保持し
ながら、円弧（Arcs）は任意のレイヤーに配置することができます。

ココココンンンンポポポポーーーーネネネネンンンントトトトのののの回回回回転転転転

コンポーネントやそれらのパッドの回転の解像度は.001度です。任意のセレクション
の回転でも角度の解像度は同じです。

各各各各種種種種ののののフフフフォォォォンンンントトトト

３種類の表示フォント（デフォルト、Selif、San selif）をサポートします。

フフフフォォォォトトトトププププロロロロッッッットトトトのののの自自自自動動動動生生生生成成成成

Gerber®プロットファイルの自動生成。アパーチャーファイルの自動生成。オンライ
ンでアパーチャーの編集。複数レイヤーのフォトプロット合成。プロットファイルは
指定されたフィルムサイズと境界設定に基づき自動的にパネライズできます。
Advanced PCBは生成したガーバーファイルを読み込み、表示できます。また、
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Advanced PCBのガーバーファイルのバッチロードは各レイヤーごとに生成されたガ
ーバーファイルを適切なレイヤーに割り当てて読み込みます。Gerber274Xフォーマッ
トに対するアパーチャーの組み込みもサポートしています。

ププププリリリリンンンンタタタタととととペペペペンンンンププププロロロロッッッッタタタタののののWindows ササササポポポポーーーートトトト

ドットマトリックスプリンタやレーザプリンタ、ペンプロッター、PostScript®出力は
すべて共通のプリントオプションからコントロールされます。Windowsでサポートさ
れる出力装置で出力することができます。プロットやプリントは、印刷シート上で自
動的にセンタリングされ合成した多層レイヤーとしてパネル化するかまた生成されま
す。

NCドドドドリリリリルルルルフフフファァァァイイイイルルルルのののの自自自自動動動動生生生生成成成成

ユーザ定義のツールファイルなしにNCドリル出力を自動的に生成することができま
す。必要なツールとそのツールの移動距離（メートルとインチの単位で）が一覧にな
ったレポートファイルが生成されます。効率よく穴あけ作業をするための高速ソーテ
ィング･アルゴリズムによりNCドリルファイルを生成します。

編編編編集集集集可可可可能能能能ななななドドドドリリリリルルルル････ドドドドロロロローーーーイイイインンンンググググ

ドリル描画は完全にユーザが編集可能な形式であり、それぞれの穴位置にはマーカが
付けられます。マーカにはコード化されたシンボルやアルファベット･コード
（A,B,C..）、割り付けられた穴の大きさが使用されます。

Windows デデデディィィィススススププププレレレレィィィィ････オオオオププププシシシショョョョンンンン

ProtelのPCBデザインシステムでは、Windowsでサポートされる24ビットカラーグラ
フィックカードとモニターをすべて使用することができます。VGAなどの標準のグラ
フィックアダプターでは、16色を越える色はディザを用いて色が合成されます。ズー
ムレベルは、32ビット･システム解像度を完全にサポートします。（精度±
0.0005mils）

DXFフフフファァァァイイイイルルルルののののイイイインンンンポポポポーーーートトトトととととエエエエククククススススポポポポーーーートトトト

DXFファイル(Auto CAD®)の読み込みや、PCBデザインをDXFファイルとして出力で
きます。マルチレイヤーDXFファイルもサポートします。

ECO シシシシスススステテテテムムムム

Engineering Change Order（ECO）システムによりレイアウト中に基板に施された物
理的変更を管理します。このシステムはPADS.ECOファイル･フォーマットと互換性
があります。

フフフフォォォォワワワワーーーードドドド、、、、ババババッッッッククククアアアアノノノノテテテテーーーーシシシショョョョンンンン

Advanced PCBは、ネットリストがロードされる毎にデザインファイルを更新しま
す。このようなフォーワードアノーテーションにより、スケマチックレベルの変更が
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自動的にPCBレイアウトに適用されます。完成したレイアウトのコンポーネントは部
分的に再びラベル付けがされデシグネータの割り付けが更新されます。

レレレレポポポポーーーートトトト

Advanced PCBからは、Bill of Materials(BOM)、Back Annotationファイル、NCドリ
ル、ボードアセンブリのための部品の位置を表すPick and Placeレポート 、Netlist
Statusレポート、エンジニアリング･チェンジ･オーダー(ECO)などの各種のレポート
を作成することができます。
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PCBワワワワーーーーククククススススペペペペーーーーススススのののの設設設設定定定定

座座座座標標標標シシシシスススステテテテムムムム
ステータスバーの左端に表示される座標は現在のワークスペースの原点に基づくカー
ソルの位置を示します。座標は、カレント･オリジンから単位の選択に応じてmilsまた
はmmで表わされます。Advanced PCBでは、原点をワークスペース内の任意の場所へ
移動できます。

アブソリュート･オリジン (原点のデフォルトの位置) はワークスペースの左隅です。

カカカカレレレレンンンントトトト････オオオオリリリリジジジジンンンンのののの設設設設定定定定

カレント･オリジンを設定するには、Edit  » Origin  » Setメニューを選択します。カー
ソルがクロスに変わり、カレント･オリジンに設定したい位置へカーソルを移動し、
マウスの左ボタンをクリックしてください。この位置が現在のカレント･オリジンに
なります。設定終了後、現在のカーソル位置でステータスバーの表示が、X:0mils
Y:0mils（またはX:0mm Y:0mm）となります。

カレント･オリジンをアブソリュート･オリジン(ワークスペースの左隅)に戻すには
Edit  » Origin  » Resetを選択してください。

デデデデザザザザイイイインンンンのののの精精精精度度度度
プリント基板は非常に高精度で製造されます。Advanced PCBでは、あらゆるPCBデ
ザイン作業に対応できる±0.001mils（.000001インチまたは.00025mm）の設計分解
能を持っています。ワークスペースの大きさは100インチＸ100インチです。

単単単単位位位位のののの切切切切りりりり替替替替ええええ

Advanced PCBではインペリアル（mils）とメトリック（mm）の単位を両方ともサポ
ートしています。単位を切り替えるには View  » Toggle Units メニューを選択、もし
くはショートカット･キーQを押してください。します。メトリックのスナップグリッ
ドが選択された場合、Advanced PCBはワークスペース座標やその他の寸法情報をミ
リメートル単位で表示します。これにより基板の配置がミリメートル単位ででき、新
しいライブラリーコンポーネントのピン間をミリメートルで設定できます。単位はい
つでも切替えることができます

ググググリリリリッッッッドドドド
Advanced PCBには３つのユーザー定義可能なグリッドシステムがあります。一つめ
は、ワークスペース内でオブジェクトの配置をコントロールするスナップ･グリッド
です。２番目は、オブジェクト同士が互いに引き込む範囲を定義するエレクトリカ
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ル･グリッド、３番目は、ワーク･スペースに表示されるビジブル･グリッドになりま
す。

ススススナナナナッッッッププププ････ググググリリリリッッッッドドドド

スナップ･グリッドは、カーソルの移動やプリミティブの配置を制限するワークスペ
ースの点の配列です。マウスを使用してカーソルをコントロールする場合(矢印のマウ
スポインタ)、カーソルがスナップグリッドの間を自由に動くことに気がつくと思いま
す。コンポーネントの配置やオブジェクトの選択などの編集機能が動作すると、クロ
スした細い線(クロスのマウスポインタ)が現れます。この細い線の移動が現在のスナ
ップグリッドを表わします。カーソルキーが使用されると、カーソルは常にグリッド
上を移動します。

è SHIFT を押しながらCURSOR KEYを押すと現在のスナップグリッドの10個分移
動します。

Document Optionsダイアログ･ボックス(Design » Options )のOptions Tab、またはメ
インツールバーのセットスナップグリッドボタンでいつでもグリッドを変更できま
す。(ショートカット; G)スナップ･グリッドを100milsに設定すると、カーソルは0.0イ
ンチ、0.1インチ、0.2インチ…の点だけを移動できます。スナップ･グリッドは0.001--
1000mils（0.0025--25.0mm）の間で設定できます。

スナップグリッドの設定は、ワークスペースのオブジェクトを配置できる所で定義さ
れます。スナップグリッドを適切に設定することは、良い基板設計を行なううえで重
要です。コンポーネントのピンピッチがまちまちだったりする場合、一般的な値を設
定してください。例えば、ピンピッチが100milsのコンポーネントを配置する場合、ス
ナップグリッドは50または100milsに設定します。適切なスナップグリッドでの作業
は、整然としたコンポーネントの配置を行う場合に役立つとともに、配線効率を良く
します。

エエエエレレレレククククトトトトリリリリカカカカルルルル････ググググリリリリッッッッドドドド

トラックやビアなどの電気的オブジェクトを簡単に配置できるようになります。
Advanced PCBには、エレクトリカルグリッドがあります。このグリッドは電気オブ
ジェクト（トラックやパッド、ビア）がその他の電気オブジェクトにマウスカーソル
を引き込む範囲を定義します。

ワークシート上で電気的オブジェクトが他の電気的オブジェクトのエレクトリカルグ
リッドに入った場合、移動したそのオブジェクトは固定されたオブジェクトのホット
スポットへ吸い込まれます。エレクトリカル･グリッドはDocument Optionsダイアロ
グ･ボックスのOptionsタブで設定します(Design » Options )。

è エレクトリカルグリッドはスナップグリッドを無効にします。これによりオフグ
リッドのオブジェクトへの接続が簡単に行なえます。

ビビビビジジジジブブブブルルルル････ググググリリリリッッッッドドドド

アイテムを移動したり配置したりする場合の目安として２種類のビジブル･グリッド
があります。これらのグリッドはそれぞれ独立に大きさを設定することができます。
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例えば、目の細かい方のグリッドだけを選択して荒さを変更したり、または一方をメ
トリックのビジブルグリッドとし他方をインペリアルのビジブル･グリッドとするこ
ともできます。

ビジブル･グリッドは、ワークスペースの背景に座標線（または点）を表示します。
ワークスペースをズームが近すぎたり遠すぎたりするとビジブル･グリッドが見えな
くなる場合があります。これはビジブル･グリッドの表示は、現在のズームレベルに
応じて行われるためです。

ググググリリリリッッッッドドドドのののの設設設設定定定定とととと単単単単位位位位

すべてのグリッドはDocument OptionsダイアログのOptionsタブによって設定しま
す。また、このタブによって単位の切り替えやエンジニアリング･チェンジ･オーダー
機能を有効ににすることができます。

すべてのグリッドとECO機能についてはOptionsタブによって設定されます。

エエエエンンンンジジジジニニニニアアアアリリリリンンンンググググ････チチチチェェェェンンンンジジジジ････オオオオーーーーダダダダーーーー

PCBを変更すると、その変更はfilename.ECOという特別なテキストファイルに書き込
まれます。ECOファイルに記録される変更には以下のものがあります。ネットに新し
く加えられたノード、ネットの変更された名前。コンポーネントの追加情報、単一の
ネットに加えられる２つ以上のネット情報、一つのネットを２つ以上に分割する情報
です。
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è Protelの.ECOファイルのフォーマットは、PADSの.ECOファイルと完全に互換性
があります。

レレレレイイイイヤヤヤヤーーーー
Advanced PCBは、レイヤーに基づく環境です。基板設計は、オブジェクトをレイヤ
ー上に配置することで行われます。レイヤーには、製造情報が作成されるフィジカル
レイヤー(物理的にトラックが配置されるレイヤー)と未接続の配線を表示するConnect
レイヤーのようなシステムレイヤーがあります。フィジカルレイヤーには、シグナル
レイヤーとインターナルプレーンレイヤー(電源、GND用内層)、シルクスクリーン、
ソルダーマスク(レジスト)、ペーストマスクレイヤーがあります。各レイヤーはそれ
ぞれ割り当てられたカラーで表示されます。

このようなマルチレイヤーデザインコンセプトが、Advanced PCBと他の多くの描画
アプリケーションやデザインアプリケーションとの違いです。デザイン内のレイヤー
はシングル･レイヤー･オブジェクトやカレント･レイヤーに配置されたオブジェクト
と同時に表示することができます。

è ProtelのPCBシステムは、レイヤーに基づく環境です。トラックの配置のという
ような設計作業は、レイヤー毎に行います。

Document OptionsダイアログのLayerタブで必要なレイヤーを有効にしてく
ださい。

レイヤーにアクセスできるようにするには、まず、レイヤーをアクセス可能状態にす
ることが必要です。レイヤーがアクセス可能な状態になるとレイヤーのLayer Tabがワ
ークスペースのボトムに表示されます。
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レイヤーをアクティブにするには:

1. Document Optionsダイアログ ･ボックスを選択してください (Design »
Options )。

レイヤーがレイヤータイプ毎にどのようにグループ化されているかがわかります。そ
れぞれのレイヤーにはチェックボックスがありその隣にレイヤー名があります。この
チェックボックスをマウスの左ボタンでレイヤーがオンとオフの状態になります。チ
ェックボックスの印はこのレイヤーがアクティブであることを示します。

è アクティブにしたレイヤーは、Advanced PCBで同じデザインを再度オープンし
たときにまたアクティブになっています。

2. レイヤーチェックボックスをクリックして必要なレイヤーをアクティブにしてく
ださい。

3. OKをクリックしてPreferencesダイアログボックスを閉じてください。

アクティブなレイヤーはドキュメント･ウィンドウの下側に表示されます。

カカカカレレレレンンンントトトト････レレレレイイイイヤヤヤヤーーーー

ある一つのワークスペースのレイヤーが、いつでもカレント･レイヤーになります。
ワークスペースのボトムにアクティブ･レイヤーのTabが表示されます。カレント･レ
イヤーのTabは最上部に表示されます。トラックやテキスト、フィル、シングルレイ
ヤーパッドなどのアイテムはカレント･レイヤーで配置できます。コンポーネントや
マルチレイヤーパッド、ビアなどのその他のアイテムは、カレント･レイヤーに関係
なく配置することができます。（移動や削除のための）選択は、レイヤーごとに行い
ます。これらの操作はカレント･レイヤーを変更することなく実行できます。

è レイヤータブをクリックしてレイヤーをカレント･レイヤーにしてください。また
は、＋キーまたは－キーを押してアクティブ･レイヤーの中でカレントレイヤーを
切り替えてください。*キーによってアクティブなシグナル･レイヤーのみを切り
替えることができます。

シシシシググググナナナナルルルル････レレレレイイイイヤヤヤヤーーーー

トラックの配置に使用するために16枚のシグナル･レイヤーがあります。これらのレ
イヤーに配置されるものはすべてPCBアートワークでソリッド銅箔パターンとしてプ
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ロットされます。トラックやその他のプリミティブ（エリアフィル、テキスト、ポリ
ゴンプレーン）をこれらのレイヤーに配置することができます。

Top

部品面信号レイヤー

Mid Layers

内部信号レイヤー（1--14に番号がつけられます）

Bottom

半田面信号レイヤー

イイイインンンンタタタターーーーナナナナルルルル････ププププレレレレーーーーンンンン

４枚のソリッド･コパー･ミッド･レイヤー（1--4の番号がつけられるインターナル･プ
レーン）を使用できます。ネットを割り付けてこれらのプレーンやコンポーネントピ
ンをインターナル･プレーンに同時にそして自動的に接続することができます。特別
なサーマル･リリーフ･パッドの形はインターナル･プレーン･アートワークをプロット
するときに任意に設定できます。インターナル･プレーンは、ネガティブ･イメージで
表示(プロット/プリント)されます。言い換えると、これらのレイヤーにプリミティブ
を配置すると配置されたところの銅箔はなくなります。

シシシシルルルルククククススススククククリリリリーーーーンンンン････オオオオーーーーババババーーーーレレレレイイイイ････レレレレイイイイヤヤヤヤーーーー

トップ･オーバーレイ、ボトム･オーバーレイ（シルクスクリーン）レイヤーは通常コ
ンポーネントのアウトラインやコンポーネントのテキスト（デシグネータやコメン
ト）を表示するために使用されます。Advanced PCBライブラリーコンポーネントで
は、アウトラインやコンポーネントテキストをデフォルトでトップ･オーバーレイに
割り付けます。コンポーネントがボトムレイヤーに置かれたり移動したりした場合、
これらのアイテムはボトムオーバーレイに表示されます。オーバーレイ･レイヤーに
は任意のテキストやその他のプリミティブを置くことができます。

メメメメカカカカニニニニカカカカルルルル････レレレレイイイイヤヤヤヤーーーー

寸法、位置あわせのターゲット、注釈などの基板製造･組み立ての詳細事項を４枚の
メカニカル･レイヤー(電気的な内容を含まない機械的なレイヤー)に記述することがで
きます。メカニカルレイヤーに記述された内容は他のレイヤーに追加し、出力(ガーバ
ーデータ作成やプリント/プロット)できます。

ママママススススクククク････レレレレイイイイヤヤヤヤーーーー

ソソソソルルルルダダダダーーーー････ママママススススクククク

フォト･ソルダー･マスクやシルクスクリーン･ソルダー･マスクのためにトップやボト
ム･マスクを使用できます。これらの自動的に作成されたレイヤーは、ウェーブソル
ダリングのマスクを作成したり、コンポーネントピンやビア以外をカバーするために
使用されます。Solder Mask Expansionデザインルールが適用される印刷やプロットを
おこなう時にこれらのマスクを拡張(パッドに対してマスクするサイズの設定)するこ
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とができます。Solder Mask Expansionルールについては、デザイン･ルールの項を参
照してください。これらのレイヤーはネガでプロットされます。

ペペペペーーーースススストトトト････ママママススススクククク

トップやボトム･マスクを表面実装デバイス（SMD）の基板の半田ペーストのフォト
またはシルクスクリーン･マスクにすることができます。Paste Mask Expansionデザ
イン･ルールを定義してこれらのマスクを拡張(パッドに対してマスクするサイズの設
定)することができます。詳しい内容についてはデザイン･ルール の項を参照してくだ
さい。これらのレイヤーは自動的に作成され、ネガでプロットされます。

ドドドドリリリリルルルル････レレレレイイイイヤヤヤヤーーーー

ドドドドリリリリルルルル････ドドドドロロロローーーーイイイインンンンググググ

基板の穴位置を記号(シンボル)で表わした図面は通常、基板製造用に使用されます。
各レイヤーのペアになったプロットは、ブラインド／バリード･ビア(埋め込みビア)を
指定するために必要になります。各穴位置にはシンボルがプロットされ、３種類のシ
ンボルを使用することができます。コード化されたシンボル(丸や四角などの図形)と
アルファベット･シンボル、割り付けられた穴のサイズの３種類です。シンボル表や
穴の大きさ、穴の番号をプロットすることができます

ドドドドリリリリルルルル････ガガガガイイイイドドドド

穴をすべてレイアウトにプロットします。パッド･マスターと呼ばれることもありま
す。各レイヤーのペアになったプロットは、ブラインド／バリード･ビア(埋め込みビ
ア)を指定するときに必要になります

そそそそのののの他他他他ののののレレレレイイイイヤヤヤヤーーーー

キキキキーーーーププププアアアアウウウウトトトト

このレイヤーは、コンポーネント配置や配線可能な範囲を指定するために使われま
す。例えば、基板の長方形をトラックやアークで作画した場合、すべてのコンポーネ
ントや配線はこの長方形の範囲内で収めるという定義になります。メカニカルオブジ
ェクトの”ノー･ゴー”領域(禁止領域)は、トラックやアーク、フィルを境界にして作
ります。コパーレイヤー(銅箔パターンとして生成されるレイヤー)にはすべてキープ
アウトが適用されます。基本的なルールとしてコンポーネントをキープアウトレイヤ
ーのオブジェクトの上に配置することができません。また配線を行う際もキープアウ
トレイヤーのオブジェクトを横切ることはできません。

ママママルルルルチチチチ････レレレレイイイイヤヤヤヤーーーー

マルチ･レイヤー上に配置されるオブジェクトは、出力(ガーバーデータ作成やプリン
トアウト、プロットアウト)の際、すべてのコパーエリア(銅箔エリア)にあらわれま
す。マルチレイヤーは通常スルーホールパッドやビアに使用されます。
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ココココネネネネククククトトトト

このオプションは、コネクション･ラインの表示をコントロールします。Advanced
PCBは、未配線の接続がどこにあってもコネクション･ラインをConnectレイヤーに作
成します。

DRC エエエエララララーーーー

このオプションは、DRCエラーの表示をコントロールします。

ビビビビジジジジブブブブルルルル････ググググリリリリッッッッドドドド

２つのビジブル･グリッドの表示をコントロールします。グリッドはドット、または
ラインで表示することができます。(Optionタブの設定)

Pad and Via Holes

パッドとビアの表示のコントロールを行います。ドラフトモードのビアとパッドを区
別するために、パッドホールは現在のパッドホール色（Preferencesダイアログ･ボッ
クスのColorsタブで設定します）で輪郭が描かれます。
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ワワワワーーーーククククススススペペペペーーーースススス････ププププリリリリフフフファァァァレレレレンンンンスススス
ユーザーが定義できるワークスペースのプリファレンスはPreferencesダイアログボッ
クス（Tools » Preferences メニュー）で設定されます。

Options タタタタブブブブ

Editing

Snap to Center

このオプションがチェックされている場合、オブジェクトを移動する際のカーソ
ルの位置は、フリーパッドやビアは中心位置へ、コンポーネントはリファレンス
ポイント(コンポーネント原点)へ、トラック･セグメントは頂点に、移動します。
このオプションがオフの場合はカーソル位置はマウスでクリックされた位置のま
まになります。

Extend Selection

このオプションがチェックされている場合、前のセレクションに追加できます。
チェックがオフの場合、現在セレクションされているオブジェクトは別のオブジ
ェクトがセレクションされると無効になります。
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Remove Duplicates

このオプションがチェックされている場合、出力データの準備中に特別なパスを
含みます。このパスは、出力データをチェックし、二重のプリミティブを削除し
ます。

Confirm Global Edit

グローバルチェンジで変更されるオブジェクトの数が表示され、グローバルチェ
ンジを中止する場合、ここでキャンセルできます。

Rotation Step

回転できるオブジェクトを移動する場合など、スペースバーを押すと反時計方向
に設定値だけオブジェクトを回転させることができます。シフトキーを押しなが
らスペースを押すと時計方向に回転できます。

Cursor Type

カーソルを小さな90度、45度のクロスや小さな45度のクロスに変更します。

Component Drag

このオプションにより、コンポーネントを移動するときにトラックをどのように
扱うかの設定をします。Connected Tracksオプションは、コンポーネントに接続
されたトラックを移動します。

Autopan

Style

このオプションがイネーブルに設定されている場合、カーソルがクロスカーソル
の状態でのオートパン(表示画面の自動切替え)が可能になります。オートパンに
は４つのオートパンモードがあります。

Re-Center – ウィンドウの端がカーソルの触れた場所を中心に表示が切り替わり
ます。また、基板上のカーソル位置が中心になるように表示を切り替えます。

Fixed Size Jump – Step Sizeで定義されるステップでパンを行います。SHIFTキ
ーを押しながらパンを実行するとShift Step Sizeで定義されるステップでパンが
実行されます。

Shift Accelerate – Step Sizeで定義されるステップでパンを行います。SHIFTキー
を押しながらパニング･アップするとShift Step Sizeで定義される最大のステッ
プ･サイズで実行されます。

Shift Decelerate – Shift Step Sizeで定義されるステップでパンを行います。
SHIFTキーを押しながらパニング･ダウンするとStep Sizeで定義される最小のス
テップ･サイズで実行されます。

Step Size

ウィンドウの端にカーソルが接触するたびに表示がシフトする値を指定します。
数値を現在の単位で入力します。
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Shift Step Size

シフト オートパン･オプションを使用している時に、ウィンドウの端にカーソル
が接触するたびに表示がシフトする値を指定します。数値を現在の単位で入力し
ます。

PCB

Online DRC

このオプションがチェックされている場合、デザインルールに違反することなく
オブジェクトがワークスペースに配置されているかどうか常時確認します。デザ
インルールはDesign Ruleダイアログボックス（Design » Rules メニュー）で定
義されます。

Loop Removal

このオプションがチェックされている場合、マニュアル配線中に配線がループし
た場合、自動的にトラックを削除します。(後から配線されたトラックが残りま
す)

Interactive Routing Mode

Ignore Obstacle – このオプションが選択されている場合、プリミティブをワーク
スペースの任意の場所に配置できます。ただしOn line DRCがチェックされてい
ると、クリアランス違反が警告されます。

Avoid Obstacle – このオプションが選択されている場合、クリアランスのデザイ
ンルールに違反しない場所にしかプリミティブを配置することができません。こ
の機能を利用すると、すでにオブジェクトが配置されてしまっている場合(すでに
途中まで設計が進んでいるような場合)にクリアランス違反を心配しないで配線で
きます。

Display

Convert Special Strings

.LAYER_NAMEや.PRINT_DATEのようなSpecial Strings(スペシャルストリング
ス)は、出力が生成される場合にもスクリーン上と同様に解釈されます。

Highlight in Full

このオプションがチェックされている場合、セレクションされたオブジェクトは
現在設定されているセレクションカラーで塗り潰し表示されます。チェックされ
ていない場合、セレクションされたオブジェクトは輪郭のみを現在設定されてい
るセレクションカラーで表示します。

Use Net Color For Highlight

このオプションがチェックされている場合、セレクションされたオブジェクトは
それらに割り付けられたネットのネットカラー（Change Netダイアログ･ボック
スで割り付けられた）でハイライト表示します。Highlight in Fullオプションとの
あわせて使用するのも良い方法です。
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Redraw Layers

このオプションがチェックされてる場合、レイヤーを切り替えた時に、切り替え
られたカレントレイヤーが最も手前(重ねられて表示されたレイヤーの１番上)の
状態で画面が表示されます。

è Redoraw Layerは、ALT+ENDショート･カット･キーで実行できます。

Single Layer Mode

このオプションがチェックされている場合、カレントレイヤーのみが表示されま
す。各レイヤーの出力(プリントアウトやデータ作成)をチェックする際に使用で
きます。カレントレイヤーがシグナルレイヤーならば、マルチレイヤーオブジェ
クトも表示されます。これらを画面上で確認する場合は"+"や"-"キーでレイヤーを
切り替え、ENDキーで画面の再描画をしてください。

Transparent Layers

このオプションがチェックされている場合、設定されたレイヤーカラーはトラン
スペアレント(透過)表示され、他のレイヤー上のオブジェクトと重なったオブジ
ェクトについては合成色(例 赤+青=紫)で表示されます。カレントレイヤーのオブ
ジェクトによって隠れて見えない他のレイヤーのオブジェクトを確認することが
できます。

Undo/Redo

スタックの大きさを設定して、どのくらい前の操作までアンドゥできるかを指定
します。スタックの大きさを０にするとアンドゥ･スタックは０になります。

Draw Order

Advanced PCBによりレイヤーが再描画される順番をコントロールできます。
Draw OrderボタンをおしてLayer Drawing Orderダイアログ･ボックスをポップ･ア
ップ表示してください。レイヤーが一覧にあらわれる順番に再描画されます。一
覧の最初のレイヤーは、スクリーン上で一番上にあらわれるレイヤーです。
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View タタタタブブブブ

Display Mode

ディスプレイ･モードを使用して、デザインオブジェクトがどのようにスクリー
ン上に表示されるかを設定します。モードには、それぞれのオブジェクトが塗り
つぶし表示されるFinalと、オブジェクトの輪郭のみが表示されるDraft、オブジェ
クトを表示させないHiddenがあります。設定方法としては各オブジェクトに対し
てそれぞれ表示モードを選択するか、All Final、All Draft、All Hiddenボタンを使
用すればすべてを同時に切り替えることができます。

Draft Thresholds

ここで設定された値より幅の狭いトラックは一本の細い線で表示されます。ま
た、幅の広いトラックについては、輪郭が表示されます。（Draftモードで表示さ
れる場合）

現在のズームレベルで文字が設定された値よりも多くのピクセルで表示される場
合、文字列として表示されます。また、少ないピクセルで表示される場合、アウ
トラインボックスに置き換えられます。これらのスレショルドは必要に応じて変
更できます。

Other

パッド番号やネット名、原点マーカーを表示します。パッド番号とネット名はズ
ームレベルが下がる(ズームアウトしていくと)と表示されなくなります



PCB Design with Advanced PCB

デデデデフフフフォォォォルルルルトトトト････ププププリリリリミミミミテテテティィィィブブブブ

Advanced PCBで使用されるオブジェクトのデフォルトはPreferencesダイアログの
Default Primitivesタブで設定することができます。

各デザイン･オブジェクトの設定の詳細についてはデザイン･オブジェクトの章を参照
してください。

è これらのデフォルトはオブジェクトを配置している際に、TABキーを押し値を変
更することによって変えることができます。ただし、このダイアログボックスで
Permanentオプションが有効の時はデフォルトの値は変更されません。



Creating, Opening and Saving PCB Documents

PCBドドドドキキキキュュュュメメメメンンンントトトトのののの新新新新規規規規作作作作成成成成、、、、オオオオーーーーププププンンンン、、、、ククククロロロローーーーズズズズ

EDA/Client全般のファイルの新規作成、オープン、保存についてはEDA/Clientセクシ
ョンのCreating, Opening and Saving Documentsの章を参照してください。この章で
はPCBの限定したインフォメーションになります。

新新新新規規規規PCBフフフファァァァイイイイルルルルのののの作作作作成成成成
Advanced PCB にはドキュメントを作成するためのウィザードPCBMakerが含まれて
います。このウィザードによっていくつかの標準的なボードのテンプレート、もしく
はユーザーのよって作成されたカスタム･テンプレートから任意のボードを選択する
ことができます。

PCBMaker ウィザードを起動するには、File » New  を選択し、Document Wizardsタ
ブをクリックします。PCBMakerサーバーがインストールされていない場合は
PCBMakerを起動できません。その場合、EDA/ClientセクションのWorking with EDA
Servers を参照し、PCBMakerサーバーをインストールしてください。

既既既既存存存存ののののPCBフフフファァァァイイイイルルルルののののオオオオーーーーププププンンンン
Advanced PCBは以下のフォーマットのPCBファイルを読み込むことができます。

· Advanced PCB (text and binary, all versions)
· Protel Autotrax files (ASCII text files)
· PADS-PCB and PADS 2000 (.ASC)※現在準備中
· PCAD (PDIF 5/6) ※現在準備中
· Tango Series II PCB files. ※現在準備中

è Protelバイナリ（*.PCB）またはProtel ASCII（*.PCB）以外のファイルをロードに
は、File » Import メニューを選択してください。ファイルを読み込む際にデータ
変換が行われ、Protel以外のファイルは保存する時に自動的にAdvanced PCBバイ
ナリフォーマットに変換されます。

PCBフフフファァァァイイイイルルルルののののセセセセーーーーブブブブ
アクティブファイルを新しい名前やフォーマットで保存するには、File » Save
Asメニュー(ショートカット；F,A）を選択してください。

è Advanced PCBの旧バージョンファイルを変換するにはエクスポート･オプション
を参照してください。
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Advanced PCB のののの作作作作業業業業

Advanced PCBサーバには、PCBエディタとPCBライブラリーエディタの２つのドキ
ュメントエディタがあります。これらのドキュメントエディタでの作業はとてもよく
似ています。オブジェクトの中からデザインを構築し、これらのオブジェクトをワー
クスペースに配置します。オブジェクトの配置や属性の編集、ワークスペースでの配
置や消去、その他の操作方法は、２つのエディタで共通です。要するに、エディタで
の作業は違ってもエディタの操作は同じということです。

PCBライブラリーエディタでは、コンポーネントやコンポーネントライブラリの作成
や編集、確認作業ができます。PCBエディタでは、プリント基板の作成や編集、確認
ができます。

これらのエディタはEDA/Clientの機能を使用しており、メニューバーやツールバー、
パネル、ステイタスバーがあります。各エディタには、ショートカットキーがあり、
Client BasicまたはClient Pascalで記述されたマクロを実行することができます。

ワワワワーーーーククククススススペペペペーーーーススススのののの構構構構成成成成
アプリケーションウィンドウやドキュメントウィンドウは他のWindowsアプリケーシ
ョンと同様に大きさの変更や移動ができます。詳細は、Windowsのユーザー･ガイド
を参照してください。

Viewメニューにより、Project ManagerやEditor Panel、Editor Tabs、Toolbar、Status
Barの表示のオン/オフを切り替えることができます。

Project ManagerとPCB Editor Panelはワークスペースのどちらかのサイドへ移動でき
ます。Editor Tabsはワークスペースのエッジへ移動できます。Toolbarも、ワークスペ
ースのエッジまたは、ワークスペース上へ移動できます。

表表表表示示示示位位位位置置置置のののの変変変変更更更更ととととワワワワーーーーククククススススペペペペーーーースススス内内内内のののの移移移移動動動動
各シート(PCBファイル)をオープンするとそれらのシート毎にウィンドウが開かれ画
面に表示されます。デザインを確認するためには このウィンドウ全体を見ます。デザ
インの表示は近つけたり、遠ざけたりできます。ワークスペースの表示を変更する方
法が、PanelやViewメニューにあります。
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パパパパネネネネルルルル････ミミミミニニニニ････ビビビビュュュューーーーアアアア
PCB Editor PanelのMiniViewerを使用して
ワークスペースの表示を変更します。点
線で囲まれたZoomBoxは、メインドキュ
メントウィンドウのズームレベルを表わ
します。(ボードの大きさとしてKeep Out
Layer、またはMechanical Layerのいずれ
か に 設 定 し て お く 必 要 が あ り ま
す)ZoomBoxのコーナーをクリック&ドラ
ッグしてメインドキュメントウィンドウ
のズームレベルを変更してください。
ZoomBox内をクリックしそれをドラッグするとメイン･ドキュメント･ウィンドウの表
示範囲が変化します。

Magnifierを使用してMiniViewerの基板の表示を拡大で
きます。Magnifierボタンをクリックし虫眼鏡のカーソ
ルをメイン･ウィンドウの基板の上に移動してくださ
い。Configureボタンにより拡大レベルを変更できま
す。また、虫眼鏡のカーソルを使用している時に
SPACEBARを押すと３段階の拡大レベルで切り替わり
ます。

View » Fit Document
このメニューを選択するとワークスペース内のオブジェクトをすべて表示されます。
（ショートカット；V,F）

View » Fit Board
このメニューを選択すると、基板の境界に沿って基板全体を表示します。（ショート
カット；V,D）

View » Area
このメニューを選択して、表示エリアを再定義してください。クリックして最初のコ
ーナーを指定しドラッグしてズーム･ウィンドウを作ります。（ショートカット；
V,A）

View » Around Point
このメニューを選択し表示エリアを再定義します。クリックして中心点を指定し、ド
ラッグしてズーム･ウィンドウを作ります。（ショートカット；V,P）

ZoomBox

board
outline
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View » Zoom Options
メニューのView » Zoom In を使用するとデザインは拡大表示されます。（ショートカ
ット；V,IまたはPAGEUP）

View » Zoom Out で、デザインは縮小表示されます。（ショートカット；V,Oまたは
PAGEDOWN）

è 拡大と縮小の段階を細かくしたい場合、PAGEUPまたはPAGEDOWNを押しなが
らシフトキーを押してください。

The View » Zoom Last メニューを使用すると前の表示に戻ることができます。（シ
ョートカット；V,L）

ワワワワーーーーククククススススペペペペーーーースススス内内内内のののの移移移移動動動動

ススススククククロロロローーーールルルル
Advanced PCBでは、スクロール･バーによりワークスペース内をスクロールできま
す。スクロール･バーにはスライディング･ボタンがあり、これをクリック＆ドラッグ
してワークスペースのスクロール･アップやスクロール･ダウン、左右の移動ができま
す。スライディング･ボタンの上や下をクリックするとワークスペースのスクロール
のステップが大きくなります。また、スクロールバーの各端部矢印をクリックすると
細かなステップでスクロールできます。

ママママニニニニュュュュアアアアルルルル････パパパパンンンンニニニニンンンンググググ
スクロール･バーを使用せずにワークスペースをパンするには、View » Panメニュー
（ショートカット；V,NまたはHOME）を選択してください。これにより現在のカー
ソル位置に画面の中央が切り替わります。カーソルの位置は移動しません。

矢印キーを使用して、ワークスペースのパニングが可能です。キーを押すごとにカー
ソルは１グリッドだけ移動します。シフト･キーを押しながら矢印キーを押すとカー
ソルは10グリッド分移動します。

オオオオーーーートトトト････パパパパンンンンニニニニンンンンググググ
マウスカーソルがクロスカーソル(十字カーソル)の状態のときにはオート･パニングが
行われます。配置や選択、オブジェクトの移動や削除のような“編集”型の操作を行
うとクロスカーソルになります。このカーソルを移動するには、マウスを移動したり
矢印キーでできます。カーソルがウィンドウのフレームにあたるように移動される
と、ワークスペースがパンします。Advanced PCBには４つのAuto Panモードがあり
ます。モードはPreferencesダイアログ･ボックスのOptionsタブで設定します。
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ブブブブララララウウウウズズズズ
PCB Editor Panelを現在のPCBの参照用に使用できます。
Nets,Componets,Net Classes,Component Classesの４つ
の参照モードがあります。

· Netまたは componentを参照すると、パネルの
MiniViewerには選択されたネットやコンポーネントが
表示されます。

· Zoomボタンを使用すると、メイン･ドキュメント･ウ
ィンドウ内の選択されたネットやコンポーネントへ移
動できます。

· 一覧からアイテムを選択すると、そのアイテムの情報
がStatus Barに表示されます。

ジジジジャャャャンンンンププププ
Edit » Jump メニュー（ショートカット；Ｊ）により、特
定のコンポーネントやネット、コンポーネント上のパッ
ド、テキスト文字列、基板の任意の位置にズームコマンド
やパンニング、画面のスクロールを行わず移動できます。

これらのオプションにより、目的の座標、またはオブジェクトにカーソルを移動する
ことができ、検索されるオブジェクトが現在の表示エリア外にある場合、画面は再描
画されます。再描画が実行されると、ターゲットはアクティブ･ウィンドウ内の中央
に表示されます。

ジャンプ･オプションには:

Absolute Origin

絶対原点へジャンプします。Advanced PCBでは、ワークスペースの左下隅が絶対原
点になります。（ショートカット；J,AまたはCTRL HOME）

Current Origin

現在の0,0原点へジャンプします。（ショートカット；J,OまたはCTRL+END）この原
点は、Edit-Origin-Setメニューを選択して指定できます。

New Location

指定された座標へジャンプします。Edit » Jump » New Location によりJump To
Locationダイアログ･ボックスをポップ･アップ表示します。XとYロケーション･テキ
スト･フィールドには現在のカーソル座標が示されます。カーソルは指定された座標
へジャンプします。（ショートカット；J,L）

Component

指定されたコンポーネントへジャンプします。Edit » Jump » Component により
Component Designatorダイアログ･ボックスがポップ･アップ表示されます。デシグネ
ータを入力しOKをクリックしてください。デシグネータがわからない場合、？を入力
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してENTERを押すかLEFT MOUSE(マウスの左ボタン)をクリックすると基板上に配置
されたコンポーネントをすべてスキャンします。カーソルは選択されたコンポーネン
トのリファレンス･ポイント(部品の原点)へジャンプします。(ショートカット;J、C)

Net

指定されたネットのピンへジャンプします。Net Nameダイアログ･ボックスへネット
名を入力しOKをクリックしてください。ネットがわからない場合、？を入力して
ENTERまたはLEFT MOUSE(マウスの左ボタン)をクリックすると基板上のすべてのネ
ットがスキャンされます。Nets Loadedダイアログ･ボックスから選択しOKをクリッ
クしてください。カーソルは選択されたネットの最も近いピンへジャンプします。
（ショートカット；J,N

Pad

指定されたコンポーネントの指定されたピンへジャンプします。Jump to Pin Number
ダイアログ･ボックスにコンポーネント･デシグネータとピン番号を入力しenterキーを
押してください。カーソルがピンの中心へジャンプします。（ショートカット；J,P）

String

カーソルが文字列へジャンプします。システムは３種類の検索を行ないます。

最初に大文字小文字と文字、長さが指定された文字列と合う文字列を検索します。

次に文字は同じで、文字数の多い文字列を検索します。

最後に大文字小文字を無視して同じ文字の文字列を検索します。

例えば、"component"は文字列"component"を最初に検索します。検索に失敗すると、
次に文字列"components"を探し最後に"CompONENT"を探します。文字列が見つかる
とカーソルは指定された文字列へ移動します。(ショートカット；J,S）

Error Marker

このメニューを選択すると、最初のDRCエラー･マーカへジャンプします。繰り返す
と、２番目、３番目…とジャンプしていきます。ルール違反を削除すると飛び先のリ
ストからエラーが削除されます。そうでなければ、繰り返すとドキュメント･ウィン
ドウ内を回り続けます。

Selection

このメニューを選択すると、最初のセレクションされたオブジェクトへジャンプしま
す。繰り返すと、２番目、３番目…とジャンプしていきます。さらに繰り返すと、現
在のドキュメント･ウィンドウ内のセレクションされたオブジェクトへのジャンプを
繰り返します。

è ジャンプ機能は、ポジション移動をズームインやアウトを行わずにできるため、
Advanced PCBでの作業が非常に効率的にできます。Jumpプロセスは、マウスを
使用しないで実行できます。ショートカットキーを使用して、ダイアログボック
スを表示してください。例えば、1000, 1000の場所へジャンプするには、JLショ
ートカットを押してください。Jump To Locationダイアログボックスが表示され
ると、X-Locationテキストボックスがハイライト表示されます。単純にXのロケー
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ションを入力してください。Y-Locationテキストボックスへ移動するには、TAB
を押してください。通常のWindowsダイアログボックスのように、TABはカーソ
ルをつぎのフィールドやボタンへ進め、SHIFT TABは戻します。新しいY-
Locationを入力して、キーボードのENTERキーを押してください。ダイアログボ
ックスはクローズし、カーソルが1000, 1000の位置にジャンプします。
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編編編編集集集集
Advanced PCBでは、オブジェクトを編集するには２つの方法があります。すなわ
ち、Changeダイアログ･ボックスで属性を変更する方法(プリミティブの色の変更のよ
うな)と、オブジェクトのグラフィック(絵柄)を変更する(フィルのサイズを変更するな
ど)方法です。

ワークスペース内のオブジェクトを編集するには、通常、その絵柄を見ながら編集す
ることがもっとも簡単です。これを行うには、オブジェクトをフォーカス.状態にする
必要があります。Changeダイアログ･ボックスでオブジェクトを編集するには、Edit
» Changeメニューを選択し、オブジェクト上でマウスをクリックしてください。

配配配配置置置置作作作作業業業業中中中中のののの変変変変更更更更
オブジェクトの属性は配置作業中に編集できます。オブジェクトがカーソル上に浮い
ている時に、TABキーを押してください。これによりオブジェクトのChangeダイアロ
グ･ボックスがポップ･アップ表示されます。配置中に編集ができることにより以下の
ようなメリットがあります。

· 属性に対する変更を、そのタイプのオブジェクトのデフォルトにすることができ
ます。これらの変更は、ADVPCB.DFTというデフォルト･ファイルに保存されま
す。注意－この方法によるデフォルトの設定は、Preferencesダイアログ･ボックス
(Tools » Preferences )の"Permanent"チェック･ボックスの設定によります。ここ
がチェックされている場合、これらの変更はデフォルトにはならず、カーソル上
のオブジェクトにのみ変更が適用されます。

· パッド･デシグネータのように数値に特定の意味合いを持つ(ピン番号のような)オ
ブジェクトは自動的にインクリメントとされます。

· 配置後にオブジェクトを編集する必要がありません。これにより設計のスピード･
アップができます。

配配配配置置置置さささされれれれたたたたオオオオブブブブジジジジェェェェククククトトトトのののの編編編編集集集集
Edit » Change メニューを使用して、配置されたオブジェクトの編集ができます。各
オブジェクトには編集可能な属性があります。属性の編集はそのオブジェクトのみに
ついて行うことも、また強力なグローバル編集オプションを使用してデザイン全体に
変更を反映することができます。

配置されたオブジェクトを変更するには、Edit » Change メニューを選択し、カーソ
ルをアイテムの上に移動しマウスの左ボタンをクリックしてください。（ショートカ
ット;マウスの左ボタンのダブル･クリック）カーソルの下に複数のオブジェクトがあ
る場合、セレクション･リストがポップ･アップ表示されます。

è 各オブジェクトの編集可能な属性については、デザイン･オブジェクト の項を参
照してください。また、グローバル編集についてはグローバル編集 の項を参照し
てください。
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ググググララララフフフフィィィィッッッックククク編編編編集集集集 – フフフフォォォォーーーーカカカカススススととととセセセセレレレレククククシシシショョョョンンンン
グラフィック編集を基本とした環境の有利な点は、スクリーンに表示されたオブジェ
クトを直接編集できることです。スクリーンに表示されたオブジェクトやオブジェク
トのグループを操作するには、今どのオブジェクトが選択されているか識別する必要
があります。これは、フォーカスまたはセレクションで行われます。

他のWindowsアプリケーションでの選択の意味合いとしては変更の前段階として、目
的のオブジェクトを指定する操作、という考え方です。典型的な例は、一つまたは複
数のオブジェクトをクリップ･ボードへコピーし他の場所へ貼り付ける作業です。選
択されたオブジェクトは、直接変更することができます。例えば、他のグラフィック
アプリケーションにおいても選択されたオブジェクトを移動したり形を変えたりする
操作は行われます。

他のWindowsアプリケーションと違い、Advanced PCBで、セレクション作業を行う
場合には、２つの独立した方法を使用します。これらの方法やセレクションやフォー
カスは、PCBの作成や編集でくり返し使用します。セレクションをこれら２つの独立
したプロセスに分割することで、Advanced PCBは上記のような単純なセレクション
では困難あるいは不可能なオブジェクトの複雑な変更を行うことができます。

è フォーカスとセレクションはワークスペースのオブジェクトの編集に使用される
別々の独立した方法です。それらの2つの方法は、Advanced PCBでは区別されま
すが、他のWindowsアプリケーションにおいては通常１つの操作にまとめられて
います。

フフフフォォォォーーーーカカカカスススス
Advanced PCBのデザイン･オブジェクトの上にカーソルを置いてこのオブジェクトを
マウスの左ボタンでクリックすると、オブジェクトがフォーカスされ表示が変わりま
す。これはWindows上でオープンされているウィンドウをクリックし、アクティブウ
ィンドウにフォーカスを切り替える方法と似ています。

フォーカスできるオブジェクトは一度に一つだけです。グラフィカル編集ハンドルが
やフォーカス･クロス･ヘアにより、現在どのオブジェクトがフォーカス中かがわかり
ます。例えば、フィルの上でマウスの左ボタンをクリックすると、リサイジング･ハ
ンドルが各コーナに表示され、回転ハンドルが中央付近に表示されます。ビアの上で
マウスの左ボタンをクリックすると、クロス･ヘアが表示されます。フォーカスを他
のオブジェクトへ移動するには、ワークスペースの何もないエリアでマウスの左ボタ
ンをクリックしフォーカスを解除してください。
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フォーカスされたオブジェクトにはハンドルが表示されます。

オブジェクトがフォーカスされている場合、そのオブジェクトの移動や表示の設定が
できます。例えば、四角のリサイジング･ハンドルをドラッグするとフィルの形を変
更できます。回転ハンドルをマウスの左ボタンでクリックするとフィルや文字列を回
転できます。

トラックをフォーカスすると、３つの編集ハンドルが表示されます。両端に一つずつ
と中央に一つです。端点のハンドルをクリックすると端点が移動します。また、中央
のハンドルをクリックすると元のトラックを２つに分割できます。

フォーカスされたオブジェクトの上をクリックすると、そのオブジェクトを移動でき
ます。オブジェクトの移動やドラッグの方法についての詳細は移動とドラッグの項を
参照してください。

ネネネネッッッットトトトをををを持持持持つつつつトトトトララララッッッッククククののののフフフフォォォォーーーーカカカカスススス

トラックをクリックするとフォーカス状
態になります。ネット名を持つトラック
をクリックすると、クリックされたトラ
ックはフォーカス状態になり、同じネッ
ト名を持つ他のオブジェクトはすべてハ
イライト表示されます。これにより、デ
ザイン上でネットのトレースが簡単に行
うことができます。この機能は、オブジ
ェクトがネット名を持っている場合に動
作します。

概概概概要要要要

フォーカスは、各オブジェクトに対して実行される多くの編集機能に必要な前作業で
す。フォーカスされたオブジェクトはクリップボード作業（Edit » Copy , Cut, Paste
もしくは Clear）に使用することができないことに注意してください。これらのクリ
ップボード機能はセレクションで動作します。

entire net is highlighted

focused track
segment
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セセセセレレレレククククシシシショョョョンンンン
セレクションはオブジェクトを操作する２つめの方法です。フォーカスと違い、セレ
クションは、それぞれのオブジェクトやオブジェクトのグループで使用することがで
きます。

è セレクションは、Edit » Copy, Cut, Paste 、Clearなどのクリップボード･プロセ
スをサポートします。

フォーカスと違い、セレクションはオブジェクトの編集ハンドルやクロス･ヘアを表
示しません。代わりに、オブジェクトはセレクションカラーで縁取られます(Tools »
Preferences )。

選択されたオブジェクトは、移動やグループ化、グループ化の解除、他のファイルへ
の出力、切り取り、コピー、他のウィンドウや同じウィンドウ内での別の場所への貼
りつけ、削除ができます。特別な Edit » Move プロセスにより、セレクションされた
グループを一度の操作で、移動させることや、回転させることができます。セレクシ
ョンは、オブジェクトをSelectedまたはUn-Selectedに限定してグローバルチェンジを
行うというように、Advanced PCBのグローバルな編集機能としても働きます。

è Advanced PCBの複雑なセレクション･モデルのキー機能により、以前セレクショ
ンに追加されたオブジェクトのセレクションを解除せずにマウスの左ボタンのク
リックが機能します。これにより、現在のセレクションに影響しないでいろいろ
な操作が可能になります。

Advanced PCBのセレクションは２つの方法で操作できます。1つめはセレクション状
態のオブジェクトが解除されるまでセレクション状態を残しておき、累積させて行く
方法です。その他はセレクションを累積させない方法です。累積させない方法の場合
は、Edit » Select メニューが選択されると、現在セレクション状態のオブジェクトに
ついては、セレクションが解除されます。セレクションを累積する方法は、
Preferencesダイアログ･ボックスのOptions Tabで切り替えられます。

セレクションを行うには:

· 各オブジェクトを直接セレクションする場合、SHIFT+マウス左ボタンを使用して
現在のセレクションへ各アイテムを追加(削除)してください。

· クリックアンドドラッグによる方法。

· Edit » Select 、または Edit » DeSelect サブメニューを使用する方法。

· Changeダイアログ･ボックスのSelectionチェックボックスを使用する方法。この
オプションは、Advanced PCBのグローバル編集機能を使用する際に、セレクショ
ン情報を現在のウィンドウ内の他のプリミティブへ反映できます。グローバル編
集についての詳細はグローバル編集 の項を参照してください。

è セレクションの操作をするときには、必要なオブジェクト以外はセレクションに
含まれていないことを確認してください。Edit-De-Select Allプロセス（ショート
カット；X,A）を使用して、現在のセレクションをクリアしてから新しいセレク
ションを作成してください。
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セレクションの操作を行った結果、意図した状態と違った場合、Edit » Undo  を
使用すれば前の状態に戻すことができます。

セセセセレレレレククククシシシショョョョンンンンのののの表表表表示示示示
セレクションされた状態はについては、Preferencesダイアログ･ボックスのDisplay
Tabで指定されたセレクションカラーで輪郭が表示されます。セレクションされた状
態の表示についてはいくつかの方法があります。

Draft Mode

プリミティブの表示方法がDraftモードの場合、セレクション状態のプリミティブ
はFinalモード(塗り潰し)で表示され、プリミティブの輪郭はセレクションカラー
で表わされます。この方法によってセレクション状態のプリミティブが見分け易
くなります。表示方法を設定するにはPreferencesダイアログ･ボックスの
Show/Hide Tabで行うことができます。

Highlight In Full

セレクションカラーでプリミティブ全体を表示させる場合、Preferencesダイアロ
グボックスのDisplay TabのHighlight In Fullオプションのチェックをオンにしま
す。

Use Net Color For Highlight

ネットについても設定されたネットカラーでハイライト表示できます。ネットカ
ラーの設定は、Change Netダイアログ･ボックスで行ってください。（パネルの
Browseモードをネットに設定し、ネット選択しEditボタンを押してください。）
このオプションを、Highlight In Fullオプションと組み合わせて使用すると有効で
す。Preferencesダイアログ･ボックスのDisplay TabのUse Net Color For Highlight
オプションをチェックしてください。

セセセセレレレレククククシシシショョョョンンンンのののの作作作作成成成成方方方方法法法法

各各各各オオオオブブブブジジジジェェェェククククトトトトをををを直直直直接接接接セセセセレレレレククククシシシショョョョンンンンすすすするるるる

直接セレクションする方法は、各オブジェクトを選択する場合、もっとも柔軟性のあ
る方法です。オブジェクトを一つずつ選択するには:

1. オブジェクト上にカーソルをあわせ、SHIFTを押しながらマウスの左ボタンをク
リックしてください。

アイテムが再描画され、セレクションカラー(Tools » Preferences )で輪郭が表示され
ます。この作業をくり返し行い、他のアイテムを現在のセレクションに追加できま
す。

ビープ音が鳴るか選択された表示が現れない場合は表示を拡大し(PGUPキー)、カーソ
ルが選択したいオブジェクトの上にあるかどうか確認してください。コンポーネント
を選択するには、カーソルをコンポーネントの外形の内側に置いてください。複雑な
コンポーネントの選択には多少時間がかかることがあります。

他のアイテムを現在のセレクションに追加するには:
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2. SHIFTキーを押しながらアイテム上でマウスの左ボタンをクリックしてくださ
い。

各アイテムのセレクションを解除するには:

3. SHIFTキーを押しながら選択されたアイテム上でクリックしてください。

セレクションが解除されると、アイテムは元の色で再描画されます。その他のセレク
ションされたアイテムは解除される（SHIFT+ マウスの左ボタン）までそのままの状
態です。または、Edit » DeSelect が実行されるまでそのままの状態です。

指指指指定定定定ののののエエエエリリリリアアアアをををを直直直直接接接接セセセセレレレレククククシシシショョョョンンンンすすすするるるる

直接セレクションする場合にあるエリアを指定しセレクションさせることができま
す。エリア内のオブジェクトをすべて選択するには:

1. マウスカーソルをオブジェクトがない場所に置いてください。

2. マウスの左ボタンを押したままの状態にします。

Status Barに"Select Second Corner"と表示されます。

3. マウスを対角線上にドラッグします。マウスの左ボタンを離したところまでの四
角のエリアがセレクションとして定義されます。

この四角のエリア内のオブジェクトだけが選択されます。選択されたオブジェクト
は、現在のセレクションカラーでハイライト表示されます。

4. この作業を繰返してこのセレクションを追加していくか、新しいセレクションを
作成してください。

è Preferencesダイアログ･ボックスのOptions TabのExtend Selectionオプションの
設定により、セレクションが追加可能か、そうでないか、が決定されます。

Select、、、、Deselectササササブブブブ････メメメメニニニニュュュューーーー
Edit » Select メニューによりエリアの内側または外側のすべてのアイテムや一つのレ
イヤーのすべてのアイテム、すべてのフリーなプリミティブ（コンポーネント以外の
アイテムすべて）を選択できます。フィジカルネットやオフ･グリッド･コンポーネン
ト･パッドについても選択できます。

SelectやDeSelectオプションを使用して複雑なグループを定義し、グループ単位の移
動、コピー、削除ができます。

è ショートカット･キーSを使用するとSelectサブ･メニューがポップ･アップ表示さ
れ、ショートカット･キーXを使用するとDeSelectサブ･メニューがポップ･アップ
表示されます。

SelectとDe-Selectメニューには、
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Inside Area

四角形のセレクション･エリアを定義することができます。エリアの中に完全に含ま
れるオブジェクトだけがセレクションされます。フリーパッドやビアについてはそれ
らのセンターがエリア内にある場合、セレクションに含まれます。

Outside Area

このオプションにより、セレクションの四角のエリア外のすべてが選択されます。セ
レクションの中に含まれるための条件はSelect » Inside Area  と同じです。セレクシ
ョンのための四角を定義する手順は、Inside Areaと同じです。

All

ドキュメント･ウィンドウ内に配置された全てを選択します。この中には表示されな
いモードのオブジェクトやレイヤーがオフになっているために見えないオブジェクト
も含まれます。

Connected Copper

このセレクションは、クリックした点と物理的な接続(トラックなどで接続された)に
あるプリミティブ（トラック、ビア、フィル）すべてを含みます。ただし物理的には
接続されていないコネクションラインで接続されているネットの部分は含まれませ
ん。

この機能を使用するには:

1. Edit » Select » Connected Copper （ショートカット；CTRL+HまたはS,P）を選
択してください。

"Choose an object on a signal layer"が表示されます。

2. 目的のネットのプリミティブの上にカーソルを置いてマウスの左ボタンをクリッ
クしてください。

選択した点に接続されたフィジカルネットが、セレクションカラーでハイライト表示
されます。

All On Layer

このセレクションには、現在のレイヤー上のプリミティブがすべて含まれます。マル
チレイヤーにあるアイテム（通常、マルチレイヤー･パッドやビア）はセレクション
から除かれます。

Free Objects

このセレクションでは、グループ（コンポーネントやポリゴン、ディメンション、コ
オーディネート）の一部に属さないオブジェクトがすべて選択されます。この機能
は、配線済み、もしくは途中まで配線されたパターンを剥ぎ取り、基板を配置された
状態に戻す場合に有効です。選択したくないオブジェクトが配置されたレイヤーをオ
フにすることでセレクションされる範囲を限定できます。
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All Locked

プリミティブやコンポーネントのもつ属性でLockedのチェックがオンのものは選択さ
れます。

Off Grid Pads

Edit » Select » Off Grid Pads を選択して現在のスナップ･グリッドに乗っていないコ
ンポーネント･パッドをすべて選択します。自動配線の前のこのオプションを使用し
てどのくらいのコンポーネント･パッドがグリッドに乗っていないかを調べることが
できます。Tools » Align Components » Move To Grid を使用してコンポーネントを
現在のスナップ･グリッドへ移動することができます。（ショートカット；A,G）

ウウウウィィィィザザザザーーーードドドドにににによよよよるるるる複複複複雑雑雑雑ななななセセセセレレレレククククシシシショョョョンンンン
Advanced PCBには、複雑なセレクションを作成するために使用されるQueryまたはセ
レクションWizardがあります。このWizardにより、ユーザーが定義したセレクション
条件に基づいて、異なるプリミティブ･タイプを同時に選択することができます。例
えば、全てのパッドやビアに対して穴径が0.5mm以下のものを選択、またトラック幅
が8mils以下、以上などの条件によっての選択ができます。

Edit » Selection Wizard メニューを選択してWizardを起動してください。Wizardが起
動しない場合、Query Wizard Serverをインストールする必要があります。インストー
ルについての詳しい説明は、EDA/Clientの項目を参照してください。

セセセセレレレレククククシシシショョョョンンンンにににに関関関関すすすするるるる作作作作業業業業
オブジェクトを選択し、それらをクリップボードにコピーしたり、またクリップボー
ドから貼り付けたりできます。Advanced PCBは、接続情報やプリミティブのレイヤ
ー属性などのPCBデータをサポートする特別なクリップボードを使用します。この
Protel内部のクリップボードは、各種のWindowsアプリケーション間でテキストなど
のデータをやり取りできるような標準のWindowsクリップボードとは違います。
Windows MetaFile(.WMF)グラフィック･フォーマットはAdvanced PCBクリップボー
ドではサポートされません。

Advanced PCBのクリップボードは、Windowsアプリケーションで使用されるクリッ
プボードと同じように使用できます。手順を以下に示します。まず、オブジェクトを
選択し、セレクションされたオブジェクトをクリップボードにカットまたはコピーし
ます。それからクリップボードの内容を目的の位置に貼りつけます。

ククククリリリリッッッッププププボボボボーーーードドドドをををを使使使使用用用用すすすするるるるととととききききのののの注注注注意意意意
· Advanced PCB にはクリップボード･リファレンス･ロケーション･オプションが

含まれています。リファレンス･ロケーションとは、CopyやCutを行った際にエン
トリーされた内容の参照座標になります。

· Edit » Copy は現在のセレクションをクリップボードへコピーします。

· Edit » Cut はワークスペースから現在のセレクションをクリアし、クリップボー
ドへコピーします。
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· Edit » Paste はクリップボードの内容をPCBドキュメントにPasteします。

· CopyやCutを行う場合には必要なアイテムだけがセレクションされているかどう
か確認してください。新規にセレクションを作成する場合には、一度、De-select
を行いセレクションをすべて解除してください。(ショートカット:X、A)

· SHIFT＋マウスの左ボタンによって現在のセレクションにアイテムを追加した
り、セレクションの解除を行うことができます。

· クリップボードに最後にCopy、もしくはCutされた内容が保持され、CopyやCut
を行う毎に上書きされます。

· Edit » Clear 現在のセレクションされているアイテムをクリップボードの内容に
関係なく、ワークスペースから削除します。(ショートカットt: CTRL＋DEL).

Special Paste Options

Paste Specialは、クリップボードからワークスペースにオブジェクトを貼り付ける際
に、それらのオブジェクトの属性をコントロールすることができます。

クリップボードの内容を貼り付ける際に、属性をコントロールするには:

1. Edit » Paste Special .を選択します。

Paste Special ダイアログ･ボックスが表示されます。Paste Spesialに含まれるオプシ
ョンとして:

Paste on current layer

このオプションがチェックされていない場合、トラックやフィル、アーク、シン
グル･レイヤー･パッドなどのシングル･レイヤー･オブジェクトのもつレイヤー属
性を保持し貼り付けられます。このオプションがチェックされている場合、すべ
てのシングル･レイヤー･オブジェクトはカレント･レイヤー(現在のレイヤー)に貼
り付けられます。

Keep net name

このオプションがチェックされている場合、ネット名を持つオブジェクトはすべ
て割り付けれたネット名を保持し、貼り付けられます。このオプションがチェッ
クされていない場合、ネット属性は"No Net"に設定されます。
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Duplicate designator

このオプションは、デザイン全体のコピーや貼り付けをする場合、"Copy"の文字
を付け加えずに貼り付けを行いますのでPCBパネル(面付け)の作成に使用できま
す。通常、このオプションがチェックされている場合、Keep net nameオプショ
ンのチェックはオフにします。

Add to component class

貼り付けられたコンポーネントを、コピー元と同じコンポーネント･クラスに追
加します。

2. オプションの設定終了後、OK をクリックしてください。

3. 貼り付ける位置を決め、マウスの左ボタンをクリックするか、Enterを押してくだ
さい。

Creating a Panel

Advanced PCBを使用して、PCBのパネル(面付け)を作成することができます。このパ
ネルは同じPCBの多面付けや、異なるPCBからパネルに作成することができます。パ
ネルを作成するには、まずクリップボードにPCBをコピーしてください。それから、
Paste Special機能を使用してPCBを必要な回数だけコピーしてください。ペーストの
時に正確に位置決めすることが難しい場合、ペーストがカーソル上で浮いている間(貼
り付け位置が確定されていない状態)にJump Locationプロセス（ショートカット；
J,L）を使用してください。これによりペーストの位置決めをマウスを使用しないで行
うことができます。ダイアログ･ボックス内のフィールドの移動は、TABキーで行いま
す。（SHIFT+TABでフィールドを戻ります）それから、OKをクリックする代わりに
ENTERを押してください。

Paste Array

Edit » Cut (またはCopy）を使用すると、クリップボード内の現在のセレクションの
コピーを配置することができます。Edit » Paste Array によりクリップボードの内容
のコピーを複数ワークスペースに配置できます。

クリップボードの内容を複数貼り付けるには:

1. Edit » Paste Special を選択します。 Paste Specialダイアログを必要に応じて設
定し、Paste Arrayボタンを押してください。Paste Arrayダイアログが表示されま
す。
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Placement Variables

Item Count

繰り返し配置を実行する回数です。例えば、4を入力すると現在のクリップボー
ドの内容が４回配置されます。

Text Increment

このオプションは、パッドやコンポーネントのデシグネータに使用します。これ
を1（デフォルト）に設定すると続き番号でデシグネータがインクリメントされ
ます。例えば、U1,U2,U3.....

１以外にもアルファベットや数値インクリメントもサポートします。クリップボ
ードへパッドをコピーする前に、パッドのデシグネータを設定してText
Incrementフィールドを設定すると、以下のようなタイプのパッド･デシグネータ
を配置することができます。 Numeric(1,3,5),Alphabetic(A,B,C),アルファベットと
数値の組み合わせ（A1,A2または1A,1BまたはA1,B1または1A,2A) 。

数値のインクリメントを行なうには、Text Incrementフィールドをインクリメン
トしたい値に設定してください。アルファベットのインクリメントを行なうに
は、Text Incrementフィールドに飛ばしたい数を設定してください。例えば、最
初のパッドに1AというデシグネータがありText IncrementフィールドにC（アル
ファベットの３番目の文字）が設定されている場合、パッドは1A,1D（Aの後３番
目の文字）,1G（Dの後３番目の文字）･･･となります。

Array Type

Circular

Circular Arrayで指定される回転やスペーシングの値を使用して、配置の繰り返し
が円状に配置されます。
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Linear

Linear Arrayで指定される値で、一定の間隔で直線的に配置されます。

Circular Array

Rotate Item to Match

配列のアイテムが、同じ角度だけ回転されます。

Spacing

それぞれの配置されたアイテム間の間隔の角度を指定します。Advanced PCBの
角度の分解能は0.001度です。

Linear Array

これらの値は、配置されている各アイテム間のXとYの距離を指定します。

2. アレイ配置の各設定が終了したらOKをクリックしてください。

ステータス･ラインに以下のメッセージが表示されます。

アレイ･タイプがLinearの場合“Select Starting Point For Array”

アレイ･タイプがCircularの場合“Select Center Of Circular Array”

3. 目的の位置にカーソルを移動し、ENTER、またはマウスの左ボタンをクリックし
てください。

円状にアレイ配置をする場合、"Select Starting Point For Array"と表示されます。
これにより、半径とアレイ配置の開始点を設定してください。

4. 目的の位置にカーソルを移動し、ENTER、またはマウスの左ボタンをクリックし
てください。

クリップボードの内容が複数貼り付けられアレイ配置が行われます。
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ググググロロロローーーーババババルルルル編編編編集集集集
1つのオブジェクト属性の編集が可能なように、Advanced PCBでは、同じ形式の他の
オブジェクトにこれらの編集結果を適用することができます。これは現行のコンポー
ネントを構成する他のオブジェクトや現行のドキュメント内のオブジェクトに対して
適用することができます。

さらに、グローバルな変更に条件を定義することもできます。例えば、変更が適用さ
れる条件を、全てのオブジェクトのなかから、セレクションされたオブジェクト、も
しくはセレクションされていないオブジェクトというように定義することができま
す。必要に応じて、変更の適用を複雑に実行することができます。

実質的にあらゆるオブジェクトの属性はグローバルに編集することができます。簡単
な例は、特定のコンポーネントのパッドのサイズの変更があります。その他には、特
定のネットのトラック幅の変更があります。これらのオプションは、グローバルな編
集で可能になります。グローバルチェンジを適用する条件は設計者の判断によって制
限されます。

è たくさんのグローバルチェンジオプションのために、始めはこの機能が何か複雑
に思えるかもしれません。しかし、グローバルチェンジを適用する基本は、一度
理解すれば簡単なことです。マスターすれば、この機能により、PCBの編集の作
業効率が飛躍的に向上します。

各オブジェクトのダイアログ･ボックスには、異なるオプションがあります。これ
は、オブジェクトのタイプにより属性が違うからです。

ググググロロロローーーーババババルルルル編編編編集集集集のののの方方方方法法法法
グローバルチェンジのオプションはいろいろなオブジェクトのダイアログ･ボックス
で違って表示されますが、使用される方法が同じです。この説明は、グローバル編集
の方法のアウトラインです。

Current Attributes

オブジェクトをダブルクリックすると、そのタイプのオブジェクトのChangeダイア
ログ･ボックスが表示されます。このダイアログ･ボックスには、オブジェクトの属性
の現在の設定や値が表示されます。

オブジェクトの属性を変更してください。

Global ボタンを押すとダイアログ･ボックスにAttributes,Attributes to Match By ,Copy
Attributeの３つの部分が表示されます。
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Global ボタンを押すとダイアログにグローバル編集のためのオプションが表示さ
れます。

Attributes to Match By

ダイアログの中央にはタイトルがAttributes To Match Byの列があります。Attributes
To Match Byではグローバル編集を行う場合の条件を定義します。

Attributes To Match Byの列には、各属性の選択フィールドやテキスト･フィールドが
あります。

選択フィールドには、Same（もしこの属性がターゲット･オブジェクトの属性と一致
した場合に変更を適用する）、Different（もしこの属性がターゲット･オブジェクトの
属性と一致しなかったら変更を適用する）、Any（デフォルト、属性の一致に関係な
く変更されます。）の３種類のオプションがあります。

è Match By の属性がすべてAnyに設定され、テキスト･フィールドがワイルドカー
ド(*)であれば、この種類のすべてのオブジェクトに対し、グローバル･チェンジ
が適用されます。

Match By の属性の組み合わせることによって、細かいグローバル編集の条件を定義す
ることがてきます。

Copy Attributes

ダイアログ･ボックスの3番目の列には、Copy Attributesがあります。Copy Attributes
にはそれぞれの属性のチェックボックスとテキスト･フィールドがあります。

この列でチェックされている属性がグローバルチェンジを行う際に条件の一致するオ
ブジェクトの属性に変更内容がコピーされます。またテキストフィールドの内容も条
件が一致するオブジェクトに対して同様にコピーされます。
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è Match ByとCopy fieldに含まれる属性はグローバルに編集することができます。

Change Scope

最後の設定するパラメータはチェンジスコープです。ここには、"All primitives"と"All
FREE primitives"の２つのオプションがあります。Advanced PCBでは、全てのプリミ
ティブのなかでオブジェクトのグループ(コンポーネントのような)に属さないプリミ
ティブは”FREE primitives”と認識されます。

ググググロロロローーーーババババルルルル････チチチチェェェェンンンンジジジジのののの例例例例
以下に、コンポーネントやプリミティブに実行されるグローバルチェンジのスコープ
に関する例を示します。

Example 1 – トトトトララララッッッッククククののののレレレレイイイイヤヤヤヤーーーーをををを変変変変更更更更すすすするるるる場場場場合合合合

トラック幅やセレクションの状態に関係なく全てのトップ･レイヤーのトラックをボ
トム･レイヤーに変更するには:

1. トップ･レイヤーのトラックのどれかをダブルクリックしてChange Trackダイア
ログ･ボックスを表示してください。

2. Layer属性をBottom Layerに設定してください。

3. Globalボタンをクリックして、グローバル編集パラメータを表示してください。

4.  Attribute to Match ByのLayerをSameに設定してください。その他の属性は、Any
に設定してください。

これで、Advanced PCBに、この変更を同じレイヤーのすべてのトラックに適用する
指示したことになります。

5.  Copy Attributesの列のLayer属性は自動的にオンになります。

これにより、Layer属性の変更をMatch Byの条件と一致するトラックすべてにコピー
することを指示したことになります。

6. Change Scope to All FREEプリミティブを設定してください。配線にアークがあ
る場合、 Incrude Arcsオプションをオンにしてください。OKをクリックして
ENTERを押してください。

編集された最初のトラックがまずBottomレイヤーに変更され、Confirm Global
Changeダイアログ･ボックスが表示されます。

7. YESをクリックしてグローバルチェンジを決定してください。

トップ･レイヤーのすべてのトラックがボトム･レイヤーへ移動されます。ENDキーを
押して、スクリーンを再描画してください。

特定のネットを他のレイヤーに変更したい場合、Edit » Select » Connected Copper
メニューを選択し、目的のネットのどこかをクリックしてください。次に、記述され
たグローバル編集プロセスを繰返します。ただしAttributes To Match ByのSelection属
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性をSameに設定しその他をAnyにしてください。選択されたネットだけがボトム･レ
イヤーへ移動されます。

Example 2 – ビビビビアアアアササササイイイイズズズズをををを変変変変更更更更すすすするるるる場場場場合合合合

基板上のすべてのビアのサイズを40milsに変更するには:

1. ビアのどれかをダブルクリックしてChange Viaダイアログ･ボックスを表示しま
す。

2. AttributesのDiameterフィールドに40と入力します。

3. Globalボタンをクリックします。

4. Atributes To Match ByすべてAny（すべてのビアが変更されます）に設定しま
す。

5. Copy Attributesで、Diameter属性が自動的にアクティブになります。

その他の属性はオフのままにしてください。

6. Change ScopeをAllプリミティブに設定しOKをクリックするかENTERを押して
ください。

最初に選択されたビアが変更後の直径で再描画されConfirm Global Changeダイアロ
グ･ボックスが表示されます。

7. OKをクリックします。

ドキュメント･ウィンドウのビアがすべて、新しく設定したサイズに変更されます。

Example 3 – ネネネネッッッットトトトををををロロロロッッッッククククすすすするるるる場場場場合合合合

オートルータが、あらかじめマニュアル配線された特定のネットを変更しないよう
に、そのネットをロックしてください。手順として、

1.  ネットを選択します。ネットを選択するには、Edit » Select » Connected
Copper  メニューを選択してネットをクリックしてください。

選択されたネットの全てのトラックがセレクション･カラーでハイライトされます。

2.  選択されたトラックのどれかをダブル･クリックします。

Change Trackダイアログ･ボックスが表示されます。

3.  Change Trackダイアログ･ボックスのLocked属性をオンにします。

4.  Global ボタンを押してください。

5.  Attributes To Match By、Selection属性をSameに設定します。

6. Change ScopeをAll FREEプリミティブに設定します。配線にアークがある場
合、Include Arcsオプションをオンにしてください。

グローバルチェンジは、グループ･オブジェクトの一部ではなくセレクションされた
トラック･セグメントすべてに適用されます。
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7. Copy Attributesで、Locked属性を設定します。

これにより、このトラックのLocked属性の変更をMatch Byの条件に合うトラックにコ
ピーします。

8. OKをクリックします。

選択された最初のトラックが変更され、Confirm Global Changeダイアログ･ボックス
が表示されます。

9. OKをクリックし、残りの選択されたトラックをロックしてください。

概概概概要要要要
この３つの例は、グローバルチェンジオプションの最も基本的な適用例です。うまく
適用すれば、この強力な機能により作業効率を向上することができます。しかし、こ
れらのオプションによって、予期しない結果が発生することがあります。特に、複雑
なセレクションを使用した場合に、発生する可能性が高くなります。

グローバルチェンジの条件などが定かでない場合、グローバル編集を使用して変更す
るよりもDe-Select All（X,A）を実行して、目的のオブジェクトを選んで設定してくだ
さい。グローバル･チェンジはMatch-Byによる条件が正しいかを確認してから行って
ください。またSelectionはグローバル編集を行う際の1つの条件として使うことがで
きます。

特に複雑な変更を実行する場合、EDA/Clientにあるオートバックアップ機能を使用し
てください。また必要に応じて、各種の操作をUndo/Redo機能により回復することが
できます。
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移移移移動動動動ととととドドドドララララッッッッググググ
オブジェクトを移動することは、オブジェクトとの接触を無視し、位置を変更するこ
とです。例えば、コンポーネントを移動する場合、パッドに接続されているトラック
は移動しません。コンポーネントをドラッグすると、トラックはパッドに接続された
ままです。Moveオペレーションはセレクションまたは各オブジェクトに実行されま
す。

è ドラッグの考え方は、オブジェクトがネットの一部である時のみ適用できます。

Move Shortcut
オブジェクトやセレクションを選択して移動するには:

1. カーソルを移動したいオブジェクトの上に置いてください。

2. マウスの左ボタンをクリックしてそのまま保持してください。

Status Barに移動されるものが表示されます。

3. オブジェクトを新しい場所へ移動してください。

Drag Shortcut
ネットの一部のオブジェクトをドラッグするには:

1. カーソルをドラッグしたいオブジェクトの上に移動してください。

2. マウスの左ボタンをクリックしてオブジェクトをフォーカスしてください。

オブジェクトがネットの一部の場合、ネット全体がハイライト表示されます。他のオ
ブジェクトがハイライト表示されない場合、このオブジェクトは同じネット属性のオ
ブジェクトを持っていないためドラッグすることができません。

3. オブジェクトの上でマウスの左ボタンをクリックしてください。

フォーカスされたオブジェクトのサイジング･ハンドルをクリックすると、オブジェ
クトをドラッグするのではなくハンドルをドラッグすることになります。フォーカス
されたオブジェクトの動作についての詳細は、フォーカス の項を参照してください。

4. オブジェクトを新しい場所へドラッグしてください。

Dragging a Component
コンポーネントをドラッグするには:   

1. Edit » Move » Drag メニュー(ショートカット；M,D）を選択してください。

2. ドラッグしたいコンポーネントの上をクリックして新しい場所へ移動してくださ
い。
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コンポーネントへ接続されたトラックやコンポーネントの下を通るトラックの動作
は、Preferencesダイアログ･ボックス（Tools » Preferences ）のComponent Dragオ
プションで設定されます。Edit » Move » Drag を使用して任意のプリミティブ･オブ
ジェクトをドラッグすることができます。

Selection のののの移移移移動動動動
1度セレクションされた個々のアイテムや複数のアイテムは1つのグループのように移
動することができます。Edit » Moveを選択するか、もしくはショートカットキーMに
よってMoveサブメニューが表示され、サブメニューには以下のものが含まれます。

Move Selection

このオプションを使用して、セレクションをブロックとして新しい場所へ移動できま
す。（ショートカット；M,L）このプロセスを起動すると、リファレンス･ポイントを
指定する必要があります。

Flip Selection

このオプションを使用すると、セレクションを垂直軸に沿ってセレクションを裏返す
ことができます。Move Selectionの間にXまたはYキーを押すとセレクションを裏返す
ことができます。（ショートカット；M,I）

Rotate Selection

このオプションを設定すると、Rotation Angleダイアログ･ボックスが表示されます。
回転角は、0.001度の解像度で入力してください。それから、回転の中心になるリフ
ァレンス･ポイントを設定してください。（ショートカット；M,O）

Move Selectionの間にSAPCEBARを押すとセレクションを回転することができます。
SPACEBARによる回転角はPreferencesダイアログ･ボックスのOptions Tabで設定し
てください。

Gerber出力では、フォトプロッターによってプリミティブの回転をサポートしていな
い場合があります。回転した四角は(四角い部品のパッドのような)、Advanced PCBで
Gerberファイルを作成する時に丸のアパーチャーを使用し、塗り潰されて表現されま
す。

個個個個々々々々ののののアアアアイイイイテテテテムムムムのののの移移移移動動動動
他のEdit » Move プロセスを行い場合に、あらかじめアイテムをセレクションしてお
く必要はありません。それはこれらのMoveプロセスは多くのアイテムが重なった密集
したレイアウトであっても指定されたアイテムにのみ作用するためです。

単独、もしくは複数のアイテムを移動／削除した場合に、画面上にそれらのプリミテ
ィブの“穴(跡)”が残ります。これはAdvanced PCBが移動／削除の間に画面をリドロ
ゥしないためです。画面をリドロゥする場合にはツール･バーのリドロゥ･ボタンをク
リックするかENDキーを押してください。

è コンポーネントやパッド、テキスト文字列のような回転できるオブジェクトは、
移動中にSPACEBARを押すと反時計方向に回転できます。時計方向に回転させる



Working in Advanced PCB

には、SHIFT+SAPCEBARを押します。回転の角度は、Preferencesダイアログ･
ボックスのOptionsタブで設定できます。

Break Track

Break Trackは、単一のトラック･セグメントを２つの接続されたセグメントに分割し
ます。トラックを分割するには:

1. Edit » Move » Break Track メニューショートカット；M,B）を選択してくださ
い。

"Choose a track"が表示されます。

2. カーソルをトラックの上に置いて、ENTERまたは、マウスの左ボタンを押してく
ださい。

トラックがドラフト･モードで表示されます。

3. カーソルを移動して分割ポイントを新しい位置へ移動してください。

4. 再び、ENTER、またはLEFT MOUSEを押して移動を完了してください。

再び"Choose a track"が表示されます。ドラッグ中にマウスの右ボタンをクリックする
かESCを１回押すと移動を中止することができます。表示は"Select track"のままで
す。

5. 他のトラックを選択するかESCを２回押す（またはRIGHT MOUSEをクリックす
る）とブレーク･トラック･モードを終了できます。

Polygon Vertices

ポリゴン･プレーンの形はポリゴンの頂点を移動することによって変更することがで
きます。詳細についてはデザイン･オブジェクトのPolygonを参照してください。

削削削削除除除除
Edit » Deleteメニューを選択すると、オブジェクトをPCBワークスペースから削除で
きます。Deleteは、CutやClearプロセスとは違います。CutやClearの場合まずオブジ
ェクトを指定してから動作を実行します。Deleteはまず削除コマンドを選択してか
ら、それからオブジェクトをクリックします。

è 削除する時にカーソルの下に複数のオブジェクトがある場合、ポップ･アップ･メ
ニューが表示され、どのオブジェクトを削除するかを選択できます。

Deleteはセレクションと関係ありません。例えば、現在のセレクションの一部のトラ
ックを削除する場合、現在のセレクションには影響しません。

削除したアイテムはEdit » Undo  (またはALT+BACKSPACE）を使用して復元するこ
とができます。一連のアイテムを削除した場合、最後に削除されたアイテムから逐一
復元されます。Edit-Redoは同様のファースト･イン･ラスト･アウト･ロジックを使用し
ます。RedoはUndo動作の反対です。
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è DELETEキーを押すとすぐにフォーカスされたオブジェクトが削除されます。
CTRL+DELETEキーを押すと現在のセレクションがすぐに削除されます。
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編編編編集集集集ののののヒヒヒヒンンンントトトト

編編編編集集集集のののの再再再再エエエエンンンントトトトラララランンンントトトト
Advanced PCBでは、プロセスを実行中に別のプロセスを実行できます。この機能
は、編集の再エントラントとして知られています。この機能は強力な機能で現在実行
中の動作を終了しないで別のオペレーションを実行できます。

編集の再エントラント機能により、作業をフレキシブルにできます。例えば、トラッ
クの配置を開始してから別のトラック･セグメントの削除ができます。この時、Place
Trackモードを出る必要がありません。単に、Deleteショートカット･キー（E,D）を
おして、必要なトラック･セグメントを削除し、 マウスの右ボタンをクリックするか
ESCを押してDeleteプロセスを終了してください。そして、Place Trackプロセスに戻
り、新しいセグメントの配置を行なってください。

è プロセスを実行中に他のプロセスにアクセスするには、ショートカット･キーを使
わなければいけません。

プロセスの途中でいくつかの他のプロセスを実行できます。他のプロセスを実行でき
る回数は、現在のプロセスが終了する前に要求され、ソフトウェア上に残っている終
了していないプロセスの回数に依存されます。グラフィックタイプのプロセスでは、
おおよそ１０のプロセスをネストすることができます。限界にくるとダイアログ･ボ
ックスが表示されます。

再再再再描描描描画画画画ののののキキキキャャャャンンンンセセセセルルルル
スクリーンの表示位置や大きさはいつでも変更でき、ワークスペースの内容は変更が
反映されて再描画されます。再描画が実行されている間にSPACEBARを押すと再描画
プロセスを終了させることができます。この再描画の時間を省くことですぐに他の他
のズームやスクロール作業に移ることができます。ソリッド･レイヤー表示オプショ
ン(トランスペアレント(透過)を使用しない)を使用して再描画時間を早くすることがで
きます。（Preferencesダイアログ･ボックスのOpstions Tab）Displayモード･オプシ
ョンをによって、すべてのプリミティブについてDraftに設定すると多少、再描画の時
間が短縮できます。（Preferencesダイアログ･ボックスのShow/Hide Tab）

è 現在のレイヤーのみ再描画するには、ALT+ENDショートカット･キーを使用して
ください。

ママママウウウウスススス････シシシショョョョーーーートトトトカカカカッッッットトトト
このガイドを読んでくるにつれて、マウスやキーボード･ショートカットを使用して
頻繁に使う操作をスピードアップしたり簡単にできることが分かると思います。例え
ば、P,Pを押すと、PlaceメニューのPadメニュー･アイテムを選択しないで、パッドを
配置することができます。マウスの左ボタンをENTERとして使用したり、マウスの右
ボタンをESCとして使用することでキーボードを使用しないで多くの操作を実行でき
ます。反対に、ダイアログ･ボックスでOkやCANCELをクリックする代わりにENTER



PCB Design with Advanced PCB

やESCを押すことができます。オブジェクトの配置中に新しくグリッドを設定する時
やセレクションの移動中にズーム･レベルを変更する時などのように、マウスをワー
クスペースから動かしたくない時にはキーボードを使用して操作する方法は非常に効
率的です。

è 任意の配置されたアイテムをダブルクリックすると、Chageダイアログ･ボックス
が表示され、属性を変更できます。

è アイテムを移動するには、単にマウスの左ボタンをクリック＆ホールドして、オ
ブジェクトをホールドしマウスを新しい位置までドラッグしてください。

è オブジェクトをデザインから削除するには、DELETEキーを押して削除したいオ
ブジェクトをクリックしてください。

ALT+F4を押してアプリケーション･ウィンドウを閉じたり、CTRL+TABを押してドキ
ュメント･ウィンドウを切替えたりする標準のWindowsショートカットをサポートし
ています。その他のショートカットはAdvanced PCBで指定されたものです。また、
ショートカット･キーのカスタマイズができます。ショートカット･キーのカスタマイ
ズについては、EDA/Clientの項目を参照してください。

WindowsのRecorder機能により指定したキーの組み合わせを操作に割り付けることが
できます。詳細についてはMicrosoft Windows Users Guideを参照してください。

キキキキーーーーボボボボーーーードドドド････シシシショョョョーーーートトトトカカカカッッッットトトト
キーボードによるショートカットを作成するには２つの方法があります。最初は、
Keyboard Shortcut Editorを使用する方法です。これらは、キーボード･ショートカッ
トとして知られています。これらによってプロセスを直接起動することができます。
例えば、CTRL+Gを押すとSnap Gridダイアログ･ボックスがポップ･アップ表示され、
スナップ･グリッドを変更することができます。

プロセスをメニュー･ショートカットを介してキーボードにより起動することができ
ます。サブ･メニューを持つ下線のついたメニュー･アイテムは、サブ･メニューをポ
ップ･アップ表示します。サブ･メニューをポップ･アップ表示しない下線の付いたメ
ニュー･アイテムはそのメニュー･アイテムに結び付けられたプロセスを起動します。
例えば、Pを押すと、Placeメニューがポップ･アップ表示され、次にVを押すとカーソ
ル上の現在のビアが表示されます。Tを押すとToolsメニューがポップ･アップ表示さ
れ続いてRを押すとAuto Routeサブ･メニューがポップ･アップ表示されます。

è 同じキーボード･キーがキーボード･ショートカットとメニュー･ショートカットに
割り付けられた場合、キーボード･ショートカットが優先されます。

メメメメニニニニュュュューーーー････シシシショョョョーーーートトトトカカカカッッッットトトト
A Tools » Align メニュー
B View » Toolbars サブメニュー
D Design  メニュー
E Edit  メニュー
F File  メニュー
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G Snap Grid ポップアップメニュー
H Help メニュー
J Edit » Jump サブメニュー
M Edit » Move サブメニュー
O Options ポップアップメニュー
P Place メニュー
R Reports メニュー
S Edit » Select サブメニュー
T Tools メニュー
U Tools » Unroute サブメニュー
V View メニュー
W Window メニュー
X Edit » DeSelect メニュー
Z Zoom ポップアップメニュー

キキキキーーーーボボボボーーーードドドド････シシシショョョョーーーートトトトカカカカッッッットトトト
L Document Option ダイアログのLayerタブ
Q 単位切り替え
CTRL+G スナップグリッドダイアログ
CTRL+H Edit » Select » Connected Copper
CTRL+P …
CTRL+Z Zoom
PGUP View » Zoom In
PGDN View » Zoom Out
CTRL+PGUP/PGDN Zoom maximum / minimum
SHIFT+PGUP/PGDN Zoom at 0.1 zoom step rate
HOME View » Pan
END View » Refresh
CTRL+HOME Jump Absolute Origin
CTRL+END Jump Current origin
CTRL+INS Edit » Copy
CTRL+DEL Edit » Clear
SHIFT+INS Edit » Paste
SHIFT+DEL Edit » Cut
ALT+BACKSPACE Undo
CTRL+BACKSPACE Redo
SHIFT+F4 重ねて表示
SHIFT+F5 並べて表示
* アクティブシグナルレイヤー切り替え
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+ or - アクティブレイヤー切り替え
F1 Help
UP, DOWN 1スナップグリッド移動(縦方向)
SHIFT+UP, DOWN 10スナップグリッド移動(縦方向)
LEFT, RIGHT 1スナップグリッド移動(横方向)
SHIFT+LEFT, RIGHT 10スナップグリッド移動(横方向)

特特特特別別別別ななななモモモモーーーードドドドにににに依依依依存存存存すすすするるるるキキキキーーーー
TAB 現在配置されているオブジェクトのダイアログ･ボッ

クスを開きます。オブジェクトの配置の時に属性の編
集ができます。タブ･キーを使用すると効率良く編集
をおこなうことができます。

SPACEBAR トラックの配置モードをStartとEndで切替えます。ア
イテムを移動中に反時計方向に回転します。（ステッ
プの幅はPreferencesダイアログ･ボックスで設定して
ください。）スクリーンの再描画をキャンセルしま
す。MiniViewerの拡大レベルを変更します。

SHIFT Autopan の 加 速 度 を コ ン ト ロ ー ル し ま す 。
（Preferencesダイアログでモードをセットしてくだ
さい。）

SHIFT+SPACEBAR トラック配置モードを切替えます。移動中にアイテム
を時計方向に回転します。

表表表表示示示示位位位位置置置置をををを変変変変更更更更ししししなななないいいいココココンンンンポポポポーーーーネネネネンンンントトトトのののの移移移移動動動動
現在作業している場所に特定のコンポーネントを配置する場合、そのコンポーネント
を見つけるためにスクロールやズームをしたくないことがあります。Edit » Move »
Move Component メニュー(ショートカット；M,C）を選択してください。カーソル
の下に何もないワークスペースのどこかをクリックしてComponent Designatorダイア
ログ･ボックスをポップ･アップ表示してください。デシグネータ･タイプが分かって
いる場合、それを入力しOKをクリックしてください。コンポーネントがスクリーン外
にある場合、表示がスクロールしてコンポーネントが表示されます。

Component Designatorダイアログ･ボックスがポップ･アップ表示された時、?を入力
してOKをクリックすることができます。これにより、Components Placedダイアロ
グ･ボックスがポップ･アップ表示され、ワークスペース内の任意のコンポーネントを
選択することができます。

アアアアンンンンドドドドゥゥゥゥととととリリリリドドドドゥゥゥゥ
Advanced PCBには、フル･マルチ･レベルのアンドゥとリドゥ機能があります。手順
は、スタックに似た配列に保存されます。Undoが選択されると、最後の操作が元に戻
されます。再び、Undoを選択すると、その前の操作が元に戻されます。
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Redo機能により、前のUndoと反対の動作が行われます。何かをアンドゥした時に、
その操作がメモリに保存されます。それから、リドゥを選択すると、最後のアンドゥ
操作が元に戻されます。

Editメニューで、UndoとRedoを選択した時にどんな動作が実行されるかを確認してく
ださい。Undoスタックは、Preferencesダイアログ･ボックスでStack Size to zeroを設
定するとクリアすることができます。
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デデデデザザザザイイイインンンン････オオオオブブブブジジジジェェェェククククトトトト

PCBを作成したり、ライブラリ･エディタで作業できるAdvanced PCBには、２つの基
本的な機能があります。すなわち、ワークスペースに配置されたオブジェクトを設計
する機能と、オブジェクトについてユーザーが作成や変更、保存、レポートを行なう
プロセス機能です。

Advanced PCBには、プリミティブ･オブジェクトとグループ･オブジェクト の２つの
タイプのオブジェクトがあります。プリミティブ･オブジェクトはAdvanced PCBで最
も基本的な要素で、トラックやパッド、ビア、フィル、アーク、文字列があります。
プリミティブで形成されデザイン･オブジェクトとして識別されるものはすべてグル
ープ･オブジェクトです。

ププププリリリリミミミミテテテティィィィブブブブ････オオオオブブブブジジジジェェェェククククトトトト

トトトトララララッッッックククク
Tracksは任意のレイヤーに配置することができます。幅は0.001milsから10000milsま
でです。Tracksを配置するには、Place » Track  メニューを選択するかオートルー
タ、またはPlacementToolsツールバーのTrackボタンを押すことで配置することがで
きます。また、Tracksによりポリゴンプレーンを作成することができます。

Advanced PCBのトラックの配置は、線を描くのにクリック＆ドラッグを行う描画ア
プリケーションとは違います。Advanced PCBでは、一連のトラックを多くのトラッ
ク･セグメントによってから形成します。トラックは、これらのセグメントを配置す
ることで形成されます。

トラックは信号ラインや、電源ラインの用いられます。

· Top (部品面) シグナル･レイヤー。
· 14の内層シグナルレイヤー 。
· Bottom (半田面) シグナル･レイヤー。

"Non-electrical"トラックを配置できるのは、以下のレイヤーです。

· ２枚のシルクスクリーン･オーバーレイ（通常、コンポーネント･パッケージの輪
郭を描くために使用されます。）

· ４枚の内層プレーン･レイヤー（ソリッド･コパー･プレーンにvoidを作成しま
す。）

· 自動配線や自動コンポーネント配置の基板の境界を定義するためのKeep Outレイ
ヤー。

· 機械的な情報を記述するための4つのメカニカル･レイヤー。
· ソルダー･マスクレイヤー、ペースト･マスクレイヤー。
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トラックは、レイヤーに関係なく同じ方法で配置や編集、移動、削除ができます。

è トラック（または、任意の他のプリミティブ）の配置や移動が行われると、それ
らは、現在のスナップ･グリッド上に配置されます。

デデデデフフフフォォォォルルルルトトトト････トトトトララララッッッックククク
デザイン･オブジェクトのデフォルトの属性は、Preferencesダイアログ･ボックスの
Default Tabで設定されます。

è 現在配置されているデザイン･オブジェクトの属性は、オブジェクトを選択してタ
ブ･キーを押すと設定することができます。PreferencesダイアログのDefaults Tab
で"Permanent"オプションが設定されていない場合、配置中の変更が新しくデフ
ォルトになります。

トトトトララララッッッッククククのののの配配配配置置置置
トラックはレイヤーに依存するオブジェクトです。トラック･セグメントを現在のレ
イヤーに配置するには、

1. Place » Track （ショートカット；P,TまたはPlacementToolsツールバーのTrack
ボタンをクリックしてください。）を選択してください。

"Choose start location"というプロンプトがStatus Barに表示されます。

2. もしそのような表示がされない場合、トラックの配置を始める前にレイヤーを選
択してください。アクティブなシグナル･レイヤーを切り替えるには、*を押すか
+か-を押してアクティブなレイヤーを切り替えてください。

3. マウスの左ボタンを一回クリック（またはENTERを押す）してトラックの始点を
定義してください。

è TABを押すと、配置中のトラックの属性を変更できます。

Statusバーにはトラックに割り付けられるネットと現在のセグメントの長さ、および
全体のトラックの長さが表示されます。

4. トラック･セグメントは任意の方向へドラッグできます。マウスの左ボタンをク
リック（ENTERを押す）して、トラックの最初のセグメントを終了してくださ
い。

5. カーソルを使用して、既存のトラックから伸びる新しいトラック･セグメントを
定義してください。 マウスの左ボタンをクリックするかENTERを押すとこのセ
グメントを定義できます。

è 失敗した場合、BACKSPACEを押すと最後に配置したトラック･セグメントを削
除することができます。

6. マウスの右ボタンをクリックして一連の接続されたトラック･セグメントを終了
してください。
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"Choose start location"がステータス･バーに表示されていることに注意してくださ
い。これにより、一連の接続されたトラックを終わって、新しく他のトラックの一連
のセグメントの配置を開始することができます。ただし、このときPlace » Trackを選
択する必要がありません。

7. トラックの配置を終了するには、ESCを押すかマウスの右ボタンを２回クリック
してください。

トトトトララララッッッックククク配配配配置置置置モモモモーーーードドドド
Advanced PCBには、７つのトラック配置モードがあります。モードにより、トラッ
クを配置するときにどのようにコーナーを作成するかが指定されます。

トラック配置モードには:

Any Angle

トラックをどのような角度でも配置できます。

90 Degree Horizontal Start and 90 Degree Horizontal End

トラックの配置を水平方向と垂直方向に限定します。

45 Degree Start and 45 Degree End

トラックの配置を45度と水平、垂直方向に限定します。

Arc Start and Arc End

トラックの配置をarcと水平、垂直線に限定します。

6つのトラック配置モード

90 degree 
horizontal end

45 degree start

45 degree end

Arc start

Arc end

90 degree 
horizontal start
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è トラックの配置中にSPACEBARを押すとStartとEnd配置モードを切り替えること
ができます。SHIFTキーを押しながらSPACEBARを押すと４種類のトラック配置
モードから切り替えることができます。

è 円弧の方向は、X/Yの比で決まります。最後の頂点からカーソルまでの距離がX方
向よりも小さい場合、アークはX軸の方向になります。Y軸方向の距離が短い場
合、アークはＹ軸の方向になります。カーソルを移動してアークの方向を変更す
ることができます。

配配配配線線線線ののののたたたためめめめののののトトトトララララッッッックククク配配配配置置置置
あるネット名を持つオブジェクトからトラックの配置をスタートすると、それはネッ
トを 配線することになります。配置したトラックは、パッドのネット名やそのネット
に適用されるデザイン･ルールを引き継ぎます。トラックを配置してネットを配線す
る作業には、多くの機能がサポートされています。

トトトトララララッッッッククククのののの変変変変更更更更
トラックは、個々に変更もでき、グローバルに変更もできます。Edit » Change メニ
ューを選択して既存のトラックを編集してください。トラックをクリックすると
Change Trackダイアログ･ボックスがポップ･アップ表示されます。編集可能なトラッ
クの属性として:

Width

トラック幅は、mils（.001インチ）かmmで設定することができます。設定範囲
は、0.001から10000milsです。

Layer

トラックは任意のレイヤーへ割り付けることができます。一般に、トラックは、
信号や電流を流すためにTop、Bottom、Midレイヤーに配置します。また、トラッ
クは電気的な目的以外にも配置することができます。例えば、コンポーネントの
外形を示すためにオーバーレイ（シルクスクリーン）･レイヤーに配置すること
ができます。また、トラックを利用して、通常反転してプロットされるレイヤー
（パワー･プレーンやソルダーマスク、ペーストマスク）に空きの部分を作成す
ることができます。

Net

プリミティブのNet属性は、Design Rule Checkerで使用され、プリミティブが正
しく配置されているかどうかを確認します。プリミティブがオートルータによっ
て配置された場合やマニュアル配置された場合、すでにネット名を持っているプ
リミティブと同じ場所に配置された場合、ネット名は自動的に割り付けられま
す。

Locked

すべてのプリミティブと同様に、トラックはワークスペースにロックされます。
場所が決定したトラックをロックするかオートルータに影響されてはならないト
ラックをロックしてください。
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Selection

トラックのセレクションや、セレクションの解除を行います。

Coordinates

トラックの始点と終点のX、Y座標を編集できます。これらの属性はグローバルに
編集することはできません。

è 配置作業中にトラックの属性を編集するには、TABキーを押してChange Trackダ
イアログ･ボックスをポップ･アップ表示してください。
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パパパパッッッッドドドド
Padsはマルチレイヤー、または各個別のレイヤーに配置することもできます。例え
ば、表面実装のコンポーネントやエッジ･コネクタはTopまたはBottomレイヤーに単一
のレイヤー･パッドを持っています。Padsの形には、円形や四角、角の丸い四角XとY
の大きさを１から10000milsに設定できる８角形があります。穴の大きさは０から
1000milsです。パッドの識別には、４文字までのデシグネータを使用します。

マルチ･レイヤー･パッドは、Topレイヤー、Midレイヤー、Bottomレイヤーに対してパ
ッドの大きさや形状を、パッドスタックを定義することで個別に割り付けることがで
きます。Padは、個々のフリー･パッドとして使用されるか、コンポーネントにおいて
他のプリミティブと組み合わせて使用できます。

デデデデフフフフォォォォルルルルトトトト････パパパパッッッッドドドド
デザイン･オブジェクトのデフォルト属性は、Preferencesダイアログ･ボックスの
Defaults Tabで設定します。

è 現在配置されているデザイン･オブジェクトの属性は、PlacemsntToolsツールバ
ーのボタンを押してから、またはPlaceメニューを選択してからTabキーを押して
設定してください。 Preferencesダイアログ ･ボックスの Defaults Tabで
"Permanent"オプションが設定されていない場合、配置作業中の変更は新しくデ
フォルトになります。

パパパパッッッッドドドドのののの配配配配置置置置
フリー･パッド（ライブラリ･コンポーネントにグループ化されていないパッド）はデ
ザインの任意の場所へ配置することができます。スルーホール･パッド（とビア）は
PCBの各信号レイヤーを接続できるマルチレイヤーのオブジェクトで、現在のレイヤ
ーの設定に関係なく配置することができます。シングル･レイヤー･パッドは任意のレ
イヤーに配置することができます。

パッドを配置するには:

1. Place » Pad を選択してください。（ショートカット；P,P、または、
PlacementToolsツールバーのPadボタンをクリックしてください。）

TABを押してデフォルトのパッド属性を配置作業中に変更できます。シングル･レイヤ
ー･パッドを配置する場合、*や+,-キーを押してレイヤーを変更することができます。
パッドを配置する場合、カーソル･クロス･ヘアーはパッド･センターにあります。

パパパパッッッッドドドド････デデデデジジジジググググネネネネーーーータタタタ
デジグネータ（通常コンポーネントのピン番号を示す）を使用して４文字までのラベ
ルをパッドにつけることができます。スペースは使用できません。必要であればデジ
グネータはブランクにすることができます。
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最初のパッドが数値のデジグネータを持っている場合、パッド･デジグネータは、配
置作業中自動的にインクリメントされます。最初のパッドを配置する前にデジグネー
タを設定するにはパッドがカーソル上で浮いている時にTABキーを押してください。

アルファベットや数値のインクリメントを１以外にするには、Paste Array機能を使用
します。パッドをクリップボードへコピーする前にパッドのデジグネータを設定し
Paste Arrayダイアログ･ボックスのText Incrementフィールドを設定することで、以下
のようなパッド･デジグネータの系列を配置することができます。

数字 (1, 3, 5)

アルファベット (A, B, C)

数字とアルファベットの組み合わせ (A1, A2, or 1A, 1B, or A1, B1 or 1A, 2A, etc.).

数値をインクリメントするには、Text Incrementフィールドにインクリメントしたい
量を設定してください。アルファベットをインクリメントするには、スキップしたい
文字の数をあらわすアルファベットをText Incrementフィールドのに設定してくださ
い。例えば、最初のパッドが1AというデジグネータでText IncrementフィールドにC
が設定されていると、パッドには、1A,1D（Aの３文字後）,1G....というデジグネータ
が付きます。

パパパパッッッッドドドドのののの変変変変更更更更
フリー･パッドもコンポーネント･パッドもそれぞれグローバルに編集することができ
ます。パッドを編集するには、Edit » Change  メニューを選択してください。Status
Barに"Change Any Object"というプロンプトが表示されます。パッドをクリックして
Change Padダイアログ･ボックスを表示してください。ダイアログ･ボックスには、
Attributes、Pad Stack 、Advancedという３つのタブがあります。

Attributes Tab

このタブには一般的なパッドの属性が含まれます。

Use Pad Stack

異なるレイヤーに異なる形のパッドが必要な場合、Use Pad Stackオプションを
チェックしてください。このオプションをチェックすると、Pad Stack Tabが使
用可能になります。

X Size

水平（X）方向のパッドの大きさを設定します。1-10000milsの範囲で設定してく
ださい。

Y Size

垂直（Y）方向のパッドの大きさを設定します。1-10000milsの範囲で設定してく
ださい。

è X SizeとY Sizeをそれぞれ変えて非対照のパッド形状を定義できます。
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Shape

パッドの形状には、RoundedやRectangular、Octagonalがあります。形状はXとY
のサイズの設定を変更して操作します。コンポーネントには、異なる形のパッド
をいくつでも設定することができます。

Designator

パッドのラベルは通常コンポーネント･ピン番号です。フリー･パッドはデシグネ
ータをつけることができます。また、デシグネータは何も設定しないこともでき
ます。

Hole Size

この属性には、製造時にパッドに明けられる穴の直径を、milsまたはmmで指定し
ます。SMDパッドまたはエッジ･コネクターには、０を設定してください。穴の
大きさは０から1000milsの範囲で設定しパッドより大きいサイズも設定できま
す。

è 穴の大きさは、現在のスナップ･グリッドの単位以外の単位で入力することができ
ます。このように入力された大きさは自動的に現在の単位に変換されます。

Layer

パッドは任意のシングル･アートワーク･レイヤーまたはスルーホール･コンポー
ネントのマルチレイヤーに割り付けることができます。SMDパッドは、普通Top
レイヤーかBottomレイヤーに割り付けられます。新しいレイヤーを選択するに
は、Layerボタンをクリックしてセレクション･バーを使用可能なレイヤーの間で
スクロールしてください。

Rotation

Advanced PCBは、パッドの回転をサポートしています。角度の解像度は0.001度
です。

X-Location

Current原点からのパッドのXの位置です。

Y-Location

Current原点からのパッドのYの位置です。

Locked

パッドはワークスペースでロックすることができます。位置が決まっているパッ
ドをロックしてください。

Selection

パッドのセレクションとセレクションの解除を行います。

Pad Stack Tab
マルチ･レイヤー･パッドは、Topレイヤー、Mid1-14レイヤー、Bottomレイヤーに
独立にサイズや形状の属性を割り付けることができます。パッド･スタックを作
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成したい場合、Attribute TabのUse Pad Stackオプションをイネーブルにしてくだ
さい。

Advanced Tab
Net

プリミティブのNet属性は、Design Rule Checkerで使用され、プリミティブが正
しく配置されているかどうかを確認します。ネット･リストがロードされると、
使用されたコンポーネント･パッドに自動的にネット名が割り付けられます。

Electrical Type

デフォルトでは、すべてのパッドにステータスはLoadに設定されます。ネットが
Daisyチェーン･トポロジーの一つを使用する場合、SourceとTerminatorの設定が
使用されます。ネットへトポロジーを適用することについての詳細は、ネット･
トポロジー またはRouting Topology Ruleの項を参照してください。

Plated Hole

パッドには、plated(スルーホール)とnon-plated(ノンスルーホール)があります。
両方のタイプのパッドがデザインに存在する場合、non-platedの穴は、NCドリル
ファイルのplatedホールと違うツールを使用して穴が明けられます。詳細は、NC
ドリル の項を参照してください。

ビビビビアアアア
２つのレイヤーに配置されたトラックを接続する場合、ビアはレイヤーからレイヤー
へ信号を送るために配置されます。ビアは、丸いパッドのようなもので、通常スルー
ホールとして基板製作時に扱われます。

ビアには、マルチレイヤー、ブラインド、バリードのビアがあり２から10000milsの
直径を設定できます。ビアはPlacementToolsツールバーのViaボタン、Place » Viaメ
ニュー、もしくはトラック配置の際の自動ビア機能によって配置されます。穴の大き
さは0から1000milsを使用できます。

ビビビビアアアア････タタタタイイイイププププ
Advanced PCBのビアには、マルチレイヤー、ブラインド、バリード･ビアがありま
す。マルチ･レイヤー･ビアはTopレイヤーからBottomレイヤーへ貫通しすべての信号
レイヤーを接続します。ブラインド･ビアは基板の表面から内部のレイヤーへ接続さ
れます。バリード･ビアはある内部レイヤーから他の内部レイヤーへの接続を行いま
す。

ブブブブラララライイイインンンンドドドド････ビビビビアアアアととととババババリリリリーーーードドドド････ビビビビアアアア

ブラインド･ビアやバリード･ビアを使用する前に、製造者がサポートできるレベルの
ビアを使用することが重要です。ほとんどの製造者は、レイヤー･ペアにおいてのブ
ラインド･ビアやバリード･ビアをサポートしています。この技術を使用して、多層基
板は両サイド基板の組みとして製造されます。これにより、ブラインド･ビアやバリ
ード･ビアは両サイド基板の表面の間を接続します。接続された基板表面がレイヤー
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のペアになります。この場合、ブラインド･ビアやバリード･ビアは以下のレイヤーの
組み合わせで使用できます。

Top layer – to – Mid layer 1 (blind)

Mid layer 2 – to – Mid layer 3 (buried)

Mid layer 4 – to – Mid layer 5 (buried)

Mid layer 6 – to – Mid layer 7 (buried)

Mid layer 8 – to – Mid layer 9 (buried)

Mid layer 10 – to – Mid layer 11 (buried)

Mid layer 12 – to – Mid layer 13 (buried)

Mid layer 14 – to – Bottom layer (blind)

また、Advanced PCBでは、任意の２つのレイヤー間でブラインド･ビアやバリード･
ビアを使用できます。

è ブラインド、またはバリードを使用する場合にはあらかじめ基板製造業者がサポ
ートしているかどうかチェックする必要があります。

デデデデフフフフォォォォルルルルトトトト････ビビビビアアアア
デザイン･オブジェクトのデフォルト属性は、Preferencesダイアログ･ボックスの
Defaultsタブで設定してください。

è 現在配置されているデザイン･オブジェクトの属性は、PlacemsntToolsツールバ
ーのボタンを押してから、またはPlaceメニューを選択してから、Tabキーを押し
て設定してください。Preferencesダイアログ･ボックスのDefaults Tabで
"Permanent"オプションが設定されていない場合、配置作業中の変更は新しくデ
フォルトになります。

ビビビビアアアアのののの配配配配置置置置
ビアは、オートルータや自動ビア機能、またはマニュアルで配置されます。

Autorouter Vias

オートルータ･ビア･パラメータの定義は、Routing Via Rulesを使用して行いま
す。デザイン･ルールについての詳細は、デザイン･ルールの項を参照してくださ
い。

Auto Via Feature

トラックを配置している際に、*キーを使用して他のシグナル･レイヤーに切り替
えると、配置されているトラックに対してビアは自動的に追加されます。

Manually Placed Vias

ビアをマニュアルで配置するには、Place » Viaメニューを選択してください。現
在のデフォルトで設定されているビアがカーソル上に表示されます。クリックし
てワークスペースにビアが配置されます。
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ビビビビアアアアのののの変変変変更更更更
ビアを編集するには、Edit » Change メニューを選択しビアをクリックしてくださ
い。Chage Viaダイアログ･ボックスがポップ･アップ表示されます。このダイアログ･
ボックスには、AttributesとAdvanced という２つのタブがあります。

Attributes Tab

Diameter

ビアの直径は、２から10000milsの範囲で設定できます。

Hole Size

ビアで使用する穴の直径を設定してください。０から1000milsの範囲で設定でき
ます。

Layer Pair

必要なレイヤーのペアを選択してください。任意の２つのレイヤーの間のブライ
ンド･ビアやバリード･ビアが必要な場合、Blind & Buried オプションを選択して
ください。Blind & Buried (Any)ビアのスタートとエンドレイヤーはAdvancedタブ
で指定されます。

è ブラインド･ビアとバリード･ビアの使用については、基板製造者に確認の上に使
用してください。

X, Y Location

ビアの座標を編集することができます。これらの変更は、他の配置されたビアに
は影響しません。

Locked

他のプリミティブと同様に、ビアはワークスペースにロックできます。位置が確
定したビアをロックするかオートルータに影響されてはならないビアをロックし
てください。

Selection

ビアのセレクションや、セレクションの解除を行います。

Advanced Tab

Net

プリミティブのNet属性は、Design Rule Checkerで使用され、プリミティブが正
しく配置されているかどうかを確認します。ネット名はプリミティブがオートル
ータによって配置された場合、マニュアル配線された場合、すでにネット名を持
っているプリミティブと同じ位置に配置された場合、自動的に割り付けられま
す。

Start Layer

Start Layerはビアが始まる最上部のレイヤーです。Attributes TabのLayer Pairオ
プションをBlind & Buried (Any)に設定してこの機能を使用してください。
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End Layer

End Layerはビアが終わる最下部のレイヤーです。Attributes TabのLayer Pairオプ
ションをBlind & Buried (Any)に設定してこの機能を使用してください。

フフフフィィィィルルルル
フィル(またはエリア･フィル) は、任意のレイヤーに配置できる四角形です。シグナ
ル･レイヤーに配置されると、銅箔で塗り潰されたエリアになり、シールディングや
大電流を流すために使用されます。いろいろなサイズのフィルを組み合わせて不規則
な形のエリアをつくることができます。それらは、トラックと組み合わせや、アー
ク･セグメントと組み合わせが可能で、デザイン･ルール･チェックでは電気的な接続
として認識されます。

フィルは、ノン･エレクトリカル･レイヤーにも配置することができます。例えば、
Keep Outレイヤーにフィルを配置して自動配線や自動コンポーネント配置の禁止エリ
アを示すことができます。PowerプレーンやSolder Mask、Paste Maskレイヤーにフ
ィルを配置してレイヤーに空白領域を作成することができます。

デデデデフフフフォォォォルルルルトトトト････フフフフィィィィルルルル
デザイン･オブジェクトのデフォルト属性は、Preferencesダイアログ･ボックスの
Defaults タブで設定してください。

è 現在配置されているデザイン･オブジェクトの属性は、PlacemsntToolsツールバ
ーのボタンを押してから、またはPlaceメニューを選択してすぐにTabキーを押し
て設定してください。Preferencesダイアログ･ボックスのDefaults Tabで
"Permanent"オプションが設定されていない場合、配置作業中の変更は新しくデ
フォルトになります。

フフフフィィィィルルルルのののの配配配配置置置置
1. Place » Fillメニューを選択してください。

ステータス･バーに"Select First Corner"と表示されます。

2. 目的の位置カーソルを移動しマウスの左ボタンをクリックします。

マウスをドラッグして対角線上の反対のコーナーにカーソルを移動します。

3. マウスの左ボタンを押して２番目のコーナーを定義してください。

フィルの配置を続けるか、 マウスの右ボタンをクリックしてフィルの配置を終了して
ください。

è フィルのネット名は、フィルを配置する際の最初のコーナーに、あらかじめ配置
されていたオブジェクトのネット名が割り付けられます。
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フフフフィィィィルルルルのののの変変変変更更更更
フィルを編集するには、Edit » Change メニューを選択しフィルをクリックしてくだ
さい。Change Fillダイアログ･ボックスがポップ･アップ表示されます。

Layer

フィルが現在、配置されているレイヤーです。フィルは、ワークスペース内の任
意のレイヤーに割り付けることができます。

Net

プリミティブのNet属性は、Design Rule Checkerで使用され、プリミティブが正
しく配置されているかどうかを確認します。ネット名はプリミティブがオートル
ータによって配置された場合、マニュアル配線された場合、すでにネット名を持
っているプリミティブと同じ位置に配置された場合、自動的に割り付けられま
す。

Rotation

Advanced PCBは、フィルの回転をサポートしています。角度の解像度は0.001度
です。

è Gerberの作成では、フィルの回転はサポートされていません。回転されたフィル
は丸のアパーチャーで塗り潰されて描画されます。

Coordinates

フィルのコーナーの座標を編集することができます。

Locked

他のプリミティブと同様に、フィルはワークスペースにロックできます。位置が
確定したフィルをロックしてください。

Selection

フィルのセレクションや、セレクションの解除を行います。

Arcs ((((円円円円弧弧弧弧))))
Arcsは丸いトラック･セグメントです。アークはどのレイヤーにも配置することがで
き、半径0.001から16000mil、幅0.001から10000milの間で設定できます。角度の分解
能は0.001度です。ArcsはPlacementToolsツールバーのArcボタン、Place » Arc プロ
セス･ランチャー、またPlace-Trackの際にトラックの一部分として配置できます。ア
ークはポリゴンによる塗り潰しやオートルータにおいても使用できます。

ArcsはPCBレイアウトでいろいろな使用方法があります。例えば、オーバーレイ･レ
イヤーでコンポーネントの形状を示すために使われたり、メカニカル･レイヤーで基
板の外形や穴などを示すために使用されたりします。Arcsは角度を指定することによ
り360度の全円や、180度半円などいろいろな形状の円を作成することができます。

Arcsはトラックの一部として信号レイヤーに配置することができます。これらのアー
クは、Track Placement ModeがArc Start またはArc Endに設定されｔいる場合、トラ
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ックの配置中に簡単に作成することができます。SHIFT+SPACEBARをトラックの配
置中に押して４つの配置モードを切り替えてください。Arcモードを選択すると、
SPACEBARを押してArc Startと Arc Endモードを切り替えてください。

デデデデフフフフォォォォルルルルトトトト････アアアアーーーークククク
デザイン･オブジェクトのデフォルト属性は、Preferencesダイアログ･ボックスの
Defaultsタブで設定してください。

è 現在配置されているデザイン･オブジェクトの属性は、PlacemsntToolsツールバ
ーのボタンを押してから、またはPlaceメニューを選択してすぐにTabキーを押し
て設定してください。Preferencesダイアログ･ボックスのDefaults Tabで
"Permanent"オプションが設定されていない場合、配置作業中の変更は新しくデ
フォルトになります。

アアアアーーーーククククのののの配配配配置置置置    (Center)(Center)(Center)(Center)
アーク･センターを使用して現在のレイヤーにアークを配置するには :

1. Place » Arc (Center)（ショートカット；P,A）選択するかArcツールボタンを選択
してください。

ステータス･バーに"Select Arc Center”と表示されます。配置するレイヤーを変更する
場合、*や＋、－を押して下さい。

2. カーソルをアークの中心に置いてマウスの左ボタンをクリックしてください。

マウスを動かすと、ハイライト表示されたアークが表示されます。

3. カーソルをアークのセンターとなる位置に移動しマウスの左ボタンをクリックし
てください。

4. カーソルをアークの始点に移動しマウスの左ボタンをクリックしてください。

5. カーソルをアークの終点に移動しマウスの左ボタンをクリックしてください。

è 開いているアークの方向を変える場合、終点を定義する前にSPACEBARを押して
ください。

360度の全円を作成する場合、始点と終点をマウスを移動させずにクリックして下さ
い。

6. 別のアークを定義するかESCまたはマウスの右ボタンを押してアークの配置を終
了してください。

アアアアーーーーククククのののの配配配配置置置置    (Edge)(Edge)(Edge)(Edge)
アークのエッヂを使用して現在のレイヤーにアークを配置するには:

1. Place » Arc  (Edge)を選択してください。（ショートカット；P,E）
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2. カーソルをアークの始点に置いてマウスの左ボタンを１回クリックしてくださ
い。

3. カーソルをアークの終点に移動し、再びマウスの左ボタンをクリックしてくださ
い。

è アークを方向に変更するには、終点を定義する前にSPACEBARを押してくださ
い。

アアアアーーーーククククのののの変変変変更更更更
編集可能なアークの属性として:

Width

アークの線幅は0.001-10000milsの間で設定できます。

Layer

PCBの任意のレイヤーにアークを設定することができます。レイヤーの割り付け
を変更するには、Layerボックスをクリックして新しいレイヤーを選択してくださ
い。

Net

プリミティブのNet属性は、Design Rule Checkerで使用され、プリミティブが正
しく配置されているかどうかを確認します。ネット名はプリミティブがオートル
ータによって配置された場合、マニュアル配線された場合、すでにネット名を持
っているプリミティブと同じ位置に配置された場合、自動的に割り付けられま
す。

X and Y Center

アークの中心を定義します。

Radius

アークの半径を定義します。

Start and End Angle

０度の点（時計の３時方向）からアーク上の２つの終点までの角度を定義してく
ださい。

Locked

他のプリミティブと同様に、アークはワークスペースにロックできます。位置を
固定したい場合、アークをロックしてください。

Selection

アークのセレクションや、セレクションの解除を行います。
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スススストトトトリリリリンンンンググググ
0.01milsから10000milsの高さのテキスト文字列を任意のレイヤーに配置することがで
きます。Stringsボタン（T）またはPlace » String メニューを選択して文字列を配置
してください。

Place » String を使用して、（スペースを含む254文字までの）任意のテキスト文字
列をPCBのレイヤーに配置することができます。テキストには、３種類の特別なフォ
ントを使用することができます。Defaultスタイルは単純なベクター･フォントでペン･
プロッティングやベクター･フォトプロッティングをサポートします。Sans Serifと
Serifフォントは、複雑なフォントです。したがって、ベクター･デバイスのプリンテ
ィングやプロッティングに時間がかかります。システムに附属のフォントはソフトウ
ェアに組み込まれているため変更することはできません。

テキスト文字列は、他のプリミティブと同様に移動や編集ができます。コンポーネン
トのコンポーネント･テキストは、単独で移動することができます。（Edit » Move）
コンポーネントが移動すると、コンポーネント･テキストも同じように移動します。

コンポーネント･テキスト（デジグネータ、コメント）は同じフォント･オプションや
高さ･幅の範囲を持っており、同じ方法で編集することができます。フリーテキスト
は、任意のレイヤーに配置することができます。コンポーネントが配置されると、コ
ンポーネント･テキストは自動的にTopまたはBottom Overlayレイヤーに割り付けられ
ます。ただし、任意のレイヤーへ移動することができます。

プロットされたりフォトプロットされるすべてのフォントは、スクリーン上に同様に
表示されます。フォントは、すべてIBM拡張ASCIIキャラクタ･セットで英語と他のヨ
ーロッパ言語をサポートします。

è 変換されたPretel Autotraxファイルの文字列は、Defaultフォント･タイプに変換さ
れます。Advanced PCBのDefaultフォントは、Autotraxより、大きなサイズのキ
ャラクターになります。

Advanced PCBには、"Special Strings"があります。これらの文字列は、出力が生成さ
れるときに特別な意味で解釈されます。

デデデデフフフフォォォォルルルルトトトト････スススストトトトリリリリンンンンググググ
デザイン･オブジェクトのデフォルト属性は、Preferencesダイアログ･ボックスの
Defaultsタブで設定してください。

è 現在配置されているデザイン･オブジェクトの属性は、PlacemsntToolsツールバ
ーのボタンを押してから、またはPlaceメニューを選択してから、Tabキーを押し
て設定してください。Preferencesダイアログ･ボックスのDefaults Tabで
"Permanent"オプションが設定されていない場合、配置作業中の変更は新しくデ
フォルトになります。

スススストトトトリリリリンンンンググググのののの配配配配置置置置
ストリングを配置するには、
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1. Place » String メニューを選択してください。現在のデフォルトのストリングが
カーソル上に現れます。

2. TABキーを押すとChange Stringダイアログ･ボックスが表示されます。

3. Textフィールドに文字列を入力するか、ドロップ･ダウン･リストから文字列を選
択してください。

4. Height(文字高)やWidth(文字幅)、Fontを必要に応じて設定してください。

5. OKをクリックしてください。ストリングがカーソル上に現れます。クリックし
てストリングを配置してください。

配置作業中に、*や+、-キーを押してレイヤーを切替えることができます。ＸまたはＹ
キーを押すとストリングをＸ軸またはＹ軸に沿って反転することができます。また、
SPACEBARを押すと回転することができます。

スススストトトトリリリリンンンンググググのののの変変変変更更更更
テキスト文字列やコンポーネント･テキスト（デジグネータまたはコメント）は個別
に変更することも、グローバルに変更することもできます。

Text

テキスト文字列は、255文字までの長さで、任意のアルファベット文字や数字、
スペースを使用することができます。

Height

テキストの大きさは、mils（.001mm）またはmmで設定します。範囲は、0.01か
ら10000milsの間です。テキストの高さの最小は36milsです。この高さがフォト･
プロットした場合に解読できる最小の高さです

Width

テキストの幅は、mils（.001mm）またはmmで設定します。範囲は、0.001から
255milsの間です。

Font

DfaultとSans Selif、Serifの３種類のフォントを使用できます。Defaultフォントは
ベクター･プロット用に作られています。

Layer

テキストストリングは任意のレイヤーに割り付けることができます。

Rotation

Advanced PCBでは、角度の分解能0.001度でストリングの回転を行うことができ
ます。

X, Y Location

ストリングの座標を編集することができます。これらの変更は、他の場所に配置
されたストリングに影響することはありません。
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Mirror

文字を半田面から見た場合に正しい方向にするためには、Mirrorにより切り替え
ます。また、文字列は、配置が確定する前のカーソル上にある時にＸまたはＹキ
ーを押すとＸ軸またはＹ軸に沿って反転することができます。

Locked

すべてのプリミティブと同様に、ストリングをワークスペース上でロックするこ
とができます。位置を固定したいストリングはロックしてください。

Selection

ストリングのセレクションやセレクションの解除を行います。

Special Strings( ススススペペペペシシシシャャャャルルルル････スススストトトトリリリリンンンンググググ)
Special Stringsを使用して、印刷やプロット、ガーバー･ファイルの作成時に解釈され
るテキストを配置することができます。例えば、文字列.PRINT_DATEは、出力が生成
される時に現在の日付と置き換えられます。使用できるスペシャル･ストリングを以
下に示します。

.PRINT_DATE

.PRINT_TIME

.PRINT_SCALE

.LAYER_NAME

.PCB_FILE_NAME

.PCB_FILE_NAME_NO_PATH

.PLOT_FILE_NAME

.ARC_COUNT

.COMPONENT_COUNT

.FILL_COUNT

.HOLE_COUNT

.NET_COUNT

.PAD_COUNT

.STRING_COUNT

.TRACK_COUNT

.VIA_COUNT

.DESIGNATOR

.COMMENT

.LEGEND

.NET_NAMES_ON_LAYER

.DESIGNATORと.COMMENTはライブラリーのコンポーネントに追加されます。コン
ポーネントの属性の位置を指定する場合、これらを使用してください。これらの文字
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列は任意のレイヤーに配置できます。標準のデジグネータやコメントは必要に応じて
表示させないようすることができます。

Drill Drawingレイヤーには.LEGENDを置いてください。.LEGENDは出力が生成される
ときにドリル･テーブルと置き換えられます。

è スクリーン上でこれらのスペシャルストリングスを変換するには、Preferencesダ
イアログ･ボックスのOptionsタブでConvert Special Stringsオプションをチェック
してください。一部のスペシャルストリングスはスクリーン上で変換することが
できません。
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ググググルルルルーーーーププププ････オオオオブブブブジジジジェェェェククククトトトト
グループ･オブジェクトはいくつかのオブジェクトが一つのグループとして定義され
たものです。例えば、コンポーネントやポリゴン、またシステムで定義されたコーデ
ィネートやディメンションがあります。グループ･オブジェクトは一つのオブジェク
トのように配置や移動、セレクション、コピーなどの操作を行うことができます。

ポポポポリリリリゴゴゴゴンンンン
ポリゴンは、銅箔で形成される特別なエリアで、Place » Polygon Plane プロセスを
使用します。ポリゴン･プレーンは、エリア･フィルと同じですが、複雑な形状の塗り
潰しを行ったり、特定のネットと接続できる点がエリア･フィルとは違います

ポリゴンはトラックやアークで構成されますが、一つのグループのように扱うことが
できます。また配置済みのポリゴンについても境界線の再編集や、あとから配置され
た障害に対してのリポア、またトラックサイズやグリッドなどの属性を変更させるこ
とができます。グリッドやトラックサイズを調整して、ポリゴンプレーンをソリッ
ド･エリアかクロス･ハッチされた格子にすることができます。

ポリゴンプレーンを配置した場合、トラック、パッド、ビア、フィル、テキストに対
し、デザインルールで設定されたクリアランスは維持されます。ネットリストに基づ
くレイアウトの場合、ポリゴンプレーンで設定したネットと同じネット名のコンポー
ネント･パッドを自動的に接続することができます。

ポリゴンは、任意のレイヤーに配置することができます。ポリゴンは任意のレイヤー
に複雑な形状の銅箔面を作成する場合に使用してください。ポリゴンがノン･シグナ
ル･レイヤーに配置される場合、ネットに割り付けられていないオブジェクトのよう
に既存のオブジェクトの周りにはポアされません。

ポポポポリリリリゴゴゴゴンンンン････ププププレレレレーーーーンンンンのののの配配配配置置置置
ポリゴン･プレーンを配置するには:

1. Place » Polygon plane を選択してください（ショートカット；P,G）

Place Polygon Planeダイアログ･ボックスがポップ･アップ表示されます。必要に応じ
て属性を設定してください。それぞれの属性は以下のように定義してください。

3. クリックしてポリゴンの始点を定義してください。

4. ポリゴンプレーンの外形が定義されるまでポリゴンの頂点をクリックしてくださ
い。SHIFT+SPACEBARを押すと、トラック配置モードに切り替わります。
SPACEBARを使用してStartとEnd配置モードを切り替えてください。

ポリゴンを実際に閉じない場合、ESCまたはマウスの右ボタンを押すと、最後の頂点
から最初の頂点へポリゴンが自動的に閉じられます。
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Place Polygon Planeダイアログ･ボックスには以下のものがあります。

Net Options

Connect To Net

ネットリストがロードされている場合、ネットリスト内のネットの一つを
Connect To Netドロップ･ダウン･メニューで選択することができます。ポリゴン
がネットに接続されると、他の２つのNet Optionsが適用されます。

Pour Over Same Net

Pour Over Same Netオプションがチェックされている場合、ポリゴンで指定され
たネットと同じネット名のトラックに対して、ポリゴンは重ねられて配置されま
す。

Remove Dead Copper

Dead Copperは、Place Polygon Planeプロセスで、指定されたネットに接続され
ずに配置されたコパーです。デッド･コパーの領域は、既存のトラックやパッ
ド、ビアによりプレーンが一つの連続領域にならない時に作成されます。必要に
応じて、これらの領域は削除することができます。このオプションがチェックさ
れており、ポリゴンで指定されたネットと同じネット名のピンがポリゴンで囲ま
れた領域に存在しない場合、ポリゴン全体は、デッドコパーとして削除されま
す。
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Plane Settings

Grid Size

ポリゴンの内部に配置されるトラックのグリッドです。理想的には、このグリッ
ドは、コンポーネントのピン･ピッチの分数です。ソリッド･プレーンでは、トラ
ック幅をグリッド･サイズよりもわずかに広く設定してください。

Track Width

ポリゴンを形成するトラックの幅です。トラック幅がグリッド･サイズよりも小
さい場合、ポリゴンは、格子状で表示されます。トラック･サイズがグリッド･サ
イズと等しいか大きい場合、ポリゴンはソリッド(塗り潰され)表示されます。ソ
リッド･プレーンでは、トラック幅をグリッド･サイズよりもわずかに大きく設定
してください。

Layer

これは、ポリゴンが配置されるレイヤーです。ポリゴンはコパー･レイヤーとノ
ンコパー･レイヤーどちらにも配置することができます。

Hatching Style

90 Degree Hatch

水平と垂直方向のハッチングを行います。

45 Degree Hatch

45度のハッチングを行います。

Vertical Hatch

垂直方向のみのハッチングを行います。

Horizontal Hatch

水平方向のみのハッチングを行います。

No Hatching

ポリゴン内部はハッチングされません。このオプションは、ポリゴンの配置によ
ってシステムのパフォーマンスを落としたくない場合に使用して下さい。ポリゴ
ンはあとからハッチングすることも可能です。

Surround Pads With

パッドを円弧や八角形で囲むことができます。八角形を使用するとガーバー･フ
ァイルの大きさを小さくでき、フォトプロットにかかる時間を短縮できます。

Minimum Primitive Size

Length

ここで設定される値は、ポリゴンで使用されるプリミティブの最小値になりま
す。ポリゴンが作成されると、そこにはたくさんの細かいトラックやアークが含
まれており、これらは基板上に存在するオブジェクトの周りを滑らかに囲むため
に配置されています。プリミティブの長さを限定することでポアしている時間や
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再描画、出力の生成時間を短縮することができます。ただしその事によって、ポ
リゴンのエッヂの滑らかさは損なわれます。

ポポポポリリリリゴゴゴゴンンンンををををパパパパッッッッドドドドにににに接接接接続続続続すすすするるるる方方方方法法法法
Connect To Netオプションはポリゴンをパッドに接続する場合に使用され、接続方法
はPolygon Connect Styleのデザインルールの設定が用いられます。このルールによ
り、ダイレクト接続とサーマル･リリーフ接続を選択することができます。リリーフ
接続を選択すると、導体の幅や接続角度を設定できます。Polygon Connect Styleデザ
イン･ルールについての詳細はデザイン･ルール  の項を参照してください。

ポポポポリリリリゴゴゴゴンンンンののののリリリリポポポポアアアア
ポリゴンをリポアするには、Edit » Change メニューを選択してください。リポアし
たいポリゴンの上をクリックすると、Place Polygon Planeダイアログ･ボックスがポ
ップ･アップ表示されます。（ショートカット；ポリゴンをダブル･クリックしてくだ
さい。）必要に応じて属性を変更し、OKをクリックしてください。変更したポリゴン
すべてにリポアを行うかを聞いてきます。その他のポリゴンを変更したい場合Noをク
リックしてください。Yesをクリックすると変更されたポリゴンがすべてリポアされ
ます。ポリゴンは変更された設定でリポアされます。

ポポポポリリリリゴゴゴゴンンンンのののの形形形形状状状状のののの変変変変更更更更
ポリゴン･プレーンの境界は、頂点の移動、頂点の削除、境界トラックの分割などに
よって形状を変更することができます。

ポリゴンの形状を修正するには;

1. Edit » Move » Polygon Vertices メニューを選択します。

ステータス･バーに"Choose a Polygon"と表示されます。

2. 編集するポリゴンをクリックしてください。

内部のポリゴントラックの表示が消え、トラックの境界だけが残ります。

3. 移動したい頂点をクリックしてください。頂点を移動することができます。

4. Deleteキーを押すと頂点を削除することができます。

5. 一つのトラック･セグメントの両端とセンターには編集ハンドルが表示され、セ
ンターのハンドルをクリックするとポリゴンの境界のトラックを分割することが
できます。

5. 編集を終わるときは、マウスの右ボタンをクリックするかESCを押してくださ
い。

è 変更したポリゴンすべてにリポアを行うかをたずねられます。その他のポリゴン
を変更したい場合Noをクリックしてください。Yesをクリックすると変更された
ポリゴンがすべてリポアされます。ポリゴンは変更された設定でリポアされま
す。
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デデデディィィィメメメメンンンンシシシショョョョンンンン((((寸寸寸寸法法法法線線線線))))
ディメンションはテキストやトラック･セグメントから成る特別な存在です。それら
は、Place » Dimension メニューを選択して始点と終点を指定すると自動的に作成さ
れます。

設計を始める時に多くの設計者が最初に行う作業の一つは、基板寸法の詳細を定義す
ることです。Advanced PCBには、便利な自動寸法機能があり、その作業を高精度に
しかも簡単に行うことができます。現在のスナップ･グリッドの設定により、インペ
リアル単位系とメトリック単位系により計算することができます。

デデデデフフフフォォォォルルルルトトトト････デデデディィィィメメメメンンンンシシシショョョョンンンン
すべてのオブジェクトのデフォルトの属性は、Preferencesダイアログ･ボックスの
Defaults タブで設定されます。

è 現在配置されているデザイン･オブジェクトの属性は、PlacemsntToolsツールバ
ーのボタンを押すかPlaceメニューを選択してすぐにTabキーを押して設定してく
ださい。Preferencesダイアログ･ボックスのDefaultsタブで"Permanent"オプショ
ンが設定されていない場合、配置作業中の変更は新しくデフォルトになります。

デデデディィィィメメメメンンンンシシシショョョョンンンンのののの配配配配置置置置
1. Place » Dimension メニューを選択してください。

2. 始点の位置でマウスをクリックしてください。

ステータス･バーに “Select Measure End Point”と表示されます。

3. 終点の位置でマウスをクリックしてください。

寸法情報が配置されます。

デデデディィィィメメメメンンンンシシシショョョョンンンンのののの変変変変更更更更
文字高やフォントなどのようなディメンションの属性は配置作業中またはディメンシ
ョンが配置された後で変更することができます。（Tabキーを押してください）Edit-
Changeメニューを選択しディメンションをクリックしてください。Change
Dimensionダイアログ･ボックスが表示されます。

Height

ディメンションのエンド･ラインの高さです。

Line Width

ディメンションの全ラインの幅です。

Unit Style

表示される単位は、現在のスナップ･グリッドの単位です。単位を表示したり、
表示しなかったり、括弧内に表示したりできます。
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Text Height

テキストの大きさはmilsまたはmmで設定することができます。0.01から
10000milsの間で設定することができます。フォトプロットで判読できる最小の
テキスト高さは36milsです。

Text Width

テキストのストローク幅をmils（.001mm）またはmmで設定できます。設定範囲
は、0.001から255milsです。

Font

DefaultとSans Selif、Serifの３種類のフォントを使用できます。Defaultフォント
はベクター･プロット用に作られています。

Layer

ディメンションは任意のレイヤーに配置可能です。

Start X, Y

始点のX,Y座標です。

End X, Y

終点のX,Y座標です。

Locked

ディメンションをワークスペース上でロックすることができます。調整や移動の
必要のないディメンションをロックしてください。

Selection

ディメンション全体のセレクションやセレクションの解除を行います。

デデデディィィィメメメメンンンンシシシショョョョンンンンのののの移移移移動動動動
Advanced PCBでは、寸法を配置した後で移動や調整をすることができます。寸法の
移動や調整を行なうには、ディメンションのどこかを一回クリックしディメンション
をフォーカス状態にしてください。（四角いフォーカス･ハンドルが表示されま
す。）ディメンションを２回クリックするとディメンションを移動できます。フォー
カス･ハンドルを２回クリックすると、ディメンションの調整ができます。ディメン
ションの大きさを変更する場合、長さは自動的に更新されます。

ココココーーーーデデデディィィィネネネネーーーートトトト (座座座座標標標標)
座標マーカーを使用してワークスペースの指定した位置の座標を示すことができま
す。座標マーカーには、ポイント･マーカー（２つのトラックでできた十字）と点の
X,Y座標があります。マーカーは、任意のレイヤーに配置することができます。
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デデデデフフフフォォォォルルルルトトトト････ココココーーーーデデデディィィィネネネネーーーートトトト
すべてのオブジェクトのデフォルトの属性は、Preferencesダイアログ･ボックスの
Defaults タブで設定されます。

è 現在配置されているデザイン･オブジェクトの属性は、PlacemsntToolsツールバ
ーのボタンを押すかPlaceメニューを選択してすぐにTabキーを押して設定してく
ださい。Preferencesダイアログ･ボックスのDefaultsタブで"Permanent"オプショ
ンが設定されていない場合、配置作業中の変更は新しくデフォルトになります。

ココココーーーーデデデディィィィネネネネーーーートトトトのののの配配配配置置置置
1. Place » Coordinate メニューを選択してください。

コーディネートがカーソルにフローティングの状態になります。

2. コーディネート･マーカーを置く位置をクリックしてください。

3. コーディネート･マーカーの配置を続けるか、マウスの右ボタンを押して作業を
終えてください。

ココココーーーーデデデディィィィネネネネーーーートトトトのののの変変変変更更更更
文字高やフォントのようなコーディネート属性は、配置中にタブ･キーを押して変更
するか、または配置された後でも変更することができます。編集可能なコーディネー
ト属性は、

Size

コーディネート･マーカー･ラインのサイズです。

Line Width

コーディネート･マーカー･ラインの幅です。

Unit Style

表示されている単位は現在のスナップ･グリッドの単位です。単位を表示した
り、表示しなかったり、括弧内に表示したりできます。

Text Height

テキストの大きさはmilsまたはmmで設定することができます。0.01から
10000milsの間で設定することができます。フォトプロットで判読できる最小の
テキスト高さは36milsです。

Text Width

テキストのストローク幅をmils（.001mm）またはmmで設定できます。設定範囲
は、0.001から255milsです。

Font

DefaultとSans Selif、Serifの３種類のフォントを使用できます。
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Layer

コーディネートは任意のレイヤーに配置可能です。

X, Y Location

コーディネート･マーカーのX,Yの位置です。

Locked

コーディネートはワークスペース上でロックすることができます。

Selection

コーディネート全体のセレクションやセレクションの解除を行います。
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ココココンンンンポポポポーーーーネネネネンンンントトトトととととラララライイイイブブブブララララリリリリーーーー

Advanced PCBのライブラリーには、基板設計時によく使用される300種類以上のスル
ーホール部品や、SMD 部品のフットプリントが用意されています。PCBフットプリ
ントは、Advanced PCBの２番目のドキュメント･エディタであるPCBライブラリーエ
ディタで作成と変更ができます。このドキュメント･エディターを使用してコンポー
ネント･フットプリントやライブラリーの作成についての詳細は、PCB ライブラリー･
エディタ の項を参照してください。

Advanced PCBでは、”フットプリント”はPCBライブラリーに存在します。このフ
ットプリントがワークスペースに配置されると、このフットプリントにはデジグネー
タが割り付けられます。これを使用してコンポーネントを参照できます。

ココココンンンンポポポポーーーーネネネネンンンントトトト････フフフフッッッットトトトププププリリリリンンンントトトトへへへへののののアアアアククククセセセセスススス
ライブラリーのコンポーネント･フットプリントにアクセスするには、まずライブラ
リーがPCBエディターの カレント･ライブラリー･リストに追加されている必要があり
ます。ライブラリーを追加･削除するにはDesignメニューのAdd/Remove Libraryを選
択するかPCB Editor PanelのAdd/Removeボタンを押してください。PCB Libraryダイ
アログ･ボックスがポップ･アップ表示され、このダイアログ･ボックスのCurrent File
Listから、新しいライブラリーを追加したり、既存のライブラリーをリストからはず
すことができます。

一度、ライブラリーに追加されると、このライブラリーからのフットプリントをワー
クスペース上へ配置することができます。追加できるライブラリーの数は、使用中の
コンピュータのメモリによって変わります。

ラララライイイイブブブブララララリリリリーーーーのののの追追追追加加加加とととと削削削削除除除除
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Change Library File List ダイアログでライブラリのエントリーを行います。

このダイアログ･ボックスには以下の機能とオプションがあります。

File Name

ライブラリー･リストに追加するライブラリーのファイル名を入力してくださ
い。

File

このフィールドに、File Nameフィールドで使用されるカレント･ファイル･マス
クに適合するカレント･ディレクトリー内のファイルが一覧表示されます。

File Types

ライブラリー･ファイルをロードするためのマスクから選択してください。この
機能を使用して拡張子によりファイルタイプを指定することができます。
Advanced PCBでは、ライブラリー･タイプを識別するために拡張子を使用できま
す。

Directories

必要なライブラリーを検索するために、このフィールドをダブル･クリックし
て、カレント･パスやカレント･ディレクトリを変更してください。

Current File List

このフィールドには、現在ロードされているライブラリーがすべて表示されライ
ブラリーの追加や削除に応じて内容が更新されます。

ライブラリーをカレント･リストへ追加するには:

1. Fileフィールド内のセレクション･バーを移動してFileフィールドに表示されてい
る希望するライブラリーをハイライト表示してください。

2. Addボタンをクリックしてください。ライブラリーがCurrent File Listフィールド
へ追加されます。

ライブラリーをカレント･リストから削除するには:

1. Fileフィールド内のセレクション･バーを移動してFileフィールドに表示されてい
る希望するライブラリーをハイライト表示してください。

2. Removeをクリックしてください。

3. OKをクリックしてダイアログを閉じライブラリー･リストを更新してください。
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ココココンンンンポポポポーーーーネネネネンンンントトトトのののの検検検検索索索索とととと配配配配置置置置
ライブラリー内のコンポーネントをブラウズするに
は、PCB Editor PanelのBrowseモードをLibrariesに設
定しリストの中の必要なライブラリーをクリックし
てください。コンポーネント･リストのコンポーネン
トをクリックすると、MiniViewerに表示されます。

PCBエエエエデデデディィィィタタタタででででのののの配配配配置置置置
コンポーネント･フットプリントを配置するには ;

1. Pnael BrowseモードをLibrariesに設定してくだ
さい。

2. 一覧の中から必要なライブラリーを選択してく
ださい。

3. Panelのリストのなかからコンポーネントを選択
し、Placeボタンを押してください。（ショート
カット；マウスの左ボタンをダブルクリック）

コンポーネントが、カーソル上にフローティングの
状態で表示されます。

4. コンポーネントを配置する前に、TABキーを押
してデジグネータとコンポーネントを編集して
ください。それからOKをクリックしてフローテ
ィング状態のコンポーネントへ戻ってくださ
い。

PAGEUPを押すとズーム･インが行われます。
SPACEBARを押すと回転し、ショートカット･キーL
によりコンポーネントを半田面に配置することがで
きます。Jumpショートカット･キーを使用して指定
した場所へジャンプすることができます。

5. マウスの左ボタンをクリックしてコンポーネン
トを配置してください。

PCBラララライイイイブブブブララララリリリリーーーー････エエエエデデデディィィィタタタタかかかかららららののののココココンンンンポポポポーーーーネネネネンンンン
トトトト配配配配置置置置
コンポーネントは、PCBライブラリー･エディタから配置することもできます。
Library Editor Panelには、Placeボタンがあります。コンポーネントを一覧から選択し
Placeを押してください。コンポーネントは、最後のアクティブPCBウィンドウに配
置されます。
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ココココンンンンポポポポーーーーネネネネンンンントトトトににににつつつついいいいてててて
フットプリントがワークスペースに配置されると、コンポーネントになります。コン
ポーネントには、R3のようなデジグネータと10Kのようなコメントがあります。ま
た、トラックやパッド、アークなどの集まりではなくひとつのオブジェクトとして扱
われ、移動や反転、回転ができます。コメントを変更するには、Edit » Change メニ
ューを選択するかコンポーネントのアウトラインの内部をダブル･クリックしてくだ
さい。

Change Component ダイアログには3つのタブがあります。編集可能なコンポーネン
トの属性は:

Attributes Tab

このタブには通常使われるコンポーネントの属性になります。

Designator/Comment

コンポーネントのデジグネー
タやコメントの値は、ここで
変更することができます。デ
ジグネータやコメント･タブ
を使用してフォントやテキス
トの文字高、テキストの幅な
どの属性を変更してくださ
い。

Footprint

コンポーネントの現在のフッ
トプリントを、コンポーネン
ト･ライブラリーの他のフッ
トプリントへ変更することが
できます。Footprintフィール
ドに異なるフットプリントの
名前を入力する場合、ダイア
ログ･ボックスを終了する時
に、Advanced PCBにより現
在オープンされているライブ
ラリーが検索され新しいフッ
トプリントが置かれます。

Layer

コンポーネントは、PCBのト
ップ･レイヤーかボトム･レイ
ヤーに配置することができま
す。レイヤーの割り付けを変
更するには、Layerボックス
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をクリックしトップ･レイヤーかボトム･レイヤーを選択してください。

レイヤー･ステータスを変更して、反対のレイヤーにコンポーネントを配置でき
ます。例えば、トップ･レイヤーのコンポーネントをボトム･レイヤーへ移動する
場合、Top Overlayレイヤーのプリミティブは、自動的にBottom Overlayレイヤー
に再割り付けされます。コンポーネントの方向はＸ軸に沿って反転され、コンポ
ーネント･オーバーレイ･テキストはボトムから読まれます。シングル･レイヤー･
パッドもトップ･レイヤーとボトム･レイヤーの間で交換できます。このような入
れ替え作業は、任意のレイヤー間でも実行することができます。

Rotation

コンポーネントを任意の角度で回転することができます。角度の解像度は0.001
度です。

Lock Prims

通常、一つのオブジェクトとしてコンポーネントを扱いたい場合にロックされま
す。この状態ではコンポーネントで作られたプリミティブは互いにロックされま
す。必要に応じて、プリミティブのロックを解除してそれらを編集することがで
きます。コンポーネントのプリミティブは再びロックすることができます。コン
ポーネント･パッドの属性はプリミティブのロックを解除しなくても変更するこ
とができます。

Locked

Locked属性により、コンポーネントがワークスペース内で固定されるか移動でき
るかが決まります。Locked属性が設定されると、自動配置によってそのコンポー
ネントが移動されることはありません。手動でそのコンポーネントを移動しよう
とすると、"Object is locked,continue?"というワーニング･メッセージが表示さ
れ、それらのロックを解除することなくコンポーネントの移動ができます。ロッ
クされた属性はこれが移動された後でもそのままの状態です。

Selection

コンポーネントのセレクションや、セレクションの解除ができます。この属性
は、制限付でコンポーネントのグローバルチェンジを行う場合に使用します。



PCB Design with Advanced PCB

Designator とととと Comment タタタタブブブブ
この2つのタブを使用しコンポーネント･デジグネータとコメントのテキスト属性を編
集できます。

Text

コンポーネントのデジグネ
ータまたはコメントです。
デジグネータ属性は、グロ
ーバルに編集することがで
きません。従って、コンポ
ーネントは独自のデジグネ
ータを持つことになりま
す。Comment属性はグロー
バルに編集することができ
ます。デジグネータとコメ
ントの文字列は255文字まで
です。

Height

テキストの大きさはmilsまた
はmmで設定することができ
ます。0.01から10000milsの
間で設定することができま
す。テキストの表示やプリ
ントに使用される文字幅は
自動的に高さに比例して設
定されます。フォトプロッ
トで判読できる最小のテキ
スト高さは36milsです。

Width

テ キ ス ト の 線 幅 を mils
（ .001mm）またはmmで設
定できます。設定範囲は、
0.001から255milsです。

Font

DefaultとSans Selif、Serifの３種類のフォントを使用できます。

Layer

コンポーネント･テキストは任意のレイヤーに配置することができます。Layerボ
タンをクリックしてセレクション･バーをスクロールしてください。選択された
レイヤーはLayerボックスに表示されます。
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Rotation

コンポーネント･テキストをコンポーネントとは別に移動したり回転したりでき
ます。コンポーネント･テキストをクリック＆ホールドしマウスをドラッグして
テキストを移動してください。SPACEBARを押して、テキストがカーソル上に浮
いている状態でテキストを回転してください。

X, Y Location

テキストのワークスペースの位置です。現在の原点の相対的な位置になります。

Hide

コンポーネント･テキストの表示、非表示ができます。表示されていないテキス
トはプリントされません。

Mirror

コンポーネント･テキストはコンポーネント毎に反転することができます。

è 配置中にコンポーネントを反転するには、コンポーネントがフローティング状態
でLキーを押してください。これによりフットプリントの反転やトップ･レイヤ
ー･パッドとボトム･レイヤー･パッドの変換、オーバーレイのボトム･オーバーレ
イ･レイヤーへの反転を実行することができます。XキーやYキーを使用するとコ
ンポーネントは反転されますがレイヤーは変更されません。

ココココンンンンポポポポーーーーネネネネンンンントトトト････フフフフッッッットトトトププププリリリリンンンントトトトのののの変変変変更更更更
既存のコンポーネントをあるフットプリントからその他のフットプリントへ変更する
には、コンポーネントのアウトライン内をダブル･クリックしてChange Componentダ
イアログ･ボックスを表示してください。新しいフットプリント名をAttributeタブの
Footprintフィールドへ入力してください。

現在のコンポーネント･フットプリントを、現在開いている任意のライブラリーのフ
ットプリントに変更することができます。Footprintフィールドに違う名前を入力しOK
をクリックしてダイアログ･ボックスを終了すると、Advanced PCBは現在開いている
ライブラリーを検索し新しくフットプリントを配置しようとします。

コンポーネント･フットプリントは自由に変更することができます。しかし、パッド
に接続されたネットリストがある場合、新しいフットプリントは以前と同じピン番号
を持つ必要があります。以前のものと一致しない場合、"cannot match pads with new
footprint"というワーニング･メッセージが表示され置き換えが中断されます。例えば、
DIP16をSMD16Aに変更することは、ピン番号が適合しているので正しい変更です。
DIP16をTO-3に変更することはワーニングの対象となり変換は中断されます。変更が
完了するとパッドの接続はそのままで、コネクション･ラインが更新されます。
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ボボボボーーーードドドド上上上上ののののココココンンンンポポポポーーーーネネネネンンンントトトトのののの変変変変更更更更
通常、コンポーネント･フットプリントに変更が必要な場合、フットプリントをライ
ブラリー内で編集し、それからPCBをアップデートします。これにより、現在開いて
いるデザインすべてのフット･プリントのインスタンスが更新されます。

また、Advanced PCBでは、基板上のコンポーネントからも変更が可能です。基板上
のコンポーネントを変更するには、コンポーネントのシンボルの内側をダブル･クリ
ックし、Change Componentダイアログ･ボックスを表示させてください。次に
Attributesタブを選択します。Lock Primsチェック･ボックスのチェックオフにしてか
らOKボタンをクリックしダイアログ･ボックスを閉じます。これにより、コンポーネ
ント･プリミティブの変更や操作が可能になります。それから、コンポーネント･プリ
ミティブを再びロックしてください。コンポーネント･パッド属性は、プリミティブ
のロックを解除しないで変更することができます。

ココココンンンンポポポポーーーーネネネネンンンントトトトののののアアアアンンンンググググルルルルーーーーププププ
必要に応じて、配置されたコンポーネントをプリミティブ･パーツの元の設定に戻す
ことができます。Tools » Convert » UnGroup Component メニューを選択してくだ
さい。このプロセスを起動すると、"Select Component"というプロンプトが表示され
ます。次に、"Confirm convert Component To Primitives"というプロンプトが表示され
ます。YESをクリックすると、コンポーネント･デジグネータとコメントがコンポー
ネントから削除されプリミティブの組みになります。これは、片道のプロセスでグル
ープを解除されたコンポーネントを再グループ化することはできません。

è アングループ化は、ライブラリーに保存されているコンポーネント･フットプリン
トに影響しません。すなわち、ドキュメント･ウィンドウに配置されたコンポーネ
ントにのみ影響します。

ププププロロロロジジジジェェェェククククトトトト････ラララライイイイブブブブララララリリリリーーーーのののの作作作作成成成成
Advanced PCBは、ワークスペースに現在配置されているすべてのコンポーネントの
ライブラリーを作成することができます。

この機能を使用するには Tool » Make Project Library メニューを選択してください。

è Make Project Library 機能はMakeLibサーバーによって供給されます。
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PCBラララライイイイブブブブララララリリリリーーーー････エエエエデデデディィィィタタタタ

ライブラリー･エディタはAdvanced PCBサーバーの第２のドキュメント･エディタで
す。PCBエディタを使用してプリント基板の設計をして、ライブラリー･エディタを
使用してPCB上のコンポーネントの作成や変更を行ないます。また、PCBライブラリ
ーの管理も行ないます。

ライブラリー･エディタには、ライブラリー･フットプリントの作成や編集、配置を行
なうプロセスが全て組み込まれています。カスタム･ライブラリーの作成やメモリー
の許す限りのコンポーネント･ライブラリーを開いて作業することができます。各ラ
イブラリーに保存されるコンポーネント･フットプリントの数には制限がありませ
ん。

通常コンポーネントには、複数のパッドとコンポーネント本体を定義するためのオー
バーレイ･レイヤー上のトラックまたはアーク･セグメントがあります。
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ラララライイイイブブブブララララリリリリーーーーののののオオオオーーーーププププンンンン
Library Editorでライブラリーをオープンするには、EDA/Clientからドキュメントをオ
ープンすると同様にFile » Openメニューを選択します。Open Documentダイアログ･
ボックスでエディターをPCBLibに設定して、ライブラリーをオープンしてください。
メモリーの許す限りライブラリーをオープンすることができます。オープンされたそ
れぞれのライブラリーは独立したウィンドウに表示されます。

ラララライイイイブブブブララララリリリリーーーーのののの作作作作成成成成
新しくライブラリーを作成するには、File » New メニューを選択してください。
Select EDA Document Typeダイアログ･ボックスがポップ･アップ表示されます。一覧
の中からPCBLibを選択してください。ライブラリーが、PCBLIB_1.LIBという名前で
オープンされます。ライブラリーはコンポーネントの組みなので、ライブラリーに
は、複数のコンポーネントが必要です。従って、新しくライブラリーを作成する場
合、PCBCOMPONENT_1という空のコンポーネント･シートが用意されます。このラ
イブラリーに名前を付けて保存するには、File » Save As メニューを選択してくださ
い。コンポーネントの名前を変更するには、Tools » Rename Component メニュー
を選択してください。

ココココンンンンポポポポーーーーネネネネンンンントトトト････ウウウウィィィィザザザザーーーードドドドにににによよよよるるるるフフフフッッッットトトトププププリリリリンンンントトトトのののの作作作作成成成成
Advanced PCBには、フットプリントを作成するためのコンポーネント作成ウィザー
ドがあります。このウィザードは２、３の質問をして、単純な２ピンの抵抗から数百
ピンのPin Grid Arrayまでのコンポーネント･フットプリントを作成します。

Component Wizardを起動するには、Library EditorパネルのAddボタンを押すかTools
メニューのNew Componentメニューを選択してください。Wizardが起動しない場
合、CompMake Wizardサーバーをインストールする必要があります。

フフフフッッッットトトトププププリリリリンンンントトトトののののママママニニニニュュュュアアアアルルルル作作作作成成成成
フットプリントはPCBエディタで利用できるデザイン･オブジェクトと同じセットを
使用し、PCBライブラリー･エディタのなかで作成されます。コーナー･マーカーやフ
ォトツールタゲット、メカニカル･デフィニションなどもPCBフットプリントとして
保存することができます。

コンポーネント･フットプリントをマニュアルで作成する一般的な手順を以下に示し
ます。
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1. 新しいコンポーネントの作成 – ライブラリー･エディタに必要なライブラリーフ
ァイルをオープンしてください。Tools » New Component メニューを選択する
と コンポーネント･ウィザードが自動的にスタートしますが、マニュアルでコン
ポーネントを作成する場合はCancelを押して下さい。PCBComponet_1と呼ばれ
る空のコンポーネント･フットプリントが用意されます。Tools » Rename
Component を選択してこれを必要な名前に変更してください。コンポーネント
名は最高255文字まで設定できます。

2. パッドの配置 – コンポーネントの形状にあわせパッドを配置してください。パッ
ドがカーソル上で浮いている時にEdit » Jump » Reference (ショートカット; J,
R)を選択するとカーソルはワークスペースの0,0座標にジャンプします。最初の
パッドを配置する際にタブ･キーを押してパッドの属性を定義すると、後から配
置するパッドについても設定された属性になります。

è 表面実装部品のフット･プリントは通常、トップレイヤーに作成します。ボトムに
実装する場合は、PCBエディタで配置作業を行う際にショート･カットキーLを使
用し実装面を切り替えます。

3. コンポーネント･アウトライン – トラック･ツールを使用して、Top Overlayレイ
ヤーにコンポーネント･アウトラインを作成してください。SPACEBARでStartと
End配置モードを切替えることができます。SHIFT+SPACEBARを押すとトラッ
ク配置モードを変更できます。

4. 保存と配置 – ライブラリーを保存します。ライブラリーエディタでオープンして
いるライブラリーファイルのコンポーネントはPanelのPlaceボタンを使用し、ラ
イブラリーエディタから直接PCBエディタに配置できます。PCBエディタのコン
ポーネントの配置についてはコンポーネントとライブラリーを参照してくださ
い。

è コンポーネントはワークスペースの0,0のリファレンスポイントの周囲で作成して
ください。ReferenceはコンポーネントをPCBエディタに配置する時にコンポー
ネントの基準点になります。EditメニューのReferenceオプションを使用して、必
要に応じてReferenceを移動してください。

è デジグネータとコメント、スペシャル･ストリング  – スペシャル･ストリン
グ.DESIGNATOR と.COMMENT はライブラリー･エディタでコンポーネントに追
加され、コンポーネントのデジグネータとコメントのレイヤー、位置、テキスト
属性をコンポーネントを配置する前段階で指定することができます。また、これ
らのストリングスは既存のデジグネータとコメントに追加されるため、必要に応
じて既存のデジグネータとコメントを非表示にしてください。

フフフフッッッットトトトププププリリリリンンンントトトトののののアアアアッッッッププププデデデデーーーートトトト
PCBライブラリー･エディタで編集されたフットプリントは、PCB Library Editor
PanelのUpdate PCBボタンを使用し、現在開いているデザインのフットプリントを更
新することができます。
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フフフフッッッットトトトププププリリリリンンンントトトトののののココココピピピピーーーー
コンポーネントはクリップボードを介してライブラリー間でコピーできます。クリッ
プボードの使用についての詳細は、Advanced PCBの作業の編集の項を参照してくだ
さい。
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PCB 設設設設計計計計手手手手順順順順

基基基基板板板板外外外外形形形形のののの定定定定義義義義
PCBの設計を行なう上で、最初のステップは基板の定義を行なうことです。基板定義
には、メカニカル･アウトラインやキープ･アウト･バウンダリー、ディメンション･デ
ィテール、フォト･ツールタゲット、他社や他製造者向けの仕様があります。

è 基板がAutoCADのようなメカニカル･パッケージで定義されている場合、
ImportDXF機能を使用してその基板情報をAdvanced PCBへ取り込むことができま
す。詳細は、インポート･オプションの項を参照してください。

Advanced PCBで設計するすべてのものは、Placeメニューにあるデザイン･オブジェ
クトで扱われます。基板のキープ･アウト境界はKeep Outレイヤーのトラックとアー
クで作成されます。メカニカル境界は、メカニカルレイヤーのトラックとアークで作
成されます。また、ディメンションはディメンション･ツールで追加されます。

ワークスペースの左下で基板を設計すると便利です。アブソリュート･オリジンから
X、Y座標がそれぞれプラス１インチの座標を基板の左下のコーナーに設定するケース
がしばしば見られます。また、カレント･オリジンは必要に応じて設定することがで
きます。

ボボボボーーーードドドド････ウウウウィィィィザザザザーーーードドドド
Advanced PCBには、ボード･ウィザードがあり多くの業界標準基板テンプレートから
選択することができます。テンプレートには、タイトル･ブロックやアライメント･マ
ーカー、リファレンス･ルール、ディメンション、標準エッヂ･コネクターがありま
す。Wizardはタイトル･ブロックを塗り潰し、配線レイヤーの数やトラック／パッド
技術の指定が必要です。

また、自社のテンプレートをBoard Wizardに追加する事もできます。自分のテンプレ
ートをWizardに表示するには、以下が必要です。

· MyTemplates.BDLファイル。このファイルは、このタイプの基板が一覧になった
ASCIIファイルです。ファイル構造の例については、既存のBDLファイルを参照
してください。

· Wizardに表示する64X32ピクセルビットマップ。

· 各テンプレート用のPCBファイル。

BDL と ビ ッ ト マ ッ プ 、 PCB テ ン プ レ ー ト ･ フ ァ イ ル を デ ィ レ ク ト リ
c:\Client\Wizards\Pcbboard\に保存してください。

PCBMaker Wizard Serverがインストールされていると、PCBドキュメントを新しく作
成するためにFile » Newを選択すると自動的に起動されます。自動的に起動しない場
合、EDA/Clientのサーバーのインストールについての記述を参照してください。
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キキキキーーーーププププアアアアウウウウトトトトのののの使使使使用用用用ににににつつつついいいいてててて
配置、配線領域は、Keep Outレイヤーに境界を作成して定義します。通常、この境界
は基板の物理的なエッヂよりもわずかに内側に定義し、トラックやコンポーネントが
基板のエッヂに近づきすぎないようにします。この境界は、トラックやアークをKeep
Outレイヤーに配置することで作成します。コンポーネントやトラックはすべてこの
境界内に配置されます。この境界は、Design Rule Checkerや自動配置、自動配線で使
用されます。

また、コンポーネントやトラックが存在しない"禁止領域"を定義することもできま
す。これには、部品を実装したり基板プロファイリングに必要な領域を含むことがで
きます。また、これらの領域は、Keep Outレイヤー上のトラックやアーク、フィルの
ようなデザイン･オブジェクトを配置して作成することもできます。Keep Outレイヤ
ーの使用についての基本的なルールは、信号レイヤーの配線がKeep Outレイヤーのデ
ザイン･オブジェクトと交差しないということです。

è Keep Outレイヤーで定義されたキープ･アウト地域はすべての信号レイヤーに適
用されます。

メメメメカカカカニニニニカカカカルルルル定定定定義義義義
メカニカル定義に必要な詳細は、会社や製造者の要求によって違ってきます。通常、
製造者は基板のコーナーの指示や穴位置、外形のディメンションを最小にするように
要求します。

メカニカル･レイヤーを使用してメカニカル定義を作成してください。４枚のメカニ
カル･レイヤーの内容は、出力を作成中に他のレイヤーに追加することができます。
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ネネネネッッッットトトトリリリリスススストトトトにににに関関関関すすすするるるる作作作作業業業業
Electronic Design Automationツールは、プリント基板を作成するためのファイルを作
成することを通して電気設計の設計者の考えを具体化するプラットフォームが与えら
れます。設計を電気的に捉えることで、コンピュータを利用して設計を迅速で正確に
いろいろなデザイン段階で実行することができます。

これらの段階を通じて、設計はいろいろな形式で表現されます。それは、互いに接続
されたコンポーネントの集まりであるスケマチックで始まり、PCBデザイン･ツールか
ら作成されるファイルから製造されるプリント基板で終わります。

スケマチック･キャプチャー･ソフトウェアとPCBレイアウト･ソフトウェアの間でデ
ザインをやりとりするために ネットリストが使用されます。ネットリストには、デザ
インで使用されるコンポーネントやデシグネーションなどの情報が含まれています。
また、ネットリストには、デザインで作成された接続情報がネットの形式で保存され
ています。ネットは、電気的に接続されたコンポーネント･ピンのリストです。コン
ポーネント･ディテールや接続情報、ネットリストも含まれます。また、その他の情
報には、シミュレーション･データやPCBデザイン･パラメータがあります。

Advanced PCBの目的は、ネットリストの中のコンポーネントや接続情報を物理的な
レイアウトや接続に変換することです。

コンポーネントの配置は、PCB設計プロセスの基本的な部分です。このプロセスに
は、配線やメカニカル･パッケージ、ボード組立て、熱性能など様々な問題がありま
す。配置の方法についての詳細は、コンポーネントの配置の項を参照してください。

ネネネネッッッットトトトリリリリスススストトトトににににつつつついいいいてててて
ネットリストには、多くの異なるフォーマットがあります。しかし通常作成される
ASCIIテキスト･ファイル形式のフォーマットでは少なくとも２種類の情報が保存され
ています。

1. デザインのコンポーネントに関する情報。

2. デザインのピンからピンへのすべての接続情報。

ネットリストの中には、これらのデータを一つの記述に組み合わせたものがありま
す。その他には、２つのデータを分離したセクションに分けているものがあります。

ネットリストは簡単なユーザーが作成したプログラムで違うフォーマットに変換する
ことができます。また、ネットリストは、テキスト･エディタやワード･プロセッサに
より作成することもできます。
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どどどどののののよよよよううううににににネネネネッッッットトトトリリリリスススストトトトはははは表表表表示示示示さささされれれれるるるるかかかか

未結線のネットと途中まで結線されたネット

ネットリストをロードすると、Advanced PCBは各ネットのピンからピンへの接続を
細い線で表示します。ネットのピンとピンを接続する線は、From-Toと呼ばれます。
From-Toの集まりは ラッツネスト として参照されます。

From-Toの接続形式、もしくは接続する際のルールは、ネット･トポロジー と呼ばれ
ます。ユーザーがネットに対してネットトポロジーを定義していない場合、現在のコ
ンポーネントの配置に基づき、全体のネットが最短距離になるFrom Toルールが与え
られます。

ネットに対しトポロジーが適用されていれば、トポロジーを維持するためのFrom-To
が追加されます。これは配線されるべき2点間を点線によって表しています。

トポロジーはToplogy Ruleを通して、もしくは固定されたFrom-Toを定義することに
よってネットに適用されます。ネットトポロジーのデザインルールについてはPCB設
計手順(The PCB Design Process)の章のデザインルールの使い方の項目を参照してく
ださい。

From-ToU5

U6

U7

From-To
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ネネネネッッッットトトトリリリリスススストトトトののののロロロローーーードドドド
ネットをロードしなければならない理由が２つあります。1つはネットリストをロー
ドして基板設計を始めることと、2つめはスケマチックで変更された内容をネットリ
ストを再ロードし、PCBデザインに反映させるためです。この2つのプロセスがフォ
ワード･アノテーションです。

ネットリストをロードするには、Design » Netlist メニューを選択してください。ロ
ード/フォワード･アノテート･ネットリストダイアログ･ボックスがポップ･アップ表示
されます。Browseボタンを押してネットリストを選択しLoad Netlistダイアログ･ボッ
クスのOKをクリックしてください。

Advanced PCBは、ネットリストとワークスペース内のデザインデータとの間で解析
を行います。ネットリストと既存のデザイン･データのとの間で発見された違いによ
り、Advanced PCBはネットリスト･マクロを作成します。このMacroより、Advanced
PCBはネットリストに合わせるためにどのような操作が必要かが指示されます。

ネットリストを最初にロードする場合、Netlist Macrosはネットリスト全体で作成され
ます。設計が進んだ時点では、Netlist Macroはそれぞれの設計変更で作成されます。

Macrosと実行される操作の確認後、Executeボタンを押してください。

è マクロを実行する前に、全てのマクロエラーを修正してください。

è ネットリストをロードする前に、現在のライブラリー･リストに必要なコンポーネ
ント･ライブラリーが追加されることを確認してください。 (Design »
Add/Remove Library  )

Netlist Macros にににに関関関関すすすするるるる作作作作業業業業

Advanced PCBがネットリストとワークスペースのPCBデザインデータを解析して
Netlist Macroを作成した後、それらはLoad/Forward Annotate Netlistダイアログ･ボッ
クスに実行される順に表示されます。Macroコマンドには以下のものがあります。

· Remove Node
· Remove Net
· Remove Component
· Add Component
· Add Net
· Change Net Name
· Change Component Footprint
· Change Component Designator
· Add Node
· Change Component Comment
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ネットリストマクロを使用することによって、ネットリストロード後のPCBの状態を
把握することができ、マクロを追加、削除、編集することによってPCB上の変更をコ
ントロールすることができます。

ネネネネッッッットトトトリリリリスススストトトトママママククククロロロロのののの追追追追加加加加、、、、編編編編集集集集、、、、削削削削除除除除

設計変更の省略や実行する場合にこのオプションを使用してください。またスケマテ
ィックに戻らないでPCBネットリストを変更する場合にもこれらのオプションを使用
してください。ネットリストマクロを編集する際に注意する点は、

· DesignatorやNetのようなテキストを一致させてください。
· ネットリスト･ノードはComponentDesignator-PinNumberで指定してください。
例としてJ3-2のようにしてしてください。PCB Library Editoの要求に応じて、ピ
ン番号は最大で４文字までの英数字を使用してください。スペースを使用しない
でください。

· フットプリントは、現在のライブラリー･リストのライブラリーの中のフットプ
リントの名前と一致させてください。

· ネットリスト･マクロを実行してからスクリーンを再描画してください。
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ネネネネッッッットトトトリリリリスススストトトト････ママママククククロロロロのののの検検検検証証証証

マクロを編集したら、常にマクロを検証してください。これは、手動でマクロを作成
した場合特に重要です。マウスの右ボタンからValidateを実行し、それぞれのマクロ
を検証してください。検証の結果をレポートするにはマウスの右ボタンをクリック
し、Reportを選択してください。（マウスの右ボタンのクリックはネットリスト･マ
クロのリストの上で行ってください）

ネネネネッッッットトトトリリリリスススストトトト････ママママククククロロロロのののの再再再再生生生生成成成成

マウスの右ボタンで表示されるメニューからRegenerate を選択すると、既存のマク
ロをクリアしネットリストとPCBデザイン･データを再解析して新しいマクロを作成
します。

ネネネネッッッットトトトリリリリスススストトトト････ママママククククロロロロ････エエエエララララーーーーのののの確確確確認認認認

ネットリスト･マクロを実行する前に、エラーやワーニングを修正してください。以
下にエラーやワーニングについて示します。マクロがレポートするエラーやそのエラ
ーの原因を示します。

Net not found

対象となるネットがノードの追加や削除、ネットの削除、ネット名の変更を行なう場
合にPCBネットリストの中にありません。

Component not found

対象となるコンポーネントがノードの追加や削除、コンポーネントの削除、フットプ
リントやコメント、デジグネータの変更を行なう場合に、PCBネットリストの中にあ
りません。

Node Not found

対象となるノードがノードの追加や削除を行なう場合に、コンポーネントのピン、ま
たは指定されたネットにありません。

Net already exists

追加されるネット名がすでにPCBネットリストの中で使用されています。

Component already exists

追加されるコンポーネントのデジグネータがすでにPCBネットリストの中で使用され
ています。

New footprint not matching old footprint

コンポーネントを変更する際に、変更するフットプリントのピンと変更されるフット
プリントのピンがあっていません。これは、変更するコンポーネントが変更されるコ
ンポーネントよりピンが少なかったり、ネットリストでのピン番号の割り当ての方法
とPCBコンポーネントのピン番号の割り当ての方法が違う場合に起こります。
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Footprint not found in Library

コンポーネントの追加、もしくはコンポーネントを変更する場合に、指定されたフッ
トプリントがカレントリストライブラリーのライブラリー、またはライブラリーにな
い場合に参照されるクロスリファレンスファイル(ADVPCB.XRF)の中にありません。

Alternative footprint used instead (warning)

コンポーネントの追加、もしくはコンポーネントを変更する場合に、指定されたフッ
トプリントがカレントリストライブラリーのライブラリーには無く、ライブラリーに
無い場合に参照されるクロスリファレンスファイル(ADVPCB.XRF)にある場合、クロ
スリファレンスファイルで指定された代わりのフットプリントをカレントリストライ
ブラリーからロードします。このワーニングが発生したら代わりのフットプリントが
正しいかどうか確認して下さい。

è ネットリスト･マクロはライブラリーに無いコンポーネント･フットプリントをロ
ードしたり変更しようとすると、コンポーネントのコメントを元にクロスリファ
レンスファイル（ADVPCB.XRF）を探します。クロスリファレンスファイルに
は、型式によってコンポーネントをリストしています。例えば、コンポーネント
U1が74LS00でフットプリントの記述が無い場合、このコンポーネントに追加す
るマクロは、XRFファイルの中から74LS00を探し出します。74LS00がDIP14と
いうフットプリントを持っています。これは、現在のライブラリー･リストからロ
ードされます。

Summary

スケマチック･ネットリストをロードする時の問題のほとんどは、通常２つに分類さ
れます。

1. コンポーネント･フットプリント－ネット･リストにコンポーネント情報が無かっ
たり現在のライブラリー･リストに必要なPCBライブラリーを追加し忘れたり
(Design » Add/Remove Library )、ネットリストのフットプリントがAdvanced
PCBのライブラリー･コンポーネントと一致しない場合です。

2. 古いフットプリントと新しいフットプリントが一致しない－スケマチック･コン
ポーネントのピン番号の割り当ての方法とPCBフットプリントでのピン番号の割
り当ての方法が一致していないことが原因です。

スケマティック･ライブラリーには、特定のコンポーネントやデバイスがあります。
Advanced PCBコンポーネント･ライブラリーには一般的なフットプリントがあり、そ
のフットプリントはピンアサインの違ういろいろな特定のコンポーネントに割り当て
ることができます。

例えば、トランジスタは、"E"、"B"、"C"のいろいろな組み合わせで表現されます。そ
れぞれのピンはAdvanced PCBで正しくピンに番号付けされる必要があります。ダイ
オードも同様に"A"、"K"というピン番号をスケマティックで使用される場合がありま
す。

PCBフットプリントのピン番号を変更してスケマチックのピン番号に合わせるか、ス
ケマチック･コンポーネントのピン番号を変更してPCBフットプリントに合わせるか
のどちらかの作業が必要です。
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Net Topology
ネットリストがロードされると、各ネットのピンとピンの接続が表示されます。ピン
とピンの接続に関するアレンジやパターンをネット･トポロジーと呼びます。デフォ
ルトでは、Advanced PCBにより各ネットのピンとピンとの接続長が最短になるよう
にアレンジされます。（このトポロジーはShortestと呼ばれます。）異なるトポロジ
ーをネットに適用することもできます。

ネットのトポロジーが再定義される理由はさまざまです。高速回路を設計する場合、
信号ラインの反射を最小にすることが要求されます。この要求を満足させるには、高
速信号のネットに対して、一方を終端とするソースピンともう一方を終端とするター
ミネータピンの間を次々につないでいくデイジーチェーンでアレンジされる必要があ
ります。他にもデザインによってはすべてのグランドピンをグランドネットのコモン
ポイントに接続する場合があります。スター･トポロジーを適用すると、このような
接続を確実に行う事ができます。

Specifying Net Topology

Advanced PCBのネットに特定のトポロジーを適用する方法が２つあります。一つ
は、ネット･レベルで適用する方法で、二つ目は個々のピンからピンの接続に対し
て、またはFrom-Toレベルで適用する方法です。デザインに特定のトポロジーを必要
とするネットがある場合、Routing Topologyデザイン･ルールをそのネットに適用して
ください。Routing Topologyデザイン･ルールについての詳細は デザイン･ルールの項
を参照してください。特定のネットのトポロジーを部分的に、またはすべてを指定す
る場合、トポロジーをコントロールしたいネット部分の From-Tosを定義してくださ
い。

From-Tos
配置の全体的な配置やネットのピンとピンの接続のパターンをコントロールする場
合、Advanced PCBによりFrom-Toの組みを定義することができます。From-Toによ
り、Advanced PCBは、「私は、このピンからあのピンに接続したい。」という指示
がされます。

一つのネットに一つのFrom-Toを定義することや、ネットの特定の部分に２、３の
From-Toを定義することができます。またすべてのピンからピンの接続を定義してネ
ットのトポロジー全体を指定することもできます。ネットの限定された部分にだけ
From-Toを作成する場合、Advanced PCBはピンからピンへの接続を最短のトポロジ
ーに設定します。

From-Toを使用して特定のネット･トポロジーを作成するのと同様に、From-Toをデザ
イン･ルールのスコープとして使用することができます。デザイン･ルールのスコープ
は、どのルールが適用されるかを指示します。From-Toをスコープとして使用する
と、ルールを各ピンからピンへの接続に適用できます。これにより、どのようなルー
ルがネットに適用されるかをコントロールすることができます。ネットをひとつの
From-Toを除いて25milsで配線することを指定することができます。デザイン･ルール
とそのスコープについての詳細は、デザイン･ルールの項を参照してください。
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Creating From-Tos

ネットのFrom-Toを指定するには、Design-From-Toエディタ･メニューを選択してく
ださい。From-Toエディタが表示されます。

From-To EditorでのFrom-Tosの作成と削除。

From-Toを指定したいネットを選択してください。このネットの中のピンはすべてグ
ラフィカルウィンドウの右側に表示されます。既存のFrom-Toはグラフィカルウィン
ドウ内の2つのピンを接続する細い線で表示されます。また、それらはネット名の下
に一覧表示されます。

Auto-Generated From-Tos

ネット全体のFrom-Tosのセットを作成するには、From-ToエディターのAuto-
Generateボタンを使用してください。これらのボタンはネット全体のFrom-Toのセッ
トを作成します。

Shortest

デフォルトでは、Advanced PCBは、ネットのピンからピンへの接続が最短になるよ
うにアレンジします。このボタンを押すとFrom-Toが削除され、shortestトポロジーで
ピンとピンが自動的に接続されます。
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Daisy-Simple

シンプル･デイジー･チェーン･トポロジーでは、ノード（ピン）はすべて互いにチェ
ーンで接続されたようになります。それらがチェーン接続される順番は、長さが最短
になるように計算されます。ソースとターミネータのパッドが指定されると、その他
のパッドは、その間で最短距離になるようにチェーン状に接続されます。パッドを編
集（パッド上をダブルクリックする）してソースかターミネータを設定してくださ
い。ソース、またはターミネータパッドが複数ある場合、それぞれの終点のパッドで
チェーン状に接続されます。

Daisy-Mid Driven

ミッド･ドリブン･デイジー･チェーン･トポロジーでは、ソース･ノードはデイジー･チ
ェーンの中央に配置され、ソースに対してロードは等しく分割されます。そのため終
端には２つのターミネータが必要になります。複数のソースノードは互いに中央で接
続されます。２つのターミネータが正しく設定されていない、シンプル･デイジー･ト
ポロジーが使用されます。

Daisy-Balanced

バランスト･デイジー･チェーン･トポロジーでは、ロードはすべて同じ数のチェーン
に分割されます。分割されるチェーンの数は、ターミネータの数と同じになります。
これらのチェーンは、ソースにスター･パターンで接続されます。複数のソースノー
ドは互いに接続されます。

Star

このトポロジーは各ノードを直接ソースノードに接続します。ターミネータがある場
合、それらは各ロード･ノードの後に接続されます。複数のソース･ノードは、バラン
スト･デイジー･トポロジーのように互いに接続されます。
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ピピピピンンンンととととピピピピンンンンののののココココネネネネククククシシシショョョョンンンンのののの表表表表示示示示
ラッツネストをより扱いやすくするためにAdvanced PCBでは、ピンからピンへの接
続ラインの表示、非表示を選択的に行うことができます。View » Connections  サブ
メニューを選択してください。

Net

選択されたネットのピンからピンへの接続の表示と非表示を行ないます。このオ
プションを選択すると、クロス･ヘア･カーソルが表示されます。ネット上のパッ
ドの位置がわかる場合、そのパッドをクリックしてください。わからない場合、
何もない場所をクリックしてダイアログ･ボックスを表示しネット名を入力して
ください。ネット名がよくわからない場合、？を入力してOKをクリックするとロ
ードされたネットがすべて表示されます。

Component Nets

選択されたコンポーネントに接続するすべてのネットのピンからピンへの接続の
表示と非表示を行ないます。

All

現在ロードされている接続のすべての表示と非表示を行ないます。

è デザインにたくさんのノードを持つネットがある場合、コネクションのモニタリ
ングに多くの時間が必要になります。この場合、特定のネットを“Hide”にする
ことによってモニタリングされるネットから除外されます。特定のネットを
“Hide”にするには、View » Connections » Hide Net を選択し目的のネットを
選択してください。

ネネネネッッッットトトト属属属属性性性性のののの変変変変更更更更
パッド、トラック、ビアなどのデザインオブジェクトにはそれぞれネットの属性を持
っています。ネットの属性を編集するには、PCB PanelのBrowseモードをNetsに設定
して、ネットを選択しEditボタンを押してください。Change Netダイアログ･ボック
スが表示され選択されたネットの属性を編集することができます。

Color

ネットリストがロードされると、各ネットにはデフォルトのネット色が割り付け
られます。ネットのカラーはここで変更することができます。

Hide

このネットのコネクション･ラインの表示、非表示を行います。グローバル編集
によっていくつかのネットの表示、非表示ができます。

è Document Optionsダイアログ･ボックスのLayerタブには、Connectレイヤーの表
示をon/offするチェック･ボックスがあります。これがoffの場合、各ネットのHide
属性に関らずコネクション･ラインは表示されません。
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ロロロローーーードドドドさささされれれれたたたたネネネネッッッットトトトののののググググロロロローーーーババババルルルル編編編編集集集集

ネット属性はグローバルチェンジオプションを使用し、グローバルに編集することが
でき、また、ネット名にワイルドカード使った条件付けも可能です。例えば、変更を
行う際のネット名を、”D*”とした場合、ネットネーム、”D1”、”D2”に対してもグロー
バルチェンジが適用されます。

ネネネネッッッットトトトのののの識識識識別別別別
PCB:IdentifyNetプロセスを使用して、任意のネットを識別します。カーソルをコネク
ション･ラインの上に置いてENTERまたはマウスの左ボタンを押してください。ネッ
トの名前がステータス･バーに表示されます。

ネネネネッッッットトトトリリリリスススストトトトののののエエエエククククススススポポポポーーーートトトト
ネットリストをエクスポートする方法については、エクスポート･オプションの項を
参照してください。

エエエエンンンンジジジジニニニニアアアアリリリリンンンンググググ････チチチチェェェェンンンンジジジジ････オオオオーーーーダダダダーーーー
ネットリストに影響するPCBの変更は、エンジニアリング･チェンジ･オーダーファイ
ル（ファイル名.ECO）に書き込まれます。ECO機能をアクティブにし、ECOテキス
トファイルの名前をDocument Optionダイアログ･ボックスのOptionsタブのページで
入力してください。

ECOファイルに保存される変更には次のものがあります。新しいネットの作成、ネッ
トの名前の変更、ネットへのノードの追加、ネットからのノードの削除、コンポーネ
ントの追加、コンポーネントの削除、コンポーネント･フットプリントの変更、コン
ポーネントの部品番号の変更。

Protelの.ECOファイルのフォーマットは、PADS.ECOファイルと完全に互換性があり
ます。

è ECO機能を無効にするとシステムパフォーマンスが改善されます。

ネネネネッッッットトトトリリリリスススストトトト････フフフフォォォォーーーーママママッッッットトトト

Protel ネネネネッッッットトトトリリリリスススストトトトフフフフォォォォーーーーママママッッッットトトト

Protelネットリストの最初の部分には、各コンポーネントの記述があります。   

[ 各コンポーネントの記述の始めをあらわすマーク。
U8 コンポーネント･デジグネータ (ラベル)。
DIP16 パッケージの記述(フットプリント)。この名前を持つ

PCBライブラリー内のフットプリントが読み込まれま
す。

74LS138 パートタイプ (またはコメント)。
(blank) これらの3行は使用されません。
(blank)
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(blank)
] コンポーネントの記述の終わりを表すマーク。

Protelネットリストの2番目の部分は各ネットの記述です。

( 各ネットの始まりを示すマーク。
CLK ネットの名前。
U8-3 最初のコンポーネントとピン番号。Advanced PCBラ

イブラリー･フットプリントのピン番号と一致する必
要があります。

J21-1 ネットの次のノード。
U5-5 3つめのノード。
) ネットの終わりを示すマーク。

Protel Netlist 2.0 Format

このフォーマットは標準のプロテルネットリストに近いフォーマットです。このフォ
ーマットにはスケマティックパーツフィールド(ドキュメンテーションやシミュレーシ
ョンで使用される )やネット属性を表すレイアウトディレクティブがあります。
Advanced PCBバージョン2.0以降のものはこのフォーマットをロードすることが可能
です。(※Advanced PCB98での対応は現在準備中です)

PROTEL NETLIST 2.0ネットリストヘッダー
[ コンポーネントの始めのマーク
DESIGNATOR (最初に名前がつけられた各フィールド)

U1 コンポーネントデジグネータ
FOOTPRINT
DIP20 ライブラリーパターン(フットプリント)
PARTTYPE
AmPAL16L8 パーツタイプフィールド
DESCRIPTION
Description スケマティックからの記述フィールド
PART FIELD 1 (スケマティックで定義できるフィールド)

Part Field 1 スケマティックからのパーツフィールド(1-16)
(etc.)
LIBRARYFIELD1
Library Part Field 1 スケマティックリブからのライブラリフィールド(1-

8)
] コンポーネントの終わりのマーク
( ネットの始めのマーク
VCC ネット名
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U1-20 AMPAL16L8-VCC POWER
ネットの最初のノード
Includes: コンポーネントピンデジグネータ

(single blank space)
パーツタイプ-ピン名

(single blank space)
ピンのエレクトリカルタイプ

U2-14 4001-VCC POWER 
ネットの最後のコンポーネントのピンノード

) ネットの終わりのマーク
{ レイアウトディレクティブの始めのマーク
TRACK (最初に名前がつけられた各フィールド)

10 トラックにサイズ(mils)
VIA
50 ビアのサイズ(mils)
NET TOPOLOGY
SHORTEST 配線のネットトポロジー
ROUTING PRIORITY
MEDIUM 配線の優先順位
LAYER
UNDEFINED 配線レイヤー
} レイアウトディレクティブの終わりのマーク

ネネネネッッッットトトトリリリリスススストトトト････パパパパララララメメメメーーーータタタタ

デジグネータとパッケージディスクリプションは12文字、パートタイプは32文字、ネ
ットネームは20文字、ネットリストのピン番号は4文字とそれぞれのパラメータには
制限があります。(文字はすべて半角英数)ブランクやスペースは使用できません。

Advanced PCBネットリストには、メモリの許す限りの数のコンポーネントやノード
を記述することができます。

そそそそのののの他他他他ののののネネネネッッッットトトトリリリリスススストトトトフフフフォォォォーーーーママママッッッットトトト

Protel Hierarchicalネットリスト･フォーマットは、Protel2フォーマットと同じ構造で
す。ただし、各シートのコンポーネントやネットの詳細はネットリスト･ファイルに
別々に記録されます。

スケマティック･キャプチャー･パッケージからのネットリストは通常Protelのフォー
マットと良く似ています。しかし、コンポーネントや情報が表示される順番は違いま
す。また、パッケージ名やコンポーネント･デジグネータ、ピン識別子はAdvanced
PCBのフィールド規則に合うように編集する必要があります。スケマチック･パッケ
ージには、よくネットリストの変換オプションがついています。ProtelまたはTango出
力オプションを使用して作成されたネットリストは、Advanced PCBで互換性があり
ます。
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デデデデザザザザイイイインンンン････ルルルルーーーールルルル
PCBデザインは、もはや単純にトラックを配置してパターンを作成していくだけでは
ありません。複雑で小型のパッケージと組み合わされた高速ロジックはPCB設計者に
新たな要求をもたらしています。もはや、トラックやパッド、ビアのクリアランスを
考慮するだけではすべての設計を満足できなくなっています。今日のPCB設計は、特
定の条件を個々のネット、コンポーネント、ボード領域に適用するだけでなく、クロ
ストーク、反射やパターン長の問題について考慮することを要求しています。これら
の設計要求を満足するには、これらの要求を管理･テストするツールが必要です。

Advanced PCBには、多くのデザイン･ルールが組み込まれています。これらの中に
は、クリアランスやオブジェクト･ジオメトリー、パラレリズム、インピーダンス･コ
ントロール、配線順位、配線トポロジーに関するルールがあります。各ルールには、
それをどのように適用するかを定義するRule Scopeがあります。ルール･スコープに
よりオブジェクトやネット、ネット･クラス、コンポーネント、コンポーネント･クラ
ス、レイヤー、領域、基板全体にルールを適用することができます。

デデデデザザザザイイイインンンン････ルルルルーーーールルルルととととはははは????
PCBを設計するにはコンポーネントやトラック、ビア、その他のデザイン･オブジェ
クトを配置します。これらのオブジェクトは、互いの関係を考慮してワークスペース
に配置する必要があります。コンポーネントは重ならないように、ネットはショート
しないように、電源ラインと信号ラインとは分離して、異なるネットは異なるパター
ン幅で配線され、あるネットは同じパターン長で、などです。

Advanced PCBでは、これらのデザインの要求を管理することができます。設計者は
デザインルールの一連の設定を、PCB設計の条件としてAdvanced PCBに指示するこ
とができます。Advanced PCBはワークスペース内のオブジェクトの配置を監視し、
オブジェクトがルールに違反して配置されるとハイライト表示されます。
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デデデデザザザザイイイインンンンルルルルーーーールルルルのののの定定定定義義義義

デデデデザザザザイイイインンンンルルルルーーーールルルルをををを定定定定義義義義すすすするるるるににににはははは????

デザインルールはDesign Rulesダイアログにリストされます。このダイアログを表示
させるにはDesign » Rules メニューを選択してください。

Advanced PCBで設定できるルールはDesign Rulesダイアログボックスのタブによっ
て4つに分類されています。左側には各タブごとに設定されたルールの一覧が表示さ
れ、隣には現在選択されているルールの説明が表示されます。別のルールを選択する
にはカーソルを移動し、別のルールのタブをクリックしてください。ダイアログの下
半分にはすでに定義されているルールの一覧が表示されます。

Design Rules ダイアログを使ってデザインルールの編集や確認を行います。



The PCB Design Process

ルルルルーーーールルルルのののの追追追追加加加加

ルールを追加するにはDesign Rulesダイアログで目的にルールを選択し、次にAddボ
タンをクリックします。(ショートカット；ルール上でマウスの左ボタンをダブルクリ
ック)Addボタンをクリックするとルールを定義するためのダイアログが表示されま
す。ここでルールとスコープを設定します。

各ルールはRuleダイアログで設定されます。

ルルルルーーーールルルル････ススススココココーーーーププププととととはははは????

スコープ、すなわちルールの範囲は、Rule Scopeにより決められます。スコープによ
り、特定のルールが適用されるターゲット･オブジェクトのセットを定義することが
できます。スコープを設定することにより、ルールを基板全体に適用したり、特定の
ネットやコンポーネント、パッドに適用できます。

例えば、デザインに100milsのクリアランスが必要なメイン･レベル電圧と10milsのク
リアランスが必要なロジックレベル電圧があるとします。

これらの要求は、２つのコパー･クリアランス･ルールを定義し、それぞれルールスコ
ープの範囲をセットすることにより満足されます。高電圧の基板エリアには100milsの
クリアランスルールを設定し、その他のエリアには10milsのクリアランスルールで設
定します。

ウウウウナナナナリリリリーーーー････ルルルルーーーールルルルととととババババイイイイナナナナリリリリーーーー････ルルルルーーーールルルル

デザイン･ルールには、ウナリー･ルールと バイナリー･ルールの２つのタイプがあり
ます。ウナリー･ルールは一つのオブジェクト、またはオブジェクト･セットの中の各
オブジェクト適用されます。バイナリー･ルールは２つのオブジェクトまたは、任意
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のオブジェクト･セットの中のオブジェクト同士の間に適用されます。ウナリー･ルー
ルの例は、ソルダー･マスク･エクスパンション･ルールです。このルールは、ルール･
スコープで識別される各パッド毎に適用されます。バイナリー･ルールの例は、コパ
ー･オブジェクトに間に適用されるコパー･クリアランスです。ウナリー･ルールを設
定すると、ルール･スコープが一つ設定され、バイナリー･ルールを設定すると、ルー
ル･スコープが２つ設定されます。

複複複複数数数数ののののルルルルーーーールルルルとととと優優優優先先先先さささされれれれるるるるルルルルーーーールルルル

ルール･スコープにより、特定のルールを適用したいものを正確に識別できます。例
えば、クリアランスの制約をネットや基板領域、各パッドに適用することができます

適用したいルールやオブジェクトのセットを定義するのにスコープを使用するのと同
じように、同じ種類の他のルールを置き換えるためにスコープを使用することもでき
ます。

各ルールは、必要な数だけ適用することができます。例えば、ソルダー･マスク･エク
スパンション･ルールを基板全体に適用し、２つめのソルダー･マスク･エクスパンシ
ョン･ルールを特定のコンポーネントに、さらに３つめのソルダー･マスク･エクスパ
ンション･ルールを同じコンポーネントの個々のパッドに適用することができます。
Advanced PCBにより、異なるスコープの同じ種類のルールの優先順位に基づいて、
このパッドへこれら３つのルールの適用が行われます。ルール･スコープの優先順位
を、順位の高い方から低い方に示します。

· Region (highest priority)
· Pad
· From-To
· From-To Class
· Net
· Net Class
· Component
· Component Class
· Object Kind
· Layer
· Whole Board (lowest priority)

これにより、ルールを最も一般的なルールと最も特殊なルールに分けて使用すること
ができます。一般的なルールは基板全体に適用してください。それからより優先順位
の高いルールを適用して設計要求を満足してください。Advanced PCBは各デザイン･
オブジェクトに適用されるルールを解析し最高順位のルールを識別しそれを適用しま
す。

è 優先順位を記憶する必要がないように、ルール･スコープは常に最高順位から最低
順位にドロップ･ダウン･リスト･ボックスの中に表示されます。

ルルルルーーーールルルルのののの重重重重複複複複にににによよよよるるるる競競競競合合合合

一つのオブジェクトに対して、同じスコープの複数のルールが適用された
場合(例えばパッドに、2つのSolder Mask Expansion Ruleが適用されており、
どちらともスコープの設定がRegionで領域がオーバーラップしている) 競合
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が発生します。Advanced PCBには、予め定義された競合を解決するための
ルールがあります。基本的な考え方は、より安全な方の選択です。これが
どのように解釈されるかは各ルールのドキュメントを参照してください。

ルルルルーーーールルルル････ススススココココーーーーププププのののの設設設設定定定定方方方方法法法法

デザインの要求を満足させるルールの使い方にはいろいろな方法があります。複数の
オブジェクトに同じルールを適用したい場合があります。その場合、Net Classやコン
ポーネント･クラス、from-toクラスを用いて、ユーザー定義のオブジェクト･クラスを
作成することができます。

ワイルドカードを使用してオブジェクトのセットを定義することもできます。任意の
１文字(?)のワイルドカードと任意の文字列(*)のワイルドカードをサポートしていま
す。

シグナル･ネットから高電圧ネットを分離する前記の設計要求を思い出してくださ
い。この要求は、領域にスコープを設定して２つのクリアランス･ルールを用いて実
現しました。以下の図は、２つのやり方を示しています。最初は、ネット･ルール･ス
コープとワイルドカードを使う方法で、２番目はネット･クラス･ルール･スコープを
使用する方法です。ネット･ルール･スコープの例では、高電圧ネットはすべて文字列
POWERで始まるネット名を持つと仮定しています。

è 代わりにネットクラスとして作成されたPowerを割り当てる場合、スコープを
NetClassに設定します。

ワイルドカードを使ったネットの設定
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このクリアランス･ルールにより、「文字列POWERで始まる名前のネットは基板全体
で他のオブジェクトから少なくとも100mils離れている必要があります。」という指定
がされます。クリアランスは、任意のPOWER*ネットと信号ネットとの間でも保持さ
れ、POWER*ネット同士でも少なくとも100milsのクリアランスが保たれます。

ルルルルーーーールルルルのののの適適適適用用用用ににににつつつついいいいてててて

Advanced PCBのルールは以下の状態で適用されます。

On-line Design Rule Check (DRC)

配置中に違反が発生するとすぐにルール違反通知されます。ルール違反は、現在
のDRCカラーで違反のオブジェクトの輪郭が縁取られて知らされます。On-line
DRC機能は、Preferencesダイアログ･ボックスのOptionsタブで無効にすることが
できます。

Batch DRC

Tools » Design Rule Check メニューを選択すると、Chose Rule Set to Checkダ
イアログ･ボックスが表示されます。テストしたいものを入力してOKボタンをク
リックしてください。チェックされているルールタイプのインスタンスがテスト
されます。

通知される違反の数を設定することができます。

During a software operation

あるルールは、ソフトウェアの操作中にモニターされます。すなわち、多角形の
注入中や、自動配線中、自動配置中、出力の生成中です。例えば、マスク･エク
スパンション･ルールは出力の生成中にモニターされ、配線ビア･スタイル･ルー
ルは自動配線中にモニターされます。

Exporting the Design

Specctra™オートルータなど機能をサポートするためのルールは、デザインと一
緒にエクスポートされます。

各ルールがいつ適用されるかはルールによって異なります。
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Rule Definitions

Acute Angle Constraint ((((ココココーーーーナナナナーーーー角角角角度度度度))))

内内内内容容容容

トラックのコーナーに許される最小の角度を指定します。鋭角なコーナーは、製造時
にコーナーでコパーのオーバーエッチングの原因になるために問題になります。

Scopeのののの設設設設定定定定

Whole Board、Layer、Net Class、Net、From-To Class、From-To、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

最大の角度。

ルルルルーーーールルルルのののの適適適適用用用用

Batch DRC.

Copper Clearance Constraint ((((ククククリリリリアアアアラララランンンンスススス))))

内内内内容容容容

コパー･レイヤー上の任意の２つのプリミティブ･オブジェクトの間の最小のクリアラ
ンスを定義します。クリアランス制限を使用して配線クリアランスが確保されます。

Scopeのののの設設設設定定定定

Whole Board、Layer、Object Kind、Component Class、Component、Net Class、
Net、From-To Class、From-To、Pad。

Connective Checking

通常は、Different Nets に設定してください。Any Netが使用される場合の例は、パッ
ドやビアに近すぎるビアのテストをする場合です。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

最大のクリアランス。

ルルルルーーーールルルルのののの適適適適用用用用

On-line DRC,、Batch DRC 、自動配線中。
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Daisy Chain Stub Length( ススススタタタタブブブブ長長長長））））

内内内内容容容容

デイジー･チェーン･トポロジーのネットの最大のスタブ長さを指定します。

Scopeのののの設設設設定定定定

Whole Board、Net Class、Net。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

一番短いスタブ長。

ルルルルーーーールルルルのののの適適適適用用用用

Batch DRC。

Matched Net Lengths ((((等等等等長長長長配配配配線線線線))))

内内内内容容容容

ネットが違う長さを持つことができる度合を指定します。Advanced PCBは、最長の
ネットを配置し、それをスコープで指定された他のネットと比較します。

Matched Net Lengthsダイアログ･ボックスにより、長さの要求に合わないネットの長
さをどのくらいに合わせるかを指定できます。Advanced PCBは、アコーディオン･セ
クションを追加してネットの長さを調整します。

Advanced PCBにアコーディオン･セクションを利用してネットの長さを調整させたい
場合、Matched Length Rulesダイアログ･ボックスを設定してTools » Equalize Nets
メニューを選択してください。matched length ruleはルールにより指定されたネット
に適用されアコーディオン･セクションがこれらのネットに追加されます。適合の度
合は、アコーディオン･セクションに使用できる空間の面積によります。90°スタイ
ルが最もコンパクトになり、ラウンド･スタイルが最も大きくなります。

Scopeのののの設設設設定定定定

Whole Board、Net Class、Net、From-To Class、From-To。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

指定された最小の誤差。

ルルルルーーーールルルルのののの適適適適用用用用

Batch DRC。
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Maximum Via Count （（（（ビビビビアアアア数数数数のののの制制制制限限限限））））

内内内内容容容容

使用するビア数を制限します。

Scopeのののの設設設設定定定定

Whole Board、Net Class、Net、From-To Class、From-To、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

ビア数が最も少ないルール。

ルルルルーーーールルルルのののの適適適適用用用用

Batch DRC。

Minimum Annular Ring （（（（最最最最小小小小アアアアニニニニュュュュララララ････リリリリンンンンググググ））））

内内内内容容容容

パッド上で許される最小のアニュラ･リングを指定します。アニュラ･リングはパッ
ド･ホールからパッドのエッヂへ放射状に計測されます。

Scopeのののの設設設設定定定定

Whole Board、Object Kind、Component Class、Component、Net Class、Net、From-
To Class、From-To、Pad、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

最大のアニュラ･リングのルール

ルルルルーーーールルルルのののの適適適適用用用用

Batch DRC。

Min-Max Length Constraint （（（（パパパパタタタターーーーンンンン長長長長のののの最最最最短短短短、、、、最最最最長長長長））））

内内内内容容容容

ネットの長さの最長と最短を指定します。

Scopeのののの設設設設定定定定

Whole Board、Net Class、Net、From-To Class、From-To。

ルルルルーーーー----ルルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

最もタイトなレンジを指定されたルール。
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ルルルルーーーールルルルのののの適適適適用用用用

Batch DRC。

Parallel Segment Constraint （（（（平平平平行行行行性性性性））））

内内内内容容容容

２つのトラック･セグメントを平行に配置できる距離を指定します。このルールはト
ラック･セグメントをテストするもので、トラック･セグメントを束ねることはしませ
ん。クロストーク特性のあるネットの複数のパラレル･セグメントの制限に適用して
ください。

Scopeのののの設設設設定定定定

Whole Board、Layer、Net Class、Net、From-To Class、From-To。

Whole Board、Layer、Net Net Class、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

このルールでは、ルールが重複しても競合が起こりません。

ルルルルーーーールルルルのののの適適適適用用用用

On-line DRCとBatch DRC。

Paste-Mask Expansion Rule （（（（ペペペペーーーースススストトトト････ママママススススクククク））））

内内内内容容容容

各パッドのサイトのペースト･マスク･レイヤーで作成される形状は、パッド･シェイ
プでこのパッド･シェイプはこのルールで指定されるExpansionにより放射状に拡張ま
たは収縮されます。

Scopeのののの設設設設定定定定

Whole Board、Layer、Component Class、Component、Net Class、Net、Pad、
Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

エクスパンジョンが最小のルール。

ルルルルーーーールルルルのののの適適適適用用用用

出力の作成中。
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Polygon Connect Style ((((ポポポポリリリリゴゴゴゴンンンンのののの接接接接続続続続ススススタタタタイイイイルルルル))))

内内内内容容容容

コンポーネントからポリゴン･プレーンへの接続スタイルを指定します。２種類の接
続方法を使用できます。一つは、ダイレクト接続（ピンへのソリッド･コパー）、も
う一つは、サーマル･リリーフ接続です。

Relief Connectを選択すると、サーマル･リリーフ･コパー接続の幅や接続の数、接続
の角度を定義する必要があります。

Scopeのののの設設設設定定定定

Whole Board、Net、Net Class、Component、Component Class、Pad、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

最初にダイレクト接続を指定するルール。

ルルルルーーーールルルルのののの適適適適用用用用

ポリゴンのハッチングを行っているとき。

Power Plane Clearance ((((内内内内層層層層パパパパワワワワーーーー････ププププレレレレーーーーンンンンククククリリリリアアアアラララランンンンスススス))))

内内内内容容容容

パワー･プレーンを通過するビアやパッドの周囲に形成される半径方向のクリアラン
スを指定します。

Scopeのののの設設設設定定定定

Whole Board、Object Kind、Component Class、Component、Net Class、Net、From-
To Class、From-To、Pad、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

最大のエクスパンジョンを指定するルール。

ルルルルーーーールルルルのののの適適適適用用用用

出力の作成中。

Power Plane Connect Style( 内内内内層層層層パパパパワワワワーーーー････ププププレレレレーーーーンンンン････接接接接続続続続ススススタタタタイイイイルルルル)

内内内内容容容容

コンポーネント･ピンからパワー･プレーンへの接続スタイルを指定します。２種類の
接続方法を使用できます。一つは、ダイレクト接続（ピンへのソリッド･コパー）、
もう一つは、サーマル･リリーフ接続です。
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Relief Connectを選択すると、サーマル･リリーフ･コパー接続の幅や穴のエッヂから
エア･ギャップのエッヂまでの拡大幅、エア･ギャップの幅を定義する必要がありま
す。AdvancedPCBでは、パワー･プレーンは反転して構成されます。従って、パワー･
プレーンに配置されるプリミティブは銅箔のない部分を形成します。

Scopeのののの設設設設定定定定

Whole Board、Net、Net Class、Component、Component Class、Pad、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

Direct Connectionを指定するルール。

ルルルルーーーールルルルのののの適適適適用用用用

出力の作成中。

Routing Corners Rule ((((配配配配線線線線ココココーーーーナナナナーーーーのののの処処処処理理理理))))

内内内内容容容容

自動配線中に使用されるコーナー･スタイルを指定します。コーナー･スタイルには、
45 degree chamberとroundedがあります。セットバックにより、コーナー位置からコ
ーナー･チャンバーの始めまでの距離の最大と最小を指定してください。

Scopeのののの設設設設定定定定

Whole Board、Layer、Net、Net Class、Component、Component Class、Pad、
Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

ルールが重複した場合、Rounded,90/45 degrees,90 degreesの順番でルールが適用さ
れます。

ルルルルーーーールルルルのののの適適適適用用用用

自動配線中。

Routing Layers Rule ((((配配配配線線線線レレレレイイイイヤヤヤヤーーーー))))

内内内内容容容容

自動配線中に使用されるレイヤーを指定します。

Scopeのののの設設設設定定定定

Whole Board、Net、Net Class、Component、Component Class、Pad、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

レイヤーの数の最小のルール。
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ルルルルーーーールルルルのののの適適適適用用用用

自動配線中。

Routing Priority Rule ((((配配配配線線線線のののの優優優優先先先先順順順順位位位位))))

内内内内容容容容

配線の優先順位を0から100までで割り付けます。100が最高の優先順位で0が最低の優
先順位です。Routing Priorityは、ネットが自動配線される順番を設定するために使用
される相対的な値です。

Scopeのののの設設設設定定定定

Whole Board、Net Class、Net、From-To Class、From-To。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

優先順位が最も高いルール。

ルルルルーーーールルルルのののの適適適適用用用用

自動配線中。

Routing Topology Rule ((((配配配配線線線線トトトトポポポポロロロロジジジジーーーー))))

内内内内容容容容

ネットのトポロジーとは、ピンとピンとの接続の配置やパターンのことです。
Advanced PCBでは、デフォルトで各ネットのピンとピンの接続が最短になるように
配置します。ネットに適用されるトポロジーには、いろいろな理由があります。高速
回路の設計では信号の反射を最小限にするためにデイジー･チェーン･トポロジーが使
用され、グラウンド･ネットでは、すべてトラックが共通な点に戻るようにスター･ト
ポロジーが使用されます。以下のトポロジーを、Routing Topologyルールにより適用
することができます。

Shortest

このトポロジーは、全てのノードに対して全体のコネクションの長さが最短にな
るように接続されます。

Horizontal

このトポロジーでは、５対１の水平と垂直の割合で水平の最短距離で接続されま
す。この方法を利用して強制的に水平方向に配線をすることができます。

Vertical

このトポロジーでは、５対１の垂直と水平の割合で垂直の最短距離で接続されま
す。この方法を利用して強制的に垂直方向に配線をすることができます。
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Daisy-Simple

このトポロジーでは、すべてのノードは互いに鎖状に連結され、連結される順番
は、最短距離になるように実行されます。ソースとターミネータパッドが指定さ
れると、その他のパッドはすべてそれらの間でできるだけ最短距離で接続されま
す。パッドを編集しソースやターミネータに設定してください。複数のソース
（ターミネータ）パッドが指定されるとそれらは終端部で互いに連結されます。

Daisy-Mid Driven

このトポロジーでは、ソースノードはデイジー･チェーンの中央に配置し、負荷
を均等に分配し、ソースノードの両側へ分離されます。この場合、終端のターミ
ネータが２つ必要になります。複数のソース･ノードは中央で互いに連結されま
す。終端が厳密な意味で２つでない場合、単純なデイジー･トポロジーが使用さ
れます。

Daisy-Balanced

このトポロジーは、負荷をすべて同じチェーンに分配し、チェーンの数と、ター
ミネータの数は同じになります。これらのチェーンはソース･ノードにスターパ
ターンに接続されます。複数のソース･ノードは互いに連結されます。

Star

このトポロジーでは、各ノードが直接ソース･ノードに接続されます。ターミネ
ータがある場合、各負荷ノードの後に接続されます。複数のソース･ノードは、
デイジー･バランスト･トポロジーのように互いに連結されます。

Scopeのののの設設設設定定定定

Whole Board、Net、Net Class。
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ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

Star、Daisy-Balanced、Daisy-Mid Driven、Daisy-Simple、Horizontal、 Vertical、
Shortestの優先順位になります。

ルルルルーーーールルルルのののの適適適適用用用用

自動配線中。

Routing Via Style Rule （（（（ビビビビアアアアササササイイイイズズズズ、、、、形形形形状状状状））））

内内内内容容容容

自動配線中に使用されるビアを指定します。ビアは、スルーホール、Blind(表面層か
ら内層へ)、Buried(2つの内層の間)を指定できます。

Scopeのののの設設設設定定定定

Whole Board、Net Class、Net、From-To Class、From-To、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

一番大きいビアのルール。

ルルルルーーーールルルルのののの適適適適用用用用

自動配線中。

Routing Width Constraint ((((パパパパタタタターーーーンンンン幅幅幅幅))))

内内内内容容容容

コパー(銅箔)･レイヤー上のトラックとアークの最大･最小幅を定義します。

Scopeのののの設設設設定定定定

Whole Board、Layer、Net Class、Net、From-To Class、From-To、Regionに適用し
てください。スコープがWhole Boardの場合、コパー･レイヤー上のプリミティブがす
べてテストされます。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

最もタイトなレンジのルールに従います。

ルルルルーーーールルルルのののの適適適適用用用用

自動配線中とBatch DRC。
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Short Circuit Constraint ((((回回回回路路路路ののののシシシショョョョーーーートトトト))))

内内内内容容容容

この制限には、コパー･レイヤー(信号層、内層プレーン)のプリミティブ･オブジェク
ト間の短絡回路のテストという意味もあります。ネット名の違う２つのオブジェクト
が接触すると回路が短絡します。

Scopeのののの設設設設定定定定

Whole Board、Net、Net Class。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

短絡を禁止するルール。

ルルルルーーーールルルルのののの適適適適用用用用

On-line DRC、Batch DRC、自動配線中。

Solder-Mask Expansion Rule ((((ソソソソルルルルダダダダーーーー････ママママススススクククク))))

内内内内容容容容

ソルダー･マスク･レイヤー上の各パッドやビアの位置に作成された形状は、このルー
ルによって設定された値だけ拡大･縮小されたパッドまたはビアの形状です。ビアを
覆う場合のExpansionの設定は、ビアの半径と同じ負の値か、またはビアの半径より
大きい負の値にします。すべてのビアを覆う場合に、デザインの中にサイズの違うビ
アが含まれている際には、最大のビアの半径と同じ負の値か、またはビアの半径より
大きい負の値にします。

Scopeのののの設設設設定定定定

Whole Board、Layer、Object Kind、Component Class、Component、Net Class、
Net、Pad、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

Expansionが最大のルール。

ルルルルーーーールルルルのののの適適適適用用用用

出力作成中。
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Un-Routed Nets Constraint ((((未未未未配配配配線線線線ネネネネッッッットトトト))))

内内内内容容容容

Un-Routed Nets Constraintはスコープで識別された各ネットの完成状態を検査するこ
とができます。ネットが未完成の場合、完了セクション（サブ･ネット）は、配線の
完了に従い一覧表示されます。配線の完了は、（完了した接続）／（接続の総数）
X100で定義されます。

Scopeのののの設設設設定定定定

Whole Board、Net、Net Class。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

ルールの最初のインスタンス。

ルルルルーーーールルルルのののの適適適適用用用用

Batch DRC。

Vias Under SMT Constraint(SMD パパパパッッッッドドドドととととビビビビアアアアのののの処処処処理理理理)

内内内内容容容容

自動配線中にビアをSMDパッドの下に配置できるかどうかを指定します。

Scopeのののの設設設設定定定定

Whole Board、Net、Net Class、Component、Component Class、Pad、Region。

ルルルルーーーールルルルのののの競競競競合合合合ははははどどどどののののよよよよううううにににに解解解解決決決決さささされれれれるるるるかかかか

ビアの配置を禁止するルール。

ルルルルーーーールルルルのののの適適適適用用用用

Batch DRCと自動配線中。
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デデデデザザザザイイイインンンンルルルルーーーールルルルのののの使使使使用用用用例例例例

ネネネネッッッットトトトククククララララススススををををルルルルーーーールルルルススススココココーーーーププププととととししししてててて使使使使用用用用すすすするるるる場場場場合合合合

シグナルネット(Signal class)とローボルテージパワーネット(LV Power class) の2つの
ネットクラスを例に考えてみます。定義するルールはネットクラス間は50milのクリア
ランス、各ネットクラスに含まれるすべてのネット間については、クリアランスを
10milとします。

このケースではWhole Board – Whole Boardを10milに設定し、Net Class – Whole
Boardを50milに設定するルールを考えるかもしれません。しかし、この定義の方法で
は、LV Powerクラス内のネットに対しても50milのクリアランスルールが定義されて
しまいます。

このルールを満足させるには、2つのネットクラスを作成する必要があり、Net Class
–Net Classのスコープに対して50milのクリアランスルールを定義します。はじめに定
義されたWhole Board – Whole Board間に対する10milのクリアランスルールは2つの
クラス内の各ネットに適用され、Net Class – Net Classのスコープに対しては2つのネ
ットクラス間のクリアランスとして適用されます。下図は定義された2つルールで
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す。

基基基基準準準準ママママーーーーククククののののソソソソルルルルダダダダーーーー････ママママススススクククク処処処処理理理理のののの場場場場合合合合

基準マークとは、自動組立て機械でPCBの配置を光学的に位置決めする場合に使用さ
れる機能です。半田マスクやペースト･マスクを組立てプラントの基準マークに合わ
せることは非常に重要です。

デザインで基準マークを使用するには、

1. 基準マークをライブラリーの中でコンポーネントとして作成してください。シン
グル･レイヤー･パッドに"FID"という名前を付けてください。コンポーネントを適
当な名前で保存してください。

2. デザインの任意の場所に基準コンポーネントを配置してください。

3. Design Rulesダイアログ･ボックスにSolder Mask Expansionルールを追加してく
ださい。ルール･スコープをPadに設定しパッド･フィールドに"FID*"と入力して
ください。適当なExpansion値を属性セクションに設定してください。

これで文字列FIDで始まるデジグネータを持つパッドは、ソルダー･マスクが拡大され
ます。それぞれの基準コンポーネントに個々のエクスパンジョン値を設定したい場
合、パッド･デジグネータを他の名前に設定しそのパッドにだけ他のルールを適用し
てください。

基準マークに対するソルダーマスクの設定

また、Paste Mask Expansionルールを適用して、半田ペーストがそれらに塗布されな
いようにする必要があります。ペースト･マスクの開いた部分を閉じるには、
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4. Design Rulesダイアログ･ボックスのPaste Mask Expansionルールを追加してく
ださい。ルール･スコープをPadに設定しパッド･フィールドに"FID*"と入力して
ください。

5. デザインで使用されている基準マークの最大半径よりも大きい負の値をエクスパ
ンジョン値に設定してください。

Expansionフィールドに負の値を使用すると、Advanced PCBはこの量だけ半径方向に
マスクの開いた部分を縮小します。最大の基準マークの半径よりも大きな縮小値を設
定すると基準マークの部分にペースト･マスクの開いた部分は無くなります。

ビビビビアアアアののののソソソソルルルルダダダダーーーー････ママママススススクククク処処処処理理理理のののの場場場場合合合合

Advanced PCBには、スルーホール･パッドやビアにソルダー･マスクの開いた部分を
自動的に作成する機能があります。ビアの上のソルダー･マスクを閉じるには、

1. Design Rulesダイアログ･ボックスにSolder Mask Expansionルールを追加してく
ださい。

2. Scope kindをObject Kindに設定し、viaチェック･ボックスだけをチェックしてく
ださい。

3. デザインで使用されているビアの最大半径よりも大きい負の値をExpansion value
に設定してください。

すべてのビアに対する閉じたソルダーマスクの設定
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Expansionフィールドに負の値を使用すると、Advanced PCBはこの量だけ半径方向に
マスクの開いた部分を縮小します。最大のビアの半径よりも大きな縮小値を設定する
とビアの部分に半田マスクの開いた部分は無くなります。



PCB Design with Advanced PCB

ククククリリリリアアアアラララランンンンスススス････ルルルルーーーールルルルをををを部部部部分分分分的的的的にににに使使使使用用用用すすすするるるる場場場場合合合合

デザイン･ルールをネットの特定の部分に適用することができます。

1. ネットの特定の部分にFrom-Toを定義して他のネットの部分と区別して下さい。

From-Toを作成するには、Design-FromTo Editorメニューを選択してください。ネッ
トの特定部分を区別するために必要なFrom-Toを定義してください。From-Toの定義
についての詳細は、From-Tosの項を参照してください。

ネットの特定部分を区別するために必要なFrom-Toが複数ある場合、From-Toクラス
を作成してください。クラスは、Object Classesダイアログで作成され、このダイア
ログボックスを表示するにはDesign-Classesを選びます。いったんネットの特定部分
が定義されれば、デザイン･ルールに追加する用意ができたことになります。

ネットの特定の部分に定義されたクリアランスルール

2. Design Rulesダイアログ･ボックスのClearance Constraintルールを追加してくだ
さい。

3. スコープをFrom-Toに設定してください。クラスを作成している場合、From-To
Classに設定してください。

4. 必要に応じてクリアランスを設定してください。これによりネットのこの部分で
任意のオブジェクト間に許される最小の距離を基板上のオブジェクトに指定する
ことができます。
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ココココンンンンポポポポーーーーネネネネンンンントトトトのののの配配配配置置置置
基板の境界やキープアウトが定義され、ネットリストがワークスペースにロードされ
ると、コンポーネントのレイアウトを行うことができます。ネットリストがロードさ
れたばかりの状態では、コンポーネントは最後のカーソルポイントを原点とた位置
へ”堆積”されます。それからコンポーネントはマニュアルで、対話形式の配置ツー
ルを使用しながら、自動配置を介して、またはこれらのテクニックを組み合わせて配
置されます。

良いコンポーネントの配置は、設計プロセスの基本的な部分です。基板の製造のしや
すさや配線のしやすさは、コンポーネントの配置によって左右される部分が多くあり
ます。

  このマニュアルでは、コンポーネントプレースメントという言葉は、ワークスペ
ース内のコンポーネントの位置決めや配置のプロセスを意味します。

ママママニニニニュュュュアアアアルルルル配配配配置置置置

マニュアル配置中のAdvanced PCBの動作に影響するセットアップオプションは数多
くあります。これらはすべてPreferencesダイアログ･ボックス(Tools » Preferences )
で設定されます。

Snap to Center

このオプションはOptionsタブにあります。これがチェックされている場合、コン
ポーネントは移動中にそれらのリファレンス･ポイント(部品単体の原点)で保持さ
れ、チェックされていない場合、カーソルはクリックした場所で保持されます。

Draft Thresholds

このオプションはDisplayタブにあります。Stringsスレッシュホールドにより、ど
のズーム･レベルでコンポーネント･デジグネータがテキストから四角に変わるか
が決まります。ズーム･レベルが遠い状態でもデジグネータをテキストで表示す
る場合には、これを小さな値に設定してください。

コンポーネントの配置をマニュアルで行なうには、Edit » Move » Component メニュ
ーを選択してください。Status Barに"Select Component"というプロンプトが表示さ
れます。移動したいコンポーネントをクリックしてください。コンポーネントがカー
ソル上に浮き、基板上を移動できます。

è マニュアル配置を行っている時に、ネットリストの最適化を行うことによって現
在の配置のコネクション･ラインはアップデートされます。ネットリストの最適化
はコンポーネントがカーソル上にフローティングの状態の時にショートカット･キ
ーNを押してください。
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ココココンンンンポポポポーーーーネネネネンンンントトトトのののの回回回回転転転転ととととフフフフリリリリッッッッププププ

コンポーネントはいろいろな方法で回転させることができます。

コンポーネントはカーソル上でフローティング状態の時に回転させることができま
す。SPACEBARを押すと反時計方向に回転し、SHIFTキーを押しながらSPACEBAR
を押すと時計方向に回転します。コンポーネントの回転角度はPreferencesダイアロ
グ･ボックスのOptionsタブで設定してください。

コンポーネントのグループを回転するには、最初にコンポーネントをセレクションし
てください。セレクションの回転は、Rotate Selectionプロセス･ランチャー(Edit »
Move » Rotate Selection )よって実行されます。はじめに回転角度の設定を促され、
次にセレクションを回転する場合の中心になるReference Pointを指定します。また、
セレクションは、Move Selectionプロセス･ランチャーを選択し、SPACEBARで回転
させることもできます。

コンポーネントをフリップし、基板のボトムサイド(半田面)に配置させるためには、
カーソル上のコンポーネントがフローティング状態の時に、ショートカットキー"L"を
押して下さい。配置されたコンポーネントをフリップするには、編集したいコンポー
ネントをダブル･クリックし、AttributeタブのLayer属性を変更してください。

ココココンンンンポポポポーーーーネネネネンンンントトトトののののロロロロッッッックククク

エッヂ･コネクターのように位置関係の重要なコンポーネントは、その位置にロック
させることができます。コンポーネントの位置をロックするには、コンポーネントを
ダブル･クリックしChange Componentダイアログ･ボックスを表示させ、Attributeタ
ブのLockedのチェック･ボックスをチェックしてください。

イイイインンンンタタタタララララククククテテテティィィィブブブブ配配配配置置置置
Advanced PCBには、会話形式の配置ツールがあり、これらは自動配置ツールを使用
した後で部分的に配置の最適化を行う場合に特に有効です。 Tools » Align
Components メニューを選択するかAショートカット･キーを使用してツールにアクセ
スしてください。

Aligning Components

Align Left、 Align Right、 Align Top、 Align Bottom の各プロセス･ランチャーはコンポ
ーネント･グループの整列に使用します。コンポーネントのグループをセレクション
し、次にAlignメニューの一つを選択してください。コンポーネントの一つを選択する
ように聞いてきます。グループの残りは選択されたアイテムの列に並べられます。

Distributing Components

Distribute HorizontalとDistribute Verticalプロセス･ランチャーを使用して、セレクショ
ンされたコンポーネントを水平または垂直の列に分配することができます。コンポー
ネントは、水平または垂直にそれらが重ならない現在のスナップ･グリッド上に移動
されます。
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Expanding or Contracting Components

これらのツールは、セレクションされたコンポーネントを１スナップ･グリッドずつ
広げたり、狭めたりします

Centering Components

このオプションはコンポーネントの中央というよりも、むしろリファレンスポイント
(部品原点)にコンポーネントを並べる時に使用されます。例えば、ICの上部にバイパ
ス･コンデンサを水平に配置する場合、ICのどこか近くの上部にバイパスコンデンサ
を配置してください。両方のコンポーネントをセレクションし、Horizontal alignment
を選択してください。コンポーネントの一つを選択するようにプロンプトが表示され
ます。ICを選択すると、バイパスコンデンサが水平にICの上部にセンタリングされて
配置されます。

Shoving Components

このオプションにより、他のコンポーネントで既にふさがれている場所へコンポーネ
ントを配置することができます。この機能を使用するには、まずコンポーネントを目
的の位置に移動しShoveを選択してください。その場所の周囲のコンポーネントは移
動してそのコンポーネントのための空間が作成されます。

Shove Depthの設定により、他の配置されたコンポーネントへの可能な変更の範囲を
定義できます。

押しのけられたコンポーネントがKeep Out周辺のエッヂに及ぶ場合、そのコンポーネ
ントは、エッヂから戻されその他のコンポーネントを移動して空間が作成されます。
コンポーネントの押しのけを行いたくない場合、そのコンポーネントのLocked属性
（Change Componentダイアログ･ボックス）をイネーブルしてください。

Setting the Shove Depth

このオプションにより、変更可能な範囲を設定できます。"1"を設定すると、”ターゲ
ット”･コンポーネントを妨害しているコンポーネントは、ターゲットコンポーネン
トが配置できる空間ができるまで移動します。深度"2"を設定すると、新しく場所を侵
害したコンポーネントの移動も繰り返されます。設計が複雑になっている場合などは
特に、場所の押しのけを実行する前にデザインを保存することを推奨します。

Moving Components to a New Grid

Move to Gridプロセスを使用して、配置されたコンポーネントをすべて指定されたス
ナップ･グリッドへ移動することができます。これは、配線や配置のモデルを変更し
た時に有効です。例えば、基板の配線を25milsのグリッドで設定していてこれを
20milsのグリッドへ変更したい場合、Move to Gridを選択して新しくスナップ･グリッ
ドを入力してください。コンポーネントのリファレンス･ポイントはすべて新しいグ
リッド上に移動します。

フフフファァァァイイイイルルルルかかかかららららのののの配配配配置置置置

Advanced PCBでは、pick-and-placeファイルで指定される基板上の位置にコンポーネ
ントを配置することができます。これにより、ワークスペースにすでに配置されたコ
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ンポーネントをpick-and-place(.PIK)フォーマット･ファイルのデジグネータで指定さ
れる位置に移動することができます。

移動する必要のないコンポーネントはロックしてください。Tools » Place From File
メニューを選択してください。.PIKファイル名を入力するようにプロンプトが表示さ
れます。.PIKファイルに一覧表示された全てのコンポーネントが、現在の位置と違っ
ている場合、Pikファイルで指定された位置に更新されます。

位置変更の参照としてpick-and-placeファイルではMid XとMid Y座標が使用されま
す。その他の座標は無視されます。PIKファイル内の異なるコンポーネントには、必
要に応じて異なる単位(ミル、ミリ)を使用することができます。
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ココココンンンンポポポポーーーーネネネネンンンントトトトのののの自自自自動動動動配配配配置置置置
プリント基板の設計において、部品配置は重要な工程です。また配線を行う労力や製
造コストは配置の質に依存されます。

配置とは、配置できる基板領域と基板サイズにコンポーネントを正確に配置すること
です。最も重要なことはデザイン･ルールに違反しないで基板上にコンポーネントを
配置し、配線作業をどれだけやりやすくするかということです。

つまり、PCBの部品配置の主な目的は:

· 基板上にコンポーネントをすべて置くこと。
· デザイン･ルール違反を避けること。
· 配置されたコンポーネントの配線を完了できること。
· 基板の組み立てやテストに対する要求と一致すること。これらについては設計段
階で基板組み立て工程の担当者と打ちあわせを行い確認してください。

Advanced PCBには、”グローバル”自動コンポーネント配置サーバーがあり、この
サーバーは、特に、設計段階において重要な配置作業の困難さを補助するために開発
されました。この章では、プレースメントサーバーの設定や実行、ならびに自動配置
アルゴリズムについて説明します

è 自動コンポーネント配置を実行するには、Placer Serverをインストールする必要
があります。サーバーのインストールについての詳細は、EDA/Clientの項を参照
してください。

è 自動配置を実行する前に、Edit » Origin » Reset  メニューを選択してカレント･オ
リジンを アブソリュート･オリジンに戻してください。これは、自動配置ルーチ
ンが絶対原点をリファレンスポイントとして使用するために行います。また、配
置されたコンポーネントは相対原点から参照するとオフグリッドになる場合があ
ります。

配配配配置置置置可可可可能能能能ななななボボボボーーーードドドド････エエエエリリリリアアアアににににつつつついいいいてててて
Global Placer Serverを実行する前に、コンポーネントの配置に使用できる基板領域を
定義してください。これは、コンポーネントの配置できる領域をキープ･アウト･レイ
ヤーにトラックを配置することにより定義されます。

基板上にコンポーネントの配置禁止領域を設定する場合、キープ･アウト･ゾーンを作
成してください。キープ･アウト･ゾーンを作成するにはキープアウトレイヤーにトラ
ックやフィル、アークを配置して下さい。詳細は、基板外形の定義の項を参照してく
ださい。

ググググロロロローーーーババババルルルル････ププププレレレレーーーーササササーーーーのののの設設設設定定定定
グローバル･プレーサーの構造は複雑ですが、使用することは簡単です。必要とする
のはデザインについての非常に基本的な事柄のみです。特別に設定を行う必要はな
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く、システムが最高の結果を得るために、ボード全体に対してコンポーネントの配置
を行います。

グローバル･プレーサーを設定するには、Tools » Auto Place メニューを選択して、
Autoplace Preferencesダイアログ･ボックスを表示してください。

オオオオププププシシシショョョョンンンン

Group Components

このオプションがイネーブルの場合、Golbal Placerは基板上のコンポーネントを
検索し、互いにしっかりと接続されているコンポーネントをグループ化します。
グループ化の主な基準は、コンポーネント間の接続の数です。この基準の重み
は、これらのコンポーネントのピンの数により影響されます。

次にシステムは各グループの相対的な配置を行います。これらのグループは、”
スーパー･コンポーネント”として扱われ、それらの相対的な配置は、メインの
配置サイクル中変更されることはありません。

このオプションは、通常は有効に動作しますが、基板上のスペースが十分でない
場合、生産性に悪影響を与えます。これは、各グループ内の相対配置がメインの
配置サイクル中に変更されないため、グループとして扱う場合基板スペースを無
駄にしてしまうことがあるためです。

Rotate Components

コンポーネントが回転できる場合、コンポーネントは、最適な方向を見つけるた
めに回転されます。90、180、270、360度の４方向が検討されます。

このオプションを使用する場合、注意が必要です。フットプリントの回転はデザ
インの製造のしやすさに直接影響を与えます。例えば、組み立て装置の中には、
回転したコンポーネントを扱うことができないものがあります。Rotate
Componentをイネーブルすると、配置作業が複雑になり、特にデザインの密度が
高い場合時間かかるようになります。通常、高品質の配置結果が得られるように
するには、ある程度の試行錯誤が必要になります。

Advanced PCBではコンポーネントを、Edit » Move、Edit » Paste Array 、また
はChange ComponentのダイアログボックスのRotationフィールドによって0.001
度の正確さで回転することができます。

Automatic PCB Update

Global Placerは、最適な状態が更新されるたびに、現在のコンポーネント･ポジシ
ョンをAdvanced PCBのボードに自動的に送ります。(およそ10分おき)また、
Placerが動作中であってもFile » Update PCB  を選択することによって、いつで
もボードのコンポーネント･ポジションを更新することができます。

Placement Grid

これは、各コンポーネントのリファレンスポイント(コンポーネントの原点)が配
置されるグリッドです。通常、コンポーネント･ピンのピッチを適当に割った値
か使用するルーティング･グリッドの幅を適当にかけた値が使用されます。コン
ポーネント配置グリッドを、最新の設定に変更する場合、Advanced PCBには、
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コンポーネントをすべて新しいグリッドに移動するツールがあります。(Tools »
Align Components » Move To Grid )

Power Nets

Power Netsオプションにより、以下の２つの機能を実行することができます。

1. Power Netsフィールドで指定されるネットは、配置アルゴリズムで無視され、こ
のため、配置プロセスの処理速度が速くなります。

2. ラージコンポーネント(１４ピン以上)にバイパス･コンデンサーを割り当てるに
は、コンデンサに接続されるネットの名前を指定してください。例えば、デザイ
ンでパワー･ネットとしてVCCとGNDネットを使用する場合、最初のフィールド
にVCCを入力し、次のフィールドにGNDを入力してください。Global Placerは、
指定されたパワー･ネット（VCCとGND）をもつラージコンポーネントにバイパ
スコンデンサを割り当てるように試みます。

è 複数のパワー･ネットを、それぞれのテキスト･ボックスに指定することができま
す。ネット名を一つのブランク･スペースで区切ってください。

Clearances

スモールコンポーネント（14ピン以下）やラージコンポーネント（14ピン以上）に必
要なクリアランスを設定してください。コンポーネントのクリアランスは、コンポー
ネントのプリミティブをすべて囲むことができる最小の長方形から計算されます。

è これらのクリアランスの設定は、２つのコンポーネントの間のクリアランスで
す。

ググググロロロローーーーババババルルルル････ププププレレレレーーーーササササーーーーのののの実実実実行行行行

Autoplace Preferencesダイアログ･ボックスを設定が完了したらOKボタンを押してグ
ローバルプレースを開始してください。

The Global Placer Window

グローバルプレイサーサーバーが配置を行なっている経過は別の専用のウィンドウに
表示されます。このウィンドウにはコンポーネントとキープアウトエリアが含まれま
す。

グローバル･プレーサーのメイン･メニューはとても簡単です。メニューには、File、
View、Window、Helpがあります。グローバル･プレーサーは、独自のデータ構造を持
っているため、配置中にPCBデータベースは変更されません。File » Update PCB メ
ニューを使用して、現在の配置情報をAdvanced PCBへ戻すことができます。これに
より、定期的にAdvanced PCBに戻り配置の品質を確認したり、Density Mapを使用し
てデザインの配線のしやすさ（ルータビリティー）を検証することができます。

プレースメントウィンドウには、独自のStatus Barがあり、以下の情報を取得できま
す。

Elapsed time

配置を始めてからの経過時間。
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Optimization

プレースメントタスクは、全部で70サイクルあります。最初の40-50サイクル
は、ほとんどのコンポーネントの移動はスムーズに行われます。しかし、温度が
下がるように、サイクルの要求を満足するためにより多くの移動が必要になって
きます。このため、サイクルは完成に近づくにつれて遅くなります。最適化は完
成までのパーセンテージで示されます。

Number of Moves

ステータス･バーに表示されたNumber of Movesは、基板の配線のしやすさを改善
するために、システムがコンポーネントを新しい位置に移動した回数です。

è 配置中、基板上に小さな紫色の四角が表示されます。これらの四角の大きさは、
その領域の接続密度をあらわしています。

Placement Results

最適な配置に近づくにつれてプレースメントプロセスでは、コンポーネントの移動回
数が少なくなります。配置を完了するための操作は特に必要ありません。File »
Closeを選択してプレースメントロセスを終了してください。プレースメントウィン
ドウを閉じる前にPCBを更新するかどうかがたずねられます。

ううううままままくくくく利利利利用用用用すすすするるるるたたたためめめめののののヒヒヒヒンンンントトトト

Global Placerでは、通常特別なユーザーによる指示は必要ありません。しかし、万一
何か困難なことが発生した場合、以下の点を確認してみてください。

Pre-Placing Components

グローバル･プレーサーを実行する前に、任意のコンポーネントをあらかじめ配置す
ることができます。これらのコンポーネントが動かされないようにするには、
Change Componentダイアログ･ボックスでLocked属性をオンにしてください。

エッヂ･コネクターやヒート･シンク、アナログ･コンポーネントのグループのように
基板の特定の位置に配置する必要のあるコンポーネントは別として、配置に関する制
限のないコンポーネントをあらかじめ配置しておくことは非常に便利です。例えば、
メモリー･チップはあらかじめ配置したほうがよいコンポーネントです。これによ
り、その他のコンポーネントの配置が簡単になります。

Use of Keep-Out Zones

基板上の特定の領域にコンポーネントを配置しないようにするには、キープ･アウト･
ゾーンを作成してください。キープアウト･ゾーンは、コネクターの近くや機械的な
理由で開けておきたい領域に配置してください。Keep Outレイヤー上にトラックやフ
ィル、アーク、ポリゴンを配置してキープ･アウト･ゾーンを作成してください。

Auto Place and Larger Nets

ラージネット(たくさんの接続箇所をもつネット)はGlobal Placerの処理速度を遅くし
ます。これは、ネットの再配置に必要な計算量がネットの大きさに指数関数的に比例
するからです。パワーやグランドのようなラージネットが、配置プロセス全体にわた
り重要な役割を果たしていないことは面白い現象です。したがって、Global Placerに
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これらの大きなネットを無視するように指示することは有効なことです。これを行う
には、Autoplace Preferencesダイアログ･ボックスのPower Netsにラージネットを割
り付けてください。

è 自動配置ツールは、設計者の判断や経験にかわるものではないことを覚えておか
なければなりません。

Post Auto-Placement Tools

グローバル･プレーサーの結果は、コンポーネントの相対位置が最適な状態の基板で
す。グローバル･プレーサーは機能の関係から場合によって、全体的には不完全なレ
イアウトが行われることがあります。例えば、プレースメントが終了した後でもコン
ポーネントが重なっている場合や、適切に配置されていないコンポーネントが残った
りすることがあります。インタラクティブ配置ツールは、配置を整理するプロセスを
支援するために作られました。インタラクティブ配置ツールの使用に関する詳細は、
コンポーネントの配置の項のインタラクティブ配置を参照してください
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基基基基板板板板のののの配配配配線線線線ににににつつつついいいいてててて
デザインの配線作業は、論理的な接続を物理的な接続に変換するプロセスです。これ
らの物理的接続には、トラックやビア、パッド、アーク、フィル、ポリゴン、パワ
ー･プレーンがあります。通常、物理接続の大部分は、トラックとビアで作成されま
す。

Advanced PCBには、論理的な接続を物理的な接続に変換するプロセスのスピードを
上げるために特に作られた機能があります。これらの機能には以下のものがありま
す。

イイイインンンンテテテテリリリリジジジジェェェェンンンントトトト････ママママニニニニュュュュアアアアルルルル配配配配線線線線

マニュアル配線を行う際には、必ずしも表示されたコネクションラインの経路に
従う必要はなく、コネクションを選択し、トラックを配置して接続してくださ
い。同じネット上の別のピンに配線するか、もしくはT字配線をしてください。
トラックの配置が終了した時点で、ネットが解析されコネクションが追加または
削除されます。

エエエエレレレレククククトトトトリリリリカカカカルルルル････ググググリリリリッッッッドドドド

Advanced PCBにはトラックやビアのようなエレクトリカル･オブジェクトを簡単
に配置するための機能としてエレクトリカル･グリッドがあります。エレクトリ
カル･グリッドは定義された範囲内にエレクトリカル･オブジェクトが移動した場
合、そのオブジェクトを他のエレクトリカル･オブジェクトへ引き込みます。エ
レクトリカル･グリッドはスナップ･グリッドを無効にするため、オフグリッドの
オブジェクトの配線を簡単に行うことができます。

エエエエララララーーーーのののの無無無無いいいいオオオオブブブブジジジジェェェェククククトトトト配配配配置置置置

Advanced PCBには、クリアランス･デザイン･ルールに違反しないプリミティブ
だけを配置していく配線モードがあります。この機能により、クリアランス･ル
ール違反を恐れることなく、設計の困難な基板に対して配線を行うことができま
す。

オオオオンンンンラララライイイインンンン････デデデデザザザザイイイインンンン････ルルルルーーーールルルル

デザイン･ルールの中には、配線を監視しているものがあります。これらのルー
ルには、ショート･サーキット･ルール、クリアランスの制約、トラック幅の制
約、配線ビア･スタイル、平行セグメント制約があります。違反は直ちに警告さ
れますので、エラーのない設計ができます。

ルルルルーーーーププププ配配配配線線線線のののの自自自自動動動動除除除除去去去去

既存のトラックを手早く再配線することができます。単に新しいトラックで配線
するだけで余分なセグメントは自動的に削除されます。

7777つつつつののののトトトトララララッッッックククク配配配配置置置置モモモモーーーードドドド

トラック配置モードにより、円弧と45度を含むトラック･コーナーの配置方法を
限定します。各モードには、次のセグメントの配置の予測や現在のセグメントを
正しく終了するために使用できるルック-アヘッド･セグメントがあります。
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自自自自動動動動ビビビビアアアア挿挿挿挿入入入入

配線している時にショートカットキー*,+,-を押すと、他のコパー･レイヤーへ切り
替えることができます。その際に一つのビアが自動的に挿入されます。

Advanced PCB のののの接接接接続続続続のののの管管管管理理理理

(
RD
U7-5
U6-32
U5-21
)
(
N00023
XTAL2-2
U9-10
U9-9
R4-2
)
(
N00024

XTAL2-1
U9-13
R3-1
)

ネットリスト内のネットRDはPCB上で未配線の状態で表示されています。

Advanced PCBはコネクティビティドリブンデザイン環境です。Advanced PCBではデ
ザインを配線を行なうごとにネットリストの接続を監視し管理しています。

上図のネットリストの一部について考えてみます。RDはネット名で、U7のピン5、
U6のピン32、U5のピン21の間の接続を表わします。スケマティックでは、この接続
はこれらの3つのピンが互いにつながれたワイヤによって表わされます。ネットリス
トがPCBワークスペースにロードされると、Advanced PCBはネットを解析し、ネッ
トRDの２つのFrom-Toを作成します。これらは上図で示されるようなConnection
Layer上のの２本の細い線で表わされます。

設計者が行うべき作業はこれら2つのFrom-ToをConnectionレイヤー上の接続からシグ
ナルレイヤー上の物理的な接続に変換することです。設計者は物理的な接続を作成す
るためにトラックを配置して変換を行います。トラックの配置がストップしたとき
に、常にAdvanced PCBではネット全体を調べてネットのどの部分が完成したか、も
しくは未完成のままであるかが確定されます。未完成部分が発見されれば、Broken
Net Markersがサブネットに与えられネットの接続を維持します。
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Advanced PCBは自動的に配線中のネットの完成状態を監視しているため、From-To
の配置に関係なく配線することができます。例えば、U5-7で配線を始めてU5-21では
なくU6-32へ配線することを決めた場合、この接続が完成するとAdvanced PCBはRD
ネット全体が解析され、Broken Net Markerが配線されていないピンから他のサブネッ
トの最も近いポイントへ追加されます。この様子は以下の図のようになります。

繰り返すと、設計者の作業は、シンボル的
な接続線から物理的なトラックへ接続を変
換することであり、Advanced PCBの作業
は設計者の作業を監視し、 From-Toや
Broken Net Markerを必要に応じて更新する
ことです。この方法には2つの利点があり
ます。1つめはネット上のどのプリミティ
ブに対してもトラックを配線でき、必ずし
もFrom-Toで接続された2つのピンの間を配
線する必要はありません。Advanced PCB
は設計者の進行状況を監視し、自動的に
Broken Net Markerの追加、削除を行いま
す。2つめはネットの接続は決して断線し
ないことで、偶然にネットの2つの接続さ
れない部分に壊れることはありません。ト
ラックセグメントを削除した場合、
Advanced PCBでは断線部が検索され、す
ぐにBroken Net Markerを追加しネットの接
続が修復されます。

Advanced PCBがネットを解析し、Broken
Net Markerを追加しなければならない場
合、ネットのトポロジーに基づきBroken
Net Markerを追加します。デフォルトで
は、すべてのネットのトポロジーは
Shortsetに設定されています。これらのネットに対して2つのサブネットが最も接近す
るところに、Broken Net Markerが追加されます。

ネットに対してトポロジーが適用されている場合、From-Toはトポロジーを維持する
ために追加され、点線であらわされた2点間を維持するトポロジーはネットはまだ未
結線であることを示しています。

トポロジーはTopology Rule、またはFrom-Toにより適用されます。ネットトポロジー
についての詳細は、Net TopologyとDesign Ruleの項のRouting Topologyデザインルー
ルを参照してください。

U5

U6

U7

From-To

ネット解析後に追加された、
Broken Net Marker
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配配配配線線線線のののの準準準準備備備備
配線を行なうためのデザインの準備は、設計の重要なプロセスの一部です

Setting the Grids

以前から、PCBは標準グリッドで設計されていました。グリッドは、オブジェクトを
簡単にしかも正確に配置できように計算されました。例えば、ピン間が100milsのスル
ーホールコンポーネントを使用したデザインでは、25milsのグリッドで配線すること
ができます。これは、12milのトラック幅と13milのクリアランスで、ICのピン間にト
ラック1本を通すことになります。

パッケージング･テクノロジーの変更で、インペリアルとメトリック両方のピン間隔
が使用されるようになり、すべてのコンポーネントとデザイン要求に対応できる標準
グリッドを指定することが難しくなります。これは、これまでの標準グリッドに基づ
くPCB設計環境の大きな欠点になっています。

Advanced PCBには、この欠点を補うために、設計者を助けるいくつかの機能があり
ます。これらには、オフグリッドであっても、電気的オブジェクトを他の電気的オブ
ジェクトのホットスポットにスナップ(吸い込ませる)させることができるエレクトリ
カルグリッド、次のトラック･セグメントの配置や現在のトラック･セグメントの正確
な終端を予測できるルック-アヘッド･トラック配置、ルール違反のないオブジェクト
の配置があります。これらの機能により、Advanced PCBはシェイプベースト(形状認
識に基づいた)マニュアルルータのように動作し、ワークスペースのあらゆる場所、ま
たあらゆるオブジェクトへ早く正確に配線することができます。

これらの機能は複雑に思われますが、非常に簡単なものです。設計が従来の配線モデ
ルに適合しない場合や、グリッドベースの配線よりもさらにタイトにトラックやビア
で配線したい場合、スナップグリッドを5mil、または1milのように小さい値に設定し
てください。このモードでの配線についてはトラックの配置と、ルッキングアヘッド
の項を参照してください。

スナップグリッドとエレクトリカルグリッドについての詳細はPCBワークスペースの
設定のグリッドの項を参照してください。

ココココンンンンポポポポーーーーネネネネンンンントトトトののののググググリリリリッッッッドドドドへへへへのののの移移移移動動動動

使用できる配線チャンネルの数を最大にするには、できるだけ多くのコンポーネント
パッドをスナップ･グリッド上に配置する必要があります。コンポーネントがグリッ
ド上にあるかどうかをチェックするには、Edit » Select » Off Grid Pads メニューを
選択（ショートカット；S,G）してください。コンポーネントをすべてスナップ･グリ
ッド上に移動するには、Tools » Align Components » Move To Grid メニューを選択
（ショートカット；A,G）してください。Component Moveダイアログ･ボックスが表
示されグリッドを指定できます。

配配配配線線線線密密密密度度度度ののののチチチチェェェェッッッックククク

トラックやグリッドのサイズ、ビア･サイズ、レイヤーの数などをもとに、ボードが
どのように配線されるべきかの判断を助けるために、Advanced PCBにはDensity Map
機能があります。Tools » Density Map メニューを選択してください。しばらくする
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とボードが、色の付いたマップでペイントされます。緑色は"cool"、すなわち密度が
低い場所をあらわし、赤色は、"hot"、すなわち密度が高い場所をあらわします。赤い
領域が多い場合、現在のコンポーネントの配置を解析して"hot"ゾーンを削除するよう
にしてください。これが不可能な場合、配線レイヤーを増やす必要があります。

配配配配線線線線レレレレイイイイヤヤヤヤーーーーのののの設設設設定定定定

Advanced PCBには、16の信号レイヤー（トップとボトム、14のミッド･レイヤー）だ
けでなく、４枚の内層パワー･プレーンがあります。デザインに内層信号レイヤーが
必要でブラインドまたはバリード･ビアを使用する場合、信号レイヤーは、レイヤー
のペアで使用してください。ブラインド･ビアやバリード･ビア、レイヤー･ペアにつ
いての詳細は、デザイン･オブジェクトの  ビアを参照してください。Document
OptionsダイアログのLayersタブで配線レイヤーにチェックマークを入れて下さい。
(Design » Options )

デデデデザザザザイイイインンンンルルルルーーーールルルルのののの設設設設定定定定

配線を始める前に、必要なデザイン･ルールを追加してください。デザイン･ルール設
定がされていない場合は、もう一度デザイン･ルールの項を参照して、デザイン･ルー
ルを適切に設定してください。
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ママママニニニニュュュュアアアアルルルル配配配配線線線線
è 配線を始める前に、トラック配置モードの項を参照してください。トラックの配
置機能をよく理解することは、配線中のAdvanced PCBの性能を最大限に生かす
ために重要です。

Advanced PCBはネットの接続を常に監視しているので、配線は非常に簡単です。ト
ラックやビア、フィル、アークを配置して物理的な接続を作成すると、Advanced
PCBでは接続が監視され、それに応じてコネクションラインが更新されます。

è デザインにたくさんのノードを持つネットがある場合、コネクションのモニタリ
ングに多くの時間が必要になります。この場合、特定のネットを“Hide”にする
ことによってモニタリングされるネットから除外されます。特定のネットを
“Hide”にするには、View » Connections » Hide Net を選択し目的のネットを
選択してください

Place » Trackを選択してネット名を持つデザイン･オブジェクトの上をクリックする
と、配置しているトラックにそのネット名が付き、ネットの一部になります。コネク
ションラインをクリックすると、Advanced PCBは、もっとも近いパッドへジャンプ
し、コネクションラインは配置しているトラックの終端につながれた状態を維持しま
す。

トラックの配置を終了すると、Advanced PCBはネットを調べてコネクションライン
を更新します。コネクションラインは、トラックの端にあるかもしれません。
Advanced PCBは、ネット･トポロジーに基づいて物理的に接続されていないネットの
すべてにコネクションラインが追加されます。デフォルトのトポロジーは、もっとも
近いサブ･ネットにコネクションラインが追加されるshortestです。トポロジーについ
ての詳細は、ネット･トポロジーの項か デザイン･ルールの項のRouting Topologyデザ
イン･ルールを参照してください。

特定のネットに異なるトラック･サイズを設定したい場合、Width Constraintデザイン･
ルールをそのネットに適用してください。デザイン･ルールの適用についての詳細
は、デザイン･ルールの項を参照してください。

以下のショートカットを使用して配線作業を迅速に行なって下さい。

· BACKSPACEキーを押すと、配線中にトラック･セグメントを削除することがで
きます。

· *キーを押すと配線中に配線レイヤーを切替えることができます。

· TABキーを押すと、Change Trackダイアログ･ボックスを表示され、トラック属
性を編集することができます。

· SPACEBARによって、StartとEndの配置モードを変更することができます。ま
た、SHIFT+SPACEBARを押すと、トラック配置モードを切り替えることができ
ます。

· 配線中に、表示をリフレッシュしたい場合、View » Refresh を選択するか、END
キーを押してください。
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トトトトララララッッッッククククのののの配配配配置置置置ととととルルルルッッッッキキキキンンンンググググ----アアアアヘヘヘヘッッッッドドドド

Advanced PCBには、トラックを配置する操作のために、"look-ahead"機能が組み込ま
れています。カーソルに接続されたトラック･セグメントは、ルック･アヘッド･セグ
メントです。（アウトライン／ドラフト･モードで示されます。）ルック･アヘッド･
セグメントと最後に配置されたセグメントの間のセグメントは、配線中のカレント･
セグメントです。これは、以下の図に示されます。

ルック-アヘッド機能を用いることによりトラックの進路を正確に予測できます。
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ルック･アヘッド･セグメントは次のセグメントを配置したい場所をみつけるためや、
現在のセグメントの終端にしたい場所を決めるために使用して下さい。現在のセグメ
ントの場所をクリックすると、そのセグメントの終端は次のセグメントの配置を始め
る場合の正確な位置になります。この機能により、既存のオブジェクトの周りや次の
トラック･セグメントが配置される場所にトラックをすばやくしかも正確に配置する
ことができます。

ルック･アヘッド･セグメントを使用して配線をすると、トラックの終端がカーソルの
位置に付いてこない場合があることに気づきます。それは、他のネット属性の電気的
オブジェクトを避けているためです。この機能により、前の図のstep2で示されるよう
に、クリアランス･デザイン･ルールに違反しない場所にだけプリミティブを配置する
ことができます。step2では、カーソルはパッドの右に移動されましたが、ルック･ア
ヘッド･セグメントは、ルール違反のないような位置まで戻されます。ルック･アヘッ
ド･セグメントはルール違反のないようにパッドの間を通る位置までカーソルが移動
されるとすぐに、ルック･アヘッド･セグメントはカーソルの位置まで伸びてきます。
プリファレンス (Tools » Preferences )のRouting ModeをAvoid Obstaclesに設定して
ください。

以下の図に示されるマニュアル配線の他の例を考えてみます。例えば水平に移動し、
次に斜め下のパッドに配線したい経路があるとします。以前はこのプロセスを試行錯
誤しながら、水平のセグメントの終了位置や、斜めのセグメントの開始位置を正確に
判断していました。ルック･アヘッド･セグメントを使用すると、カーソルを目的のパ
ッドまで移動し、水平のセグメントを終了するために一旦クリックし、それからもう
一度クリックすると、斜めのセグメントを終了することができます。

ルック-アヘッド機能を用いて配置されるトラックを予測します。

first click will place the
current segment look-ahead segmentprevious segment

previous segment second click will place the 
new current segment
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è 輪郭が表示されるセグメントはルック･アヘッド･セグメントで、現在配線中のセ
グメントではないことに注意してください。セグメントを配置してクリックした
時になにも起こらない場合、おそらくルック･アヘッド･セグメントを配置してい
ます。配置モードをStartにすべき所をEndに設定していたり、または、反対に
Endに設定すべきところをStartに設定していたりするとこのようなことが起こる
ことがあります。SPACEBARを押して、Start配置モードとEnd配置モードを切替
えてください。

再再再再配配配配線線線線

リ･ルーティング(再配線)は、PCB設計のなかで通常行われる作業の一つです。おそら
くコンポーネントが追加された、フットプリントが変更された、または自動配線後の
パターン修正の際に行われるでしょう。Advanced PCBには、強力なループリムーバ
ル機能があり、トラックのリ･ルーティングのプロセスで有効です。既存のトラック
をリ･ルーティングするには、

1. Preferencesダイアログ･ボックスでLoop Removal機能がオンになっていることを
確認してください。

2. Place » Trackメニューを選択してください。

3. トラックまたはパッドをクリックしてリ･ルーティングを実行してください。

トラック全体がハイライト表示され、カーソル上にトラック･セグメントが現れま
す。

4. 新しい径路に沿ってトラックをリ･ルーティングし、それを古いトラックに合う
まで戻してください。

5. リ･ルーティングを終了する場合、マウスの右ボタンをクリックするかESCキー
を押してください。

この新しいトラックによりループが形成されます。Advanced PCBはループの古い部
分を削除します。リ･ルーティングにより、新しいビアを追加したり古いビアを削除
したりできます。新しいトラックが既存のトラックを横切って配線するとエラーが発
生しますが、これについては後からリ･ルーティングによって配線された他のトラッ
クについても同様です。

è Loop RemovalはPreferencesダイアログ･ボックスのOptionsタブにあります。

内内内内層層層層パパパパワワワワーーーー････ププププレレレレーーーーンンンン

内層パワー･プレーンは特別なソリッド･コパーの内部レイヤーです。Advanced PCB
には４枚の内層パワー･プレーンがあります。設計がネットリストを基本にしている
場合、ネットにこれらのレイヤーを割り付けることができます。また、分離している
２つ、またはそれ以上の絶縁されたエリアによって複数のネットを1つのパワープレ
ーンの間で"共有"することも可能です。

各ピンをパワー･プレーンに接続するには２種類の形式があり、ダイレクト接続、ま
たはサーマル･リリーフ接続になります。サーマル･リリーフ接続を使用すると、基板
が半田付けされる場合にソリッド･コパー･プレーンから接続ピンを温度的に隔離する
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ことができます。Advanced PCBでは、それぞれの、または全てのパッドのパワー･プ
レーンへの接続をサーマル･リリーフ形状に定義することができます。

特別なサポートとしてSMDパワー･ピンをパワー･プレーン･レイヤーへ接続する機能
も準備されています。パワー･プレーンに接続されるネット上のSMDパッドは、適切
なプレーンに接続されるように自動的にタグが付けられます。オートルータは、
SMD”ストリンガー”によりこれらのパッドの物理的な接続を完成しています。”ス
トリンガー”とは短いトラックと内層パワー･プレーン･レイヤーにリリーフまたはダ
イレクト接続されたマルチ･レイヤー･パッドです。

内内内内層層層層パパパパワワワワーーーー････ププププレレレレーーーーンンンンへへへへのののの接接接接続続続続

ネットを内層パワー･プレーンに接続するには

1.  使用する内層プレーンをDocument Optionsダイアログ･ボックス（ショートカッ
ト：O,L）のLayer Tabでオンにしてください。

2.  Design » Internal Planes メニューを選択して Internal Planesダイアログ･ボック
スを表示してください。

3.  使用するプレーンのドロップ･ダウン･リスト･ボックスから必要なネットを選択
してください。

そのネットのFrom-Toがすべて表示から削除されます。ネットの各パッドに小さい十
字マークが表示されます。十字はリリーフ接続の"+"または、直接接続の"x"のような
形です。

è パッドとプレーンの接続の属性は、Power Plane Connect Styleデザイン･ルール
で指定してください。このルールの使用についての詳細はデザイン･ルールの項を
参照してください。

パパパパワワワワーーーー････ププププレレレレーーーーンンンンにににに接接接接続続続続ししししなななないいいいピピピピンンンン

プレーンに接続しないパッドは銅箔がない領域によってプレーンから絶縁されます。
銅箔がない領域は、Power Plane Clearanceデザイン･ルールによりパッド･ホールの周
りの逃げが指定されます。このルールの使用についての詳細は、デザイン･ルールの
項を参照してください。

パパパパワワワワーーーー････ププププレレレレーーーーンンンンのののの表表表表示示示示

パワー･プレーンはネガのイメージで作成されます。パワー･プレーン･レイヤーに配
置されたオブジェクトは銅箔のない部分になり、スクリーン上の黒の領域(バックグラ
ンド)が銅箔部分になります。どのようにピンがパワー･プレーンに接続されているか
を表示するには

1.  プレーン･レイヤーとパッド･ホール･レイヤー、マルチ･レイヤーだけをオンにし
てください。

2.  ワークスペースの下側のパワー･プレーン･レイヤー･タブをクリックしてくださ
い。
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3.  必要に応じて、ENDキーを使用してス
クリーンを再描画してください。

リリーフ接続されたパッドは図のように表
示されます。ダイレクト接続されたパッド
にはピンまで銅箔部分があり、それらは単
にパッド･ホールまで黒(バックグランドの
カラー)で表示されます。この本では、白い
部分が銅箔部分を表わし、黒い部分が銅箔
のない部分を表わします。

ススススププププリリリリッッッットトトト････パパパパワワワワーーーー････ププププレレレレーーーーンンンンのののの作作作作成成成成

内層パワー･プレーンを複数のネットによっ
て共有したい場合、プレーンをネットの領域
ごとに分配、または“分割”します。通常、ピン数がもとっも多いネットが最初に内
層プレーンに割り付けられ、それからこのプレーンに接続したい他のネットの領域が
定義されます。各領域は、ネット上のピンをすべて囲む特別な境界トラックを配置し
て定義されます。スプリットプレーン領域で囲まれないピンはコネクションラインが
表示されたままになり、これらのピンはシグナル･レイヤーで接続する必要があるこ
とを表わします。

パワー･プレーンはネガイメージで構成されますので、特別な境界として配置された
トラックの部分の銅箔はなくなり、プレーン上のあるネットと近接する他のネットの
間のセパレーションを形成します。

スプリットプレーンを作成するには、

1.  Document Options ダイアログのLayerタブをクリックし目的の内層プレーンをオ
ンにしてください。

2.  ワークスペースの下にあるレイヤータブをクリックし、内層プレーンをカレント
レイヤーにしてください。

3.  Design » Internal Planes メニューを選択し Internal Planesダイアログ･ボックス
を表示してください。

4. 最も多くのピンを持つネットを内層プレーンに接続してください。

5. Split Planeを追加するには、Addボタンを押してください。Split Planeダイアロ
グ･ボックスが表示されます。必要に応じて、Track WidthやLayer、Connect to
Netを設定してください。

6. Split Planeダイアログ･ボックスが設定されるとOKをクリックしてください。ダ
イアログ･ボックスが消え、クロスのカーソルが現れます。

7. 境界を定義するためにそれぞれのポイントをクリックします、閉じた境界を作成
するために始めの点に戻ってください。

è SPACEBARを使用して、 Startと End配置モードを切替えてください。
SHIFT+SPACEBARを押してトラックの配置モードを切替えてください。アーク
を境界に使用することができます。

air
gap

conductor
    width

expansion

pad
hole
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境界が閉じられると、Internal Planesダイアログが再表示されます。新しくスプリッ
トプレーンがSplit Planesリストに表示されます。リストをクリックすると領域が表示
されます。

複複複複数数数数ののののススススププププリリリリッッッットトトト････ププププレレレレーーーーンンンン

プレーンに複数のネットを接続する場合、スプリット･プレーンを追加してプレーン
上に他のネットの領域を作成してください。通常、近接する境界トラックは若干重ね
て配置し、銅箔の無い部分が途切れない(銅箔が残らない)ように作成します。

領域の中に領域を定義するには、下図のように外側の領域が内側の領域を囲む必要が
あります。

大きなスプリットプレーンの中のスプリットプレーン－大きなプレーンが内側のプレーン
の周りをどのように囲んでいるかに注意してください。境界トラックを細くして２つのス
プリットプレーンを明確にあらわしています。

è スプリットプレーンは他のスプリットプレーンを囲むように作成し、オーバーラ
ップしないよう注意してください。

ススススププププリリリリッッッットトトト････ププププレレレレーーーーンンンンにににに関関関関すすすするるるるヒヒヒヒンンンントトトト

スプリット･プレーンの中に囲みたいパッドを作成するには、以下の手順を実行しま
す。
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1. 表示するレイヤーを最小限にします。キープアウトレイヤー、マルチレイヤー、
必要に応じてメカニカルレイヤー、パワープレーンなど現在使用されるレイヤー
を表示します。

2. すべてのコネクションラインを非表示にします。(View » Connections » Hide
All )

3. Preferencesダイアログ･ボックスのShow/Hide Tabでパッドとコンポーネントの
表示モードをドラフト･モードに設定してください。

4. Preferencesダイアログ･ボックスのOptions TabでHighlight In Fullオプションと
Use Net Color For Highlightオプションをオンにしてしてください。

5. スプリット･プレーンの各ネットの色属性を違う色に変更してください。手順と
して、エディタパネルのBrowseモードをネットに設定し、リストからネットを選
択しEditボタンを押してChange Netダイアログ･ボックスを表示してください。

6. Edit » Select » Net メニューを選択しネット上のパッドの一つを選択してくださ
い。Extend Selectionをオンにすると一度に複数のネットを選択することができ
ます。（Preferencesダイアログ･ボックスのOptions Tab）これら２つのパッドの
設定により、ネットが違う色で表示され識別が簡単になります。

ススススププププリリリリッッッットトトト････ププププレレレレーーーーンンンンのののの変変変変更更更更

スプリット･プレーンの境界は、定義された後でも変更することができます。以下の
ような変更がサポートされています。

1. スプリットプレーンの境界となるトラック幅、スプリット･プレーンを配置する
レイヤー、および接続されたネットはすべて変更することができます。これの属
性を変更するには、スプリット･プレーンの内側をダブルクリックして、スプリ
ット･プレーン･ダイアログ･ボックスを表示してください。

2. スプリットプレーンの境界となるトラックの位置を変更することができます。
Edit » Move » Polygon Vertices メニューを選択してください。Polygonを選択す
るようにプロンプトが表示され、変更するスプリット･プレーンの内側をクリッ
クしてください。境界トラックの編集ハンドルが表示されます。編集ハンドルを
クリックしてハンドルを移動してください。
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デデデデザザザザイイイインンンンのののの確確確確認認認認
Design Verificationは、デザインが正しく作成されているかを確認するプロセスです。
それは基板設計過程では基本であり、不可欠な部分です。Verificationプロセスによっ
て、基板が回路図と論理的に適合しているか確認しなければなりません。また、基板
が物理的に機能するかどうかも確認しなければなりません。さらにトラックやパッ
ド、ビアのような電気的オブジェクトはクリアランス違反が無いようにしなければな
りません。

Advanced PCBには、デザインがデザイン･ルールで指定された条件に適合しているか
を確認するための機能として、強力なDesign Rule Check機能があります。クリアラ
ンス･エラーのような配線違反や未配線のネット、トラック幅のエラー、トラックの
長さに対するエラー、さらに製造に影響するような状態もテストします。

基板設計中の生産性を上げるために、Advanced PCBにはオンラインDRC機能があ
り、配線中のコパー･クリアランス違反をテストします。違反をなくすには、単に問
題の原因になるオブジェクトを移動してください。

è デザインが正しく完成したかを確認するためには、"何についてテストが行われる
か"の参照内容が必要になります。Advanced PCBではDesign Ruleダイアログ･ボ
ックスで定義されるデザイン･ルールを参照し、テストを行います。最もよい方法
は、設計を行なう最初の時点でデザインに適したルールを定義することです。

デデデデザザザザイイイインンンン････ルルルルーーーールルルル････チチチチェェェェッッッッカカカカーーーーととととはははは?
デザイン･ルール･チェック（DRC）はデザインの論理的および物理的、いずれも完全
にチェックする強力な自動機能です。この機能は 最小クリアランス･ルールが維持さ
れているかや他のデザイン･ルール違反がないかを確認するために、ボードの配線が
行なわれるごとに使用されます。Advanced PCBではいつでもレイアウトの変更がで
きるため、常に最終的なアートワークを作成する前にデザイン･ルール･チェックを実
行することが特に重要です。

Online DRC
オンライン･デザイン･ルール･チェック機能を有効にするには、Preferencesダイアロ
グのOptionタブのチェックボックスをオンにしてください。この機能が有効の状態の
時、マニュアル配線等の作業中に発生したバイオレーションはすぐにハイライト表示
されます。Design Rule CheckingダイアログのOn-lineタブにおいてチェックされてい
る項目はオンラインDRCによってテストされます。(Tools » Design Rule Check を選
択してください).

è ルールが定義されていない場合、チェック項目はグレーで表示され、チェックす
ることができません。もし、テストしたい項目がグレーで表示されている場合
は、Design » Rules  を選択し、デザインルールを定義してください。

è ポリゴンやパワープレーンを使用し配線されたラージネット(たくさんのノードを
持つネット)がデザインに含まれ、それらのネットに関係する編集を行った場合、
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コネクションのアナライジングに長い時間が必要になります。このアナライジン
グの機能はネットを”hide”にすることによって無効にすることができます。View
» Connections » Hide Net  を選択し、任意のネット上をクリックしてください。

ババババッッッッチチチチモモモモーーーードドドドにににによよよよるるるるデデデデザザザザイイイインンンン････ルルルルーーーールルルル････チチチチェェェェッッッッククククのののの設設設設定定定定
Tools » Design Rule Check メニューを選択すると、Design Rule Checkingダイアロ
グボックスが表示されます。

デザイン･ルール･チェックはアートワークを作成する前に必ず行ってください。

バッチDRCには以下の機能があります。

Rules

テストしたいルールの項目をオンにしてください。各ルールの詳細はデザイン･ルー
ルの項を参照してください。

Create Violations

この機能がオンの場合、現在設定されたDRC Errorカラーでクリアランスやパラレル
セグメントに関するエラーがハイライト表示されます。

è パネルのブラウジングの設定をViolationsにすると、現在のエラー箇所を一覧する
ことができ、エラー箇所へ簡単に移動することができます。

Sub-Net Details

このオプションはUnrouted Net Ruleと関連しており、サブネットの詳細が必要な場
合、このオプションをオンしてください。
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è Unrouted Net Rule はすでに配線された場合のみオンにしてください。コネクショ
ンラインは実際は未結線です。

Stop When Found XX Violations

エラーの数がここで設定された数に到達するとデザインのテストを停止します。

Create Report File

Create Report Fileオプションをオンにすると自動的にDRCレポート･ファイルが作成
され、Text Expertで開かれます。ファイル名が指定されない場合、filename.DRCとい
う名前でレポートが作成されます。

ババババッッッッチチチチDRCのののの実実実実行行行行

バッチDRCをスタートするには、Design Rule Checkingダイアログの設定終了後、
Run DRCボタンをクリックしてください。DRCが終了すると、レポートファイルが
Text Editorにオープンされます。

The DRC Report

DRCレポートは、Choose Rule Set to Checkダイアログ･ボックスで指定された項目の
テスト結果が記録されます。(提示されていないルールはテストされません)それぞれ
の違反には、参照する情報の詳細が記録され、それらの情報には、レイヤー、ネット
名、コンポーネント･デジグネータとパッド番号、また当然のことながらオブジェク
トの位置も含まれます。クリアランスやトラックの長さ、およびトラック幅のエラー
の場合、現在のDRCカラーでオブジェクトの輪郭がハイライト表示されます。

DRCをををを実実実実行行行行すすすするるるる際際際際ののののヒヒヒヒンンンントトトト

DRCレポートはAdvanced PCBになれていないユーザーにとっては扱いにくく感じら
れるかもしれないのですが、使い方にはいくつかのコツがあります。例えば１つの方
法としてレポートされるバイオレーションの数を少ない値に設定することです。
Design Rule CheckingダイアログのStop when found機能を10程度の値にしてくださ
い。またDRCによってテストされる項目を少なくし、いくつかの段階に分けて実行す
ることもDRCを効率よく使うためのコツといえるでしょう。経験を積んでくると状況
に応じていろいろなデザインルールのテストができるようになります。

レレレレポポポポーーーートトトトととととPCB間間間間ののののククククロロロロスススス････ププププロロロローーーーブブブブ

クロス･プローブは、PCBファイルとレポートファイルの間で作業するために
使用できます。２つのドキュメント･ファイルを並べて表示し、レポート･フ
ァイルの希望する参照箇所を選択して、テキスト･エディタ･ツールバーの
Cross Probeボタンを押してください。コンポーネント･デジグネータやピ
ン、XYロケーション、文字列を参照箇所として使用できます。クロス･プローブされ
たオブジェクトはPCBウィンドウの中央に表示されるように画面が切り替わります。
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Jump 機機機機能能能能にににによよよよるるるるオオオオブブブブジジジジェェェェククククトトトトへへへへのののの移移移移動動動動

Jumpショートカットを使用してコンポーネントやパッド、ネット、エラー･マーカ
ー、指定された位置にすばやく移動できます。ショートカット･キー"J"を押してJump
メニューをポップ･アップ表示してください。

ブブブブララララウウウウズズズズモモモモーーーードドドドにににによよよよるるるるババババイイイイオオオオレレレレーーーーシシシショョョョンンンンのののの確確確確認認認認

パネルのブラウズモードをViolationsに切り替えることによって、PCB上の違反箇所の
リストを表示することができます。DetailsボタンをクリックするとViolation Detailsダ
イアログが表示され、ルールやプリミティブなどの違反箇所の詳細を確認できます。

Tracking Down Broken Nets

壊れたネット(Broken Net)は事実上“未接続”で、２つの壊れたサブネットは1箇所の
未接続を表し、3つ壊れたサブネットは2箇所の未接続を表します。未接続の箇所は以
下の手順で探しだすことができます。

1. PCBエディタパネルのブラウズモードをViolationsにしてください。

2. Jumpボタンをクリックし、ネット全体を確認できるズームレベルに変え、Hilight
ボタンを使ってネットを“フラッシュ”させます。

3. ネットを識別するために、Edit » Select » Net (ショートカット; S, N)を選択し、
ネットをクリックします。

4. サブネットを識別するには、Edit » Select » Connected Copper (ショートカッ
ト; S, P)を選択し、ネットのオブジェクトをクリックしてください。

Select » Connected Copper はサブネットがハイライト表示されるのに対し、Select
» Net はネット全体がハイライトされます。この違いを利用し、ネットの未接続の位
置を探し出すことができます。このテクニックをうまく利用するには、Preferencesダ
イアログのExtend Selectionをオフにしておく必要があります。
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ネネネネッッッットトトト上上上上ののののエエエエククククスススストトトトララララピピピピンンンンのののの確確確確認認認認

レポートにおいて、壊れたネットの中にたくさんのサブネットが含まれ、1つめのネ
ットに含まれるはずのピンが別のネット上にエクストラピンとしてレポートされた場
合、これらの2つのネットはショートしている可能性があります。このようなケース
は、Short-Circuit Rule をチェックすることによってショートしている箇所をレポート
することができます。
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アアアアーーーートトトトワワワワーーーーククククのののの出出出出力力力力

PCBレイアウトを完成させることは、PCBの製造･組立てまでの段階の最初の部分に
すぎません。設計と完成した基板とを関連付けるものは、Advanced PCBデザイン･シ
ステムに組み込まれたPlot/PrintやGerber、NC Drill機能を使用して作成されるアート
ワークです。システムには、設計過程においてデザインを確認するための、いろいろ
な"ハード･コピー"をサポートする機能が組み込まれており、コンピュータに直接プリ
ンタが接続されている場合でもGerberファイルを製造者へモデムで送信する場合にお
いてもその機能を使うことができます。

アアアアーーーートトトトワワワワーーーーククククのののの種種種種類類類類ににににつつつついいいいてててて
通常、インパクトプリンタやレーザープリンタなどのプリンタ出力は、チェック･プ
リントに適しています。これらのプリントにより出力ファイルの確認ができますが、
最終的なアートワークにこれらが使用されることはありません。レーザー･プリンタ
の解像度が改良とともに、多少質が落ちるとしてもユーザーの中には、簡単な試作基
板の作成にはプリンタ出力が適していると考える人もいます。プリント出力自体の直
線的な歪みはレイヤー登録やpad hole-to-pin配置に問題があることがあります。

ほとんどのユーザーは、高解像度の出力装置を利用してPCB製造者の要求する品質を
満足する必要があります。これまでは、ペン･プロッタかフォトプロッタを使用する
ことを意味していました。Advanced PCBでは、Windowsが使用できる出力装置をす
べてサポートします。加えて、Advanced PCBには、HP-GLやDM-PL、それらの互換
プロッタに直接プロットできる特別のオプションがあり、同様にGerber標準フォトプ
ロッタもサポートしています。

ポポポポスススストトトトススススククククリリリリププププトトトト出出出出力力力力
高解像度ポストスクリプト“イメージセッタ”が、グラフィックアートや写植の業界
で一般的に使用されています。このデバイスは、2540dpi(インチあたりのドット数)で
ポジフィルムを作成することができ、がーバープロットの代用として使用することが
できます。

このデバイスをPCBアートワークに使用する場合、制限があることに注意してくださ
い。特に大きなエリアでは、位置や直線性の精度が正確ではなく、またフィルムサイ
ズにも制限があります。

フフフフォォォォトトトトププププロロロロッッッッテテテティィィィンンンンググググ
ガーバーフォーマットフォトプロッティングは、高解像度による品質の高いアートワ
ークを作成することができるため、一般的に基板製作を行う方法として用いられてい
ます。デザインの総面積が大きい場合や、精密さが要求される場合はフォトプロット
が必要になります。
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ププププリリリリンンンントトトト基基基基板板板板製製製製作作作作をををを依依依依頼頼頼頼すすすするるるる場場場場合合合合のののの注注注注意意意意
設計の始めるにあたり、基板の製造技術や製造方法により“何を”“どのように”出
力しなければならないかを、明確に考えておかなければなりません。

基板製造メーカーやプロットサービス業者に依頼してアートワークを作成する場合に
は、事前に出力に関する仕様の打ち合わせを行うことが必要です。場合によっては業
者の要求する仕様に応じてファイルやアートワークを提出しなければならない場合が
あります。例えば基板を量産したい場合などにはガーバーファイルをパネライズ(面付
け)する必要がでてきます。

これを行なうには作画の際に使用するフォトプロッタのフィルムサイズやクリアラン
スなどの仕様、また製造時の許容差に関係する事柄を知っていなければなりません。
NCドリルについても同様に考えておく必要があります。

いくつかの実例では、基板業者ではパネライズ(面付け)されたガーバーデータより
も、"そのまま"のデータの方が作業を直接おこなう事ができるので好まれます。これ
らの必要条件を理解することは、効果的に、そして トラブルのない基板を完成するた
めの、全体の設計プロセス計画の助けになります。

ププププリリリリンンンントトトト////ププププロロロロッッッットトトトアアアアウウウウトトトト可可可可能能能能ななななレレレレイイイイヤヤヤヤーーーー
プリントやペン･プロット、Gerberプロットできるレイヤーを以下に示します。

ソソソソルルルルダダダダーーーー････ママママススススクククク (Top and Bottom)

これらのマスクは、デザインのパッドやビアと一致します。マスク･レイヤーは自動
的にパッドに基づいて作成されます。これらのマスクを大きくすることは、製造誤差
を扱うために必要で、Solder Mask Expansionデザイン･ルールで指定されます。特定
のパッドに異なる要求がある場合、複数のルールを追加することができます。Solder
Mask Expansionルールの詳細は、デザイン･ルールの項を参照してください。

ペペペペーーーースススストトトト････ママママススススクククク (Top and Bottom)

ペースト･マスクはソルダーマスクに似ていますが、このマスクは、”ホット･リフロ
ー”技術を使用してSMDコンポーネントを実装する時に、ソルダー･ペースト･スクリ
ーンを作成するために使用されます。ソルダーマスクのように、ペースト･マスクは
反転してプロットされます。これらのマスクには、Paste Mask Expansionデザイン･
ルールを使用して、各パッドでの拡大と縮小を定義することができます。特定のパッ
ドに異なる要求がある場合、複数のルールを追加することができます。Paste Mask
Expansionルールの詳細は、デザイン･ルールの項を参照してください。

ドドドドリリリリルルルル････ガガガガイイイイドドドド

各穴あけ部分に小さい十字が表示され、穴あけの視覚的なターゲットが表示されま
す。それぞれオンにされたレイヤーの組みあわせでプロットが作成されます。
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ドドドドリリリリルルルル････ドドドドロロロローーーーイイイインンンンググググ

各ドリル部分のDrill Drawingレイヤーにマーカーが配置されます。このマーカーに
は、アルファベット文字や穴のサイズを表わす文字列、グラフィカル･シンボルを使
用することができます。.LEGENDの スペシャル･ストリングをDrill Drawingレイヤー
に追加すると、穴の数やドリル･サイズを出力できます。Graphic Symbolsオプション
を使用すると１６個の異なる穴の大きさを出力できます。

トトトトッッッッププププ････レレレレイイイイヤヤヤヤーーーー

これは、”部品搭載側”の信号レイヤーです。トラックやアーク、フィル、文字列、
このレイヤーに配置されるトップ･レイヤー･パッドはすべて出力されます。また、マ
ルチ･レイヤー･パッドとビアも出力されます。

ミミミミドドドドルルルル････レレレレイイイイヤヤヤヤーーーー (1–14)

Advanced PCBでは、14のミッド･レイヤーを使用できます。これらのレイヤーに配置
されたプリミティブはすべて出力されます。同時にマルチ･レイヤー･パッドとビアも
出力されます。

ボボボボトトトトムムムム････レレレレイイイイヤヤヤヤーーーー

PCBの“半田面”ともいわれます。また、コンポーネントもこのレイヤーに配置され
ます。トラックやアーク、フィル、文字列、このレイヤーに配置されたボトム･レイ
ヤー･パッドがプリントされます。同時にマルチ･レイヤー･パッドとビアも出力され
ます。

トトトトッッッッププププ････オオオオーーーーババババーーーーレレレレイイイイ、、、、ボボボボトトトトムムムム････オオオオーーーーババババーーーーレレレレイイイイ

シルクスクリーン･レイヤーとも呼ばれ、通常、コンポーネントのアウトラインやコ
ンポーネントのテキストとして使用されます。

イイイインンンンタタタターーーーナナナナルルルル････パパパパワワワワーーーー････ププププレレレレーーーーンンンン

これらの特別な内部レイヤーは、製造された基板では大部分を銅箔面であり、効率良
くするためにネガイメージで印刷されます。銅箔面に空白(銅箔の無い部分)を作成し
たい場合は、このレイヤーにフィル、トラックまたアークを配置します。例えば、製
造業者の多くは、基板周辺部分から銅箔がはみ出ないように基板の周囲にトラックを
配置することを推奨しています。

メメメメカカカカニニニニカカカカルルルル････レレレレイイイイヤヤヤヤーーーー 1–4

これらのレイヤーは、製造や組立図などを作成するために使用され、これらの図は、
寸法やトリム･マーク、基準マーク、穴指示、組立て指示、その他基板の機械的仕様
を示します。これらレイヤーの内容は、印刷時に他のレイヤーに追加することができ
ます。

パパパパッッッッドドドド････ママママススススタタタターーーー

これらのレイヤーはトップまたはボトムレイヤーの全てのパッドを印刷する場合に使
用されます。
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ミミミミドドドドルルルル････レレレレイイイイヤヤヤヤーーーー････パパパパッッッッドドドド

ミドルレイヤーに接続されないマルチ･レイヤー･パッドをガーバーデータ作成および
印刷時に出力から削除することができます。

キキキキーーーーププププ････アアアアウウウウトトトト････レレレレイイイイヤヤヤヤーーーー

Keep Outレイヤーの内容が印刷されます。

出出出出力力力力のののの設設設設定定定定
Advanced PCBから出力を作成するには、いくつかの方法があります。１つはGerber
ファイルの生成です。この場合、PCB情報はGerberファイルに変換され、フォトプロ
ット業者はフォトツール１式を作成できます。出力を作成する３つめの方法は、
Windowsのドライバーを介して行なう方法です。これにより、多くの印刷技術や
Windowsでサポートされる装置が利用できます。

出力形式の選択、および設定を行う
には、File » Setup Printer を選択し
ます。Printer Setupダイアログが表示
され、現在使用可能なドライバーの
一覧が表示されます。また、他の出
力デバイスを追加したい場合には、
Windowsの設定によって、プリンタ
やプロッタを追加してください。

Advanced PCBにはWindowsドライバ
ーとは別にProtelプロッタドライバー
が組み込まれており、指定したポー
トへプロットデータを送ることがで
きます。これらは一般的な HP-
GL/DM-PLプロッタドライバーで
Windowsベクタープロッタドライバ
ーが入手できない場合に使用することを目的としています。このドライバーは
Advanced PCBに組み込まれていますが、現在ではほとんどの出力デバイスに
Windowsのドライバーが添付されており、これらのドライバーを使うことによってネ
ットワークなどへの出力が可能になります。Windowsプロッタドライバーについては
販売店やプロッタメーカーにお問い合わせください。

ドライバーがインストールされると現在使用可能な出力デバイスリストへ追加さ
れ、”Final”とComposite”の出力が可能になります。

Final Output Drivers
ファイナルアウトプットオプションは、出力時にオンされているそれぞれのレイヤー
ごとに印刷します。必要に応じて、それぞれのレイヤーを１枚のシート上にパネライ
ズすることができます。このオプションは“ファイナルアートワーク”作成時に使用
されます
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Composite Output Drivers
コンポジットアウトプットオプションは出力時、オンされた全てのレイヤーを印刷し
ます。これにより、必要なレイヤーを重ねたボードのイメージを出力できます。これ
らは、”チェック･プロット”としても知られています。プリンタの能力により、各
レイヤーを異なる色やグレー･スケールで印刷することができます。   

Layers Button
Setup Printerダイアログ･ボックスのLayer Buttonが押された場合、選択された出力形
式がGerberか、final、compositeかによって表示されるダイアログボックスの内容は変
わります。

Gerber and Final Output

Layerボタンを押すと、Setup Output Optionダイアログが表示されます。このダイア
ログには3つのタブがあります。

Layers

出力したいレイヤーを設定します。レイヤーの中でメカニカル･レイヤーは他の
レイヤーと合成して出力することができます。

Drill Plots

このタブでは、Drill DrawingレイヤーとDrill Guideレイヤーの設定を行います。ま
た、Drill Drawing Symbolの設定もここで行うことができます。これらのシンボル
はスペシャルストリング.LEGENDをDrill Drawing レイヤーに配置することによ
り、ホールサイズを表すシンボルになります。

Mirroring

レイヤー･ミラーリングはレイヤーのボトムサイドを水平軸に沿って裏返しま
す。そのため、製造業者がレイヤーのレジストを落とす場合、エマルジョンサイ
ドを下にすることができます。

Composite Output

Layerボタンを押すと、Setup Composite Printer Layerダイアログボックスが表示され
ます。各レイヤーに対してレイヤーをオンするチェックボックスと“カラー”ボック
スがあります。この“カラー”ボックスにより、レイヤーに割り付けられた色やグレ
イスケールが表示されますが、出力結果については出力デバイスの性能に依存されま
す。このボックスをクリックしてレイヤーに割り付けられた色やグレイスケールを変
更してください。

Options Button
Setup PrinterダイアログボックスのOptionボタンが押された場合、選択されている出
力形式が以下のどれかによって表示されるダイアログボックスの内容は変わります。
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Final

Finalの出力デバイスをダブルクリックするとFinal Artworkダイアログが表示されま
す。

Scale

出力するデータのスケールを任意で設定することができ、また用紙サイズにあわ
せて出力することも可能です。Fit Layer On Pageオプションがオンの場合、縦横
の比率を変えることなく用紙サイズに合わせて、拡大/縮小されます。

è Fit Layer On Pageオプションを使用する場合、プリンタ設定のダイアログボック
スの縦/横の設定が、PCBの形に合っているかどうか確認してください。

X and Y Correctionは XとYの補正係数でプリンタの繰り返しエラーの補正のため
に与えられます。これら２つの値は乗算され、調整された値がプリンタへ送信さ
れます。ｘの修正値は水平の値にかけられ、ｙの修正値は垂直の値にかけられま
す。修正値を計算するには、寸法の分かっているトラックセグメントをできるだ
け大きくプリント又はプロットし、その結果を計測してください。これは、いろ
いろな座標を参照するために計測ポイントを作成する場合や、機械の問題以外の
プリンタの繰り返しエラーを確認するための何回かのテストプロットの作成に役
立ちます。補正係数を計算して、各軸の繰り返し直線エラーを修正してくださ
い。

Options

各レイヤーを別々のページに、又は紙やフィルムを節約するためにパネライズし
て同じページに印刷することができます。Show Holesオプションは、パッドやビ
アの穴を印刷します。Show Holeオプションは、ラスタータイプのプリンタで動
作し、一般的にはベクタータイプのプリンターでは動作しません。これは、渡さ
れたデータがWindowsのドライバーを通して処理されるためです。

Setup

Setupボタンを押すと、プリンタ設定のダイアログボックスが表示されます。こ
のダイアログには、プリンタドライバーと各プリンタにより異なるオプションが
あります。

è プリンタ設定ダイアログボックスからはスケール精度が±1％しかありませんの
で、PCBアートワークのスケールを設定しないでください。Final Artwork又は
Composite ArtworkダイアログボックスのScaleオプションを使用して出力スケー
ルの設定を行ってください。

Protel HPGL Plotter Final Driver

Final Artwork ダイアログには使用されるプロッタ言語やプロットデータの通信の
ためのオプションが含まれます。

SerialボタンによってSetup Serial Communicationsダイアログが表示されます。
このドライバーはポートとダイレクトに通信を行い、シリアルのデータ通信のパ
ラメータはここで設定します。使用するプロッタにあわせた設定をしてくださ
い。
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Pensボタンによってプロット時のペンスピードやペンサイズの設定を行うPlotter
Pens Setupダイアログが表示されます。

Use Software Arcsはプロットデータ内のアークコマンドに対応していないプロッ
タを使用する場合のオプションです。プロッタがアークに対して誤った結果を表
した場合にはこのオプションをオンにしてください。Advanced PCBではアーク
のデータを細かい直線に置き換えてデータを出力します。

Composite

Compositeの出力デバイスをダブルクリックするとComp;osite Artworkダイアログが表
示されます。

Scale

出力するデータのスケールを任意で設定することができ、また用紙サイズにあわ
せて出力することも可能です。Fit Layer On Pageオプションがオンの場合、縦横
の比率を変えることなく用紙サイズに合わせて、拡大/縮小されます。

è Fit Layer On Pageオプションを使用する場合、プリンタ設定のダイアログボック
スの縦/横の設定が、PCBの形に合っているかどうか確認してください。

X and Y Correctionは XとYの補正係数でプリンタの繰り返しエラーの補正のため
に与えられます。これら２つの値は乗算され、調整された値がプリンタへ送信さ
れます。ｘの修正値は水平の値にかけられ、ｙの修正値は垂直の値にかけられま
す。修正値を計算するには、寸法の分かっているトラックセグメントをできるだ
け大きくプリント又はプロットし、その結果を計測してください。これは、いろ
いろな座標を参照するために計測ポイントを作成する場合や、機械の問題以外の
プリンタの繰り返しエラーを確認するための何回かのテストプロットの作成に役
立ちます。補正係数を計算して、各軸の繰り返し直線エラーを修正してくださ
い。

Primitives

各プリミティブをFinal(塗り潰し)、またはDraft(輪郭)で作画することができ、
Hiddenにすることによってプリントしないようにすることができます。

Other Options

プリンタがカラーやグレースケールに対応している場合、Color/Grayを選択して
ください。対応されていない場合はMonochromeを選択してください。

Show Holesオプションは、パッドやビアの穴を印刷します。Show Holeオプショ
ンは、ラスタータイプのプリンタで動作し、一般的にはベクタータイプのプリン
ターでは動作しません。これは、渡されたデータがWindowsのドライバーを通し
て処理されるためです。

Setup

Setupボタンを押すと、プリンタ設定のダイアログボックスが表示されます。こ
のダイアログには、プリンタドライバーと各プリンタにより異なるオプションが
あります。
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è プリンタ設定ダイアログボックスからはスケール精度が±1％しかありませんの
で、PCBアートワークのスケールを設定しないでください。Final Artwork又は
Composite ArtworkダイアログボックスのScaleオプションを使用して出力スケー
ルの設定を行ってください。

Protel HPGL Plotter Composite Driver

Composite Pen Plotダイアログには使用されるプロッタ言語やプロットデータの
通信のためのオプションが含まれます。

SerialボタンによってSetup Serial Communicationsダイアログが表示されます。
このドライバーはポートとダイレクトに通信を行い、シリアルのデータ通信のパ
ラメータはここで設定します。使用するプロッタにあわせた設定をしてくださ
い。

Pensボタンによってプロット時のペンスピードやペンサイズの設定を行うPlotter
Pens Setupダイアログが表示されます。

Use Software Arcsはプロットデータ内のアークコマンドに対応していないプロッ
タを使用する場合のオプションです。プロッタがアークに対して誤った結果を表
した場合にはこのオプションをオンにしてください。Advanced PCBではアーク
のデータを細かい直線に置き換えてデータを出力します。

Gerber

Protel Gerber RS274を項目をダブルクリックするとGerber Outputダイアログが表示
されます。ガーバー出力を行う場合には、あらかじめ出力したいレイヤーの設定を忘
れないようにしてください。

ガーバー出力のオプションについてはこの後のセクションで説明を行います。

Generating a Print or Plot
プリントやプロット、ガーバーファイルの作成の準備ができたら、File » Print メニュ
ーを選択してください。現在のPrinter Setupダイアログの設定に基づきプリントやプ
ロットが行われます。

プリントが作成されている様子はスクリーン上に表示されます。すなわち、Panelオ
プションを使用した場合、パネライズされたファイルの状態を見ることができ、コン
ポジットオプションが選択されている場合、レイヤーが重ね合わされた状態が表示さ
れます。

プリントはいつでも中断させることができます。Cancelボタンを押すと印刷を中断す
るか続行するかを入力するプロンプトが表示されます。

Advanced PCBでは、印刷中であってもウィンドウを最小化することができ、その場
合に、印刷はバックグラウンドで実行されます。Print Managerを使用する大きなファ
イルを印刷する場合、プリンタに出力できずにプリント動作を中断しているという内
容のPrint Managerからのメッセージが表示されることがあります。これは、プリンタ
がデータを受け取る速度がPrint Managerから送られてくるデータの転送速度に追いつ
かないことを意味します。このようなことが起こった場合、プリンタが追いつくまで
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数分間待って、Print Managerプログラムを開いてResumeボタンを押して残りのファ
イルをダウンロードしてください。

è プリンタによってはフォントの回転がサポートされていないことに注意する必要
があります。また代わりのフォントは、PCB上の標準の水平方向のテキストに対
して、プリンタで出力できるサイズの場合のみ使用されます。ポストスクリプト
プリンタのようなその他のプリンタでは、フォントの回転がサポートされていま
す。

ポポポポスススストトトトススススククククリリリリププププトトトト出出出出力力力力ののののヒヒヒヒンンンントトトト
ポストスクリプト･プリンタや“イメージャ”は通常300から2540dpiの間で出力を生
成します。これらの装置からは高解像度の出力が得られるために、多くのユーザは、
アートワークをGerberプロットに代わってコストの低いポストスクリプト･プリント
で作成することに興味を持っています。しかし、印刷する前に注意しなくてはならな
い点が幾つかあります。

高解像度のレーザー･プリンタは、直接フィルムや感光紙に印刷します。これらの装
置は確かに水平方向についての精度は十分ですが、常にその直線性を維持できるとは
かぎりません。特に、フィルムや紙がロールになっている場合は維持できない場合が
あります。

今では、いくつかの植字／グラフィックアートの業者では大きなドラムにマウントし
たロール･フィルムよりカットしたフィルムを使うPostscriptイメージャーを使ってい
ます。これらのイメージャーは直線性の問題は少なくクリティカルでない設計に対し
てはGerberプロットの代替えとして適しています。

ポストスクリプトの出力装置をテストするには、分かっている長さの垂直と水平方向
のトラックのファイルを作成し、精度が分かっているメジャーで正確にその長さを計
ります。いずれかの軸に設定した補正係数のスケールを適応することができます。 直
線性の全エラーはいつも一定ではないかも知れません、そのためアートを製造する前
に各最終のアートワークのプリントの精度をチェックすべきです。

300か600dpiのデスクトップ型のレーザー･プリンターでの他の問題はトナーが紙に溶
融定着する時に作られる“オーバースプレー”と“ブリード”の影響があります。線
のどちらかの側に小さな粒子が紙に付着し、アートワークでは好ましくない電位が発
生します。

レーザープリンタで印刷することを前提に設計する場合は、クリアランスを多めに
し、スケールとブリード効果を極小化するために適当なスケールでプリントすべきで
す。

レーザープリンターで得られる印刷の品質は用紙によって決まります。多くの特殊な
用紙を現在では利用することができ、この用紙ではこのトナーの“ブリード”効果を
減少し外形線がシャープになります。これらの特殊な用紙のいくつかは少し重く、扱
いやすくするために切り張りをした版下に使われているワックスや糊の影響を受けな
いような処理がされています。特に、これらの用紙をクリーンにしておく必要があり
ます。
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ポストスクリプトに互換性のあるフォト-タイプセットには非常に高解像度（2540dpi
まで）の出力を得ることができます。これらの出力装置は直接A3（又は“Ｂ”）サイ
ズまでのポジのフィルムを印刷することができます。

しかしながら、前述した直線性についての問題は同様にこれらのの装置においても存
在します。直線性の精度の問題は既にグラフィック･アートの業界でカラーセパレー
ションを行うイメージセッティングのところではよく出会う問題です。

è ポストスクリプト･プリンタの中には、指定された時間内にページ･マーカの終わ
りを受け取らなかった場合、現在のデータを放棄するものもあります。これは、
ページ抜けの原因になります。ポストスクリプト･プリンタやその他の印刷デバイ
スを使用してこのような問題が発生した場合、コントロール･パネルのプリンタ･
アイコンを選択し、さらにプリンタを選択してConfigureボタンをクリックしてく
ださい。Transmission Retryを500秒に変更するかもっと大きな値にしてくださ
い。これにより、Print Managerがギブ･アップする前にプリンタが追い付く充分
な時間を設定することができます。

ペペペペンンンンププププロロロロッッッッタタタタをををを使使使使用用用用すすすするるるる場場場場合合合合ににににつつつついいいいてててて
ペン･プロッタでドラフト･アートワークやファイナル･アートワークを作成する場
合、２つの基本的な選択があります。

1. Windowsプロッタドライバーを介してプロットできます。プロッタがWindowsド
ライバーにサポートされている場合、こちらを選んで下さい。これを使用する
と、最近のインクジェット･プロッタのようなラスターを使用する最新の装置で
も問題がありません。また、ベクター･プロッタ･ドライバーも使用できます。詳
細については、プロッタの販売店かProtelの代理店に問い合わせてください。

2. Advanced PCBに組み込まれたプロッタ･ドライバーを使用するとWindowsプロッ
タ･ドライバーをバイパスすることができます。このオプションにより、ベクタ
ー･タイプのHP-GLやDM-PLプロッタを直接コントロールできます。通常のペン･
プロッタを使用する場合、Advanced PCBのプロッタドライバーを使用すること
により高品質のペン･プロットを作成することができ、標準のMicrosoft Windows
プロッタ･ドライバーよりも品質の良い出力を生成することができます。

è 業者に依頼する場合、または、他のコンピュータからプロットする場合、プロッ
トデータをファイルとして作成する必要があります。Windowsドライバーで行な
うには、プロッタをプリンタ･ポートの代わりにファイルへ割り当てなければなり
ません。この方法についてはWindows User Guide参照してください。Protelのプ
ロッタ･ドライバーでファイルへプロットするには、Printer Setupダイアログ･ボ
ックスでドライバーを選択し、Optionsボタンを押してください。Pen Plotダイア
ログ･ボックスでOutput PortをFileに設定してください。プロットデータを作成す
る時に、ファイル名を入力してください。
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ガガガガーーーーババババーーーーデデデデーーーータタタタ作作作作成成成成
Advanced PCBにより、現在の基板レイアウトからGerberフォーマット･フォトプロッ
ト･ファイルを作成することができます。このGerberの作成プロセスは高度に自動化
され、ユーザーが入力する項目はほとんどありません。Advanced PCBにより、ファ
イルをフォトプロットする場合に使用されるアパーチャー･テーブルが自動的に作成
されます。また、GerberファイルをPCBエディターへ戻すこともできます。これは、
フォトプロットを実行する前にファイルを確認する便利な方法です。また、フォトプ
ロット･ファイルをロードして、PCBファイルへ戻すこともできます。これは、その
他のデザイン･システムからのPCBファイルをAdvanced PCBフォーマットへ変換する
強力な方法です。

フフフフォォォォトトトトププププロロロロッッッッタタタタににににつつつついいいいてててて
フォトプロッタは多くの部分でペンプロッタと似ています。その主な相違点は、フォ
トプロッタは感光紙に直接、光を当ててプロットすることです。この方法による多く
の利点のために電気業界にフォトプロットが広く採用されています。

プリント基板のエッチングは、一般的にフォトグラフィック技術に基づいており、ポ
ジとネガのフォトツール（フィルム）の作成は、基板製造の工程の上で重要な部分で
す。オリジナル･アートワークがペン･プロットの場合、最終的なツールを作成するた
めには、多くの中間段階での作業が必要になります。実用的な精度を確保するために
ペン･プロットは通常少なくとも2:1の縮尺でブロットされます。

フォトプロッタを使用すると、1:1の縮尺でも十分な精度を得られます。フォトプロッ
トの業者のサービスは幅広く利用することができ、設計者はその利点について十分考
慮する必要があります。フォトプロットを有効に使用するには、いくつかのポイント
となる考え方を理解することが大切です。

ベベベベククククタタタターーーー････ププププロロロロッッッッタタタタととととララララススススタタタターーーー････ププププロロロロッッッッタタタタ
フォトプロッタは、ラスターとベクターの２つの大きなカテゴリーに分けることがで
きます。

ベクター･プロッタは一般的に、“ホイール”または“スライド”のアパーチャーを
使用し、“フラッシュ”と“ストローク”の組み合わせでイメージを作成します。ベ
クター･プロッタはペンプロッタとほとんど同様の方法でイメージを作成します。描
画するためにはインストルメント（またはアパーチャー）を選択し描画領域にベクト
ルのイメージを描画します。 その結果、アパーチャーで指定された幅が線となりま
す。アパーチャーはプロッタで使用されるさまざまなトラックの幅、パッドの形状な
どが定義された集まりです。光源の動きがない場合はフラッシュが生じ、光源がonし
ている間に動きがあればストロークが生じます。いくつかのプロッターは適切な露光
を維持するためにストロークとフラッシュに対して別々のアパーチャーを使います。
他に光の強度をコントロールします。-光の強度はどちら(フラッシュ、ストローク)を
使用するかで変わります。
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ラスター･プロッタは固定されたアパーチャーを使用しません。このプロッタは、ガ
ーバー･ファイルをを読み込んで、イメージ全体を作成してフィルム上に焼き付けま
す。ラスター･フォトプロッタは、仮想的に無限種類のアパーチャーを合成すること
ができます。したがって、設計者の要求に柔軟に対応することができます。

フォトプロッタの中には、ポストスクリプト言語を使用するものもあります。これら
の装置に対応するフォトプロット･ファイルは、適切なポストスクリプト･ドライバー
を使用して作成します。ポストスクリプト印刷についての詳細は、ポストスクリプト
出力のヒントの項を参照してください。

ターゲットとなるフォトプロッタを効率的に利用するには設計段階でフォトプロッタ
について基本的な知識が必要になるでしょう。

è データを提出する前に基板製作を依頼するメーカーとデータの仕様等について確
認をして下さい。設計段階でメーカーの仕様にあわせることによってガーバー･フ
ォト･ツールを作成にかかる費用と時間を抑えることができます。

フフフフォォォォトトトトププププロロロロッッッッタタタタ言言言言語語語語

ほとんどのフォトプロッタは、ベクターベースのプロッティング言語で制御され、こ
のプロッティング言語は“ガーバー”(Gerber Scientific Coの登録商標)と呼ばれ、フ
ォトプロットを行うために開発されたものです。この言語は業界の標準として使用さ
れています(RS-274)。この言語はプロッティング装置やデザイン業務の変化に対応し
てきたにもかかわらず、ガーバー出力を作成する場合、基本的な問題点、ならびに制
限事項を考慮する必要があります。

ガーバー･フォーマット･ファイルには、一連のドラフト･コードと座標データが記述
されています。ドラフト･コードは使用するアパーチャーや光源のオン･オフを制御す
るためのものです。座標データによりプロット上のフラッシュやストロークの位置が
定義されます。これらの情報は、ASCIIテキスト･ファイルとして保存されます。

ガーバー･ファイルの構造は、プロッティング･ハードウェアの能力の改善に伴い永年
の改良により変わっています。Protelのガーバー･フォーマットに関する詳細を以下に
示します。

Protelのガーバー･ファイルは、キャリッジ･リターンで区切られるコマンドとライン･
フィード･コマンドで分けられます。それぞれのレコードは "*"文字で終了します。

レコードにより、絶対位置とアパーチャー交換のドラフト･コードが参照されます。
レコードが"X800Y775*"のように記述されている場合、プロッタに特定の座標への移
動が命令されます。また、"D16*"は、アパーチャー変更のドラフト･コードです。

プロッタの中には、D01--D09のドラフト･コードをアパーチャーの変更以外で使用す
るものもあります。例を以下に示します。

· D01 光源のオン。
· D02 光源のオフ。
· D03 光源のフラッシュ。

古いプロッタの中には、アパーチャー･コードを変更する前に"G54"という特別なコー
ドを入力する必要のあるものがあります。最後のガーバー･レコードは、M02*という
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特別なレコードで"hex 08,"があり、それから509"spaces"(hex20)、そしてキャリッジ･
リターンとライン･フィードが続きます。

ガーバー･ファイルは、フォーマットの無いテキスト･ファイルとしてテキスト･エデ
ィタやワード･プロセッサにロードすることができます。

アアアアパパパパーーーーチチチチャャャャーーーーととととはははは？？？？

ガーバー･フォーマット･フォトプロッタはフィルムの各種のツールを描画するために
アパーチャーを使用します。ベクター･プロッタの場合、これらのアパーチャーは、
アパーチャー･ホイールやアパーチャー･スライドの様々な大きさ形の穴にあたりま
す。光はこれらのアパーチャーをとおってフィルムに感光します。

ラスター･プロッタには、特定のアパーチャーの大きさや形の制限がありません。ラ
スター･イメージング･システムでは、ガーバー･ファイルのアパーチャー情報を認識
してプロット･イメージ全体を合成してビット･マップでイメージを表現します。

アアアアパパパパーーーーチチチチャャャャーーーーのののの使使使使いいいい方方方方

PCBファイルをガーバー･ファイルに変換するために使用されるアパーチャーは、拡
張子.APTでファイルに保存されます。アパーチャーは、プロッタ･ペンのようなもの
です。アパーチャーには、50mm squareという形状とFlash、Stroke、Anythingなどの
使用方法が記述されています。

ガーバー･ファイルを作成する前に、使用するプロッタの能力に合ったアパーチャー･
ファイルをロードするか、現在のPCBファイルのプリミティブから展開されるアパー
チャー･ファイルを自動的に作成してください。ベクター･プロッタを使用する場
合、.APTファイルのアパーチャーは実際に使用できるアパーチャー･ホイールやスラ
イドに対応します。フォトプロッティング業者はベクター･プロッタに対応するアパ
ーチャー･テーブルを供給します。ラスター･プロッタは、アパーチャー･ファイルを
使用して、ドラフト･コードを直接イメージ･マップに変換します。使用するプロッタ
がラスター･デバイスの場合、アパーチャーをPCBから作成し、作成されたアパーチ
ャーとガーバー･ファイルを業者に支給します。出力の仕様については、フォトプロ
ット業者に問い合わせてください。

既存のアパーチャー･ファイルを使用する場合、PCBファイル内のプリミティブを検
索し、検索されたプリミティブとロードされたアパーチャーファイルとの比較を行い
ます。アパーチャーファイルの中に一致するアパーチャーが無い場合、プリミティブ
は自動的に適当なアパーチャーで”ペイント(塗りつぶし)”されます。”ペイント”
する適当なアパーチャーがない場合、.MATマッチ･ファイルが作成され、必要なアパ
ーチャーをリストアップし、ガーバー･ファイルの作成が中止されます。

ベクター･プロッタの場合、アパーチャーと一致するプリミティブを使用してくださ
い。設計者がフォトプロッタでサポートされるアパーチャー･セットに熟知してお
り、それらに対応してPCB上のオブジェクトを選択し配置しなおすことによって、フ
ォトプロッタは、もっとも効率的にファイルを再生成することができます。
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アアアアパパパパーーーーチチチチャャャャーーーーのののの読読読読みみみみここここみみみみとととと編編編編集集集集

すべてのアパーチャーの取り扱いは Apertures ダイアログで行われます。

フォトプロットに使用されるアパーチャーの読み込み、登録、編集を行う場合には、
Design » Aperture Library メニューを選択してください。このメニューを選択する
と、Apertureダイアログが表示され、現在読み込まれているアパーチャーの一覧をみ
ることができます。これらのアパーチャーはこれから出力するフォトプロットに使用
されます。アパーチャーが読み込まれていない場合はアパーチャーリストは表示され
ません。各オプションは新規、もしくは既存のファイルに対して変更を行う場合に使
用され、変更された内容がメモリに読み込まれます。また、変更された内容を保存す
るには、Save to APT Fileボタンをクリックしてください。

è D00--D999の1000個のドラフトコードを定義できます。使用するプロッタに応じ
て幾つかのコード(D00-D09)は予約されているかもしれません。従って、これら
のコードの使用はなるべく避けてください。

è 新しいアパーチャーを設定するとき、ドラフトコードに"D"をつけないでくださ
い。この文字は自動的につけられます。
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ガガガガーーーーババババーーーー出出出出力力力力のののの設設設設定定定定
ガーバーファイル作成の設定はプリント/プロットの設定方法とほぼ同様です。そのた
めこのセクションを読む前にあらかじめ前セクションにおいて、プリント/プロットに
関する基本的な事柄を把握しておくことをお勧めします。

ガーバー･ファイルを作成するには、File » Setup Printer  メニュー(ショートカット
F,R)を選択し、Setup Printerダイアログ･ボックスを開いてください。File outputオプ
ションのProtel Gerber RS274を選択してください。Layersボタンを押して出力するレ
イヤーを設定してください。Setup Peinterダイアログ･ボックスのOptionsボタンを押
してGerber Outputダイアログ･ボックスを表示してください。

ガーバープロットを行う前に、使用するフォトプロッタの仕様について理解
しておく必要があります。

Apertures

アパーチャー･ファイルが設定されない場合、Aperture Libraryボタンを押して
Aperturesダイアログ･ボックスを表示してください。

Plotter Type

これらのオプションは、作成されたガーバー･ファイルを、ベクター･プロッタま
たはラスター･プロッタで効率良くプロットできるように処理します。Vector Plot
オプションは、プロット･ファイルの作成が遅くなりますが、マシンのプロット
は早くなります。このオプションを使用するとプロット時間が短縮されますの
で、業者で時間によって決められる作画料金を安くすることができます。Raster
Plotオプションをplot unsortedにするとプロット･ファイルをより早く作成するこ
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とができます。ラスター･プロットでプロット･ファイルをソートしてもあまり意
味がありません。

Film Size

これらのフィールドで、使用するフォトプロッタで使用するフィルム･サイズを
設定してください。デフォルトでは、12インチＸ16インチの大きさです。業者に
使用できるサイズを確認し、作画の向きとＸとＹの値の指定には注意してくださ
い。各フィルムに必要なボーダー･サイズを設定してください。各プロットの周
囲のボーダーサイズを定義してください。すなわち、パネライズされたプロット
とプロットの間には、ボーダー･サイズの少なくとも２倍のスペースが必要で
す。システムは、プロットの間隔を広げててプロットの周囲のボーダーが等しく
なるようにします。

Use Software Arcs

フォトプロッタの中には、ガーバー･アーク描画コマンドをサポートしていない
物もあります。このようなアークはプロッタで作成され”ハードウェア･アー
ク”と呼ばれます。Advanced PCBは、一連の短い直線セグメントでアークを描
画することができます。このようなアークは”ソフトウェア･アーク”と呼ばれ
ます。使用するプロッタがサポートしている場合、ハードウェア･アークを使用
してください。詳細はフォトプロット業者に確認してください。Use Software
Arcsが選択されているかどうかに関係なく、どんなに小さなアーク角度でも、ソ
フトウェア･アークは作成されます。

G54 On Aperture Change

初期のモデルのフォトプロッタの中には、アパーチャーの変更コマンドの前の制
御コードにG54コマンドが必要なものがあります。まず、フォトプロット業者に
確認してから、このオプションをオン／オフしてください。

Center Plots on Film

これがオンの場合、Advanced PCBはプロットの大きさを計算し指定された大き
さのフィルムの中央にプロットされるようにガーバー･ファイルの座標を計算し
ます。このオプションがオフの場合、ガーバー･ファイルの座標はワークスペー
スの左下を基準にして計算されます。このオプションを使用する場合、選択した
フィルム･サイズの正しい場所にデザインが位置することを確認してください。

Embedded Apertures (RS274X)

このオプションがオンの場合、フォト･ツールを作成するために必要なアパーチ
ャーは、RS274Xガーバー･ファイル仕様に従い、ガーバー･ファイルに書き込ま
れます。組み込まれたアパーチャーが使用される場合、アパーチャー･ファイル
をガーバー･ファイルと一緒に送る必要はありません。フォトプロット業者に
RS274X組み込みアパーチャーをサポートしているかどうか確認してください。

Format

ガーバー･ファイルの座標の数値フォーマットを指定してください。書式は、A:B
です。ここでAは、小数点前の桁でBは小数点以下の桁です。これらはインチ単位
で表わします。2:3フォーマットの意味は、ガーバー･ファイルの最大値は99.999
インチで最小値は0.001インチ（1mil）です。ミリ単位のガーバー･ファイルもサ
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ポートされており、ミリ単位での2:3（インチ）は5:3（mm）にあり2:4は5:4、
2:5は5:5になります。

Match Tolerances

フォトプロット･ファイルの作成中、Advanced PCBはプロット･レイヤーのアイ
テムに一致するアパーチャーを検索します。現在のアパーチャー･リストの中に
一致するものがない場合、Match Tolerancesが確認され、わずかに大きかったり
わずかに小さかったりするアパーチャーでも使用できるかどうかが判断されま
す。

例えば、62milのパッドの場合に、62milのアパーチャーを使うことによって最も
効率良く作画することができます。しかしフォトプロッタで62milのアパーチャー
による作画を行うことができない場合にはどのようにすればよいでしょうか？こ
の場合にオリジナルのプリミティブに近いアパーチャーを代用し作画を行いま
す。例えば62milの代わりに60milのアパーチャーを使用するとすれば、Match
Toleranceの値を－2にします。この方法で作画されたパッドは60milになります。

完全に一致するアパーチャーが無い場合や誤差範囲のアパーチャーが無い場合、
Advanced PCBは小さいアパーチャーを使用して必要な形状を作成しようとしま
す。これには、適当なアパーチャーが使用できることと、このアパーチャーがペ
イントに使用できることが必要です。フォトプロッタの中には、各アパーチャー
の使用をフラッシュかストロークのどちらかに制限しているものがあります。そ
の他のプロッタでは、使用に制限がありません。プロッタの能力のこのような違
いから、ガーバー･プロットを使用するプロッタに合わせて計画することが重要
になるわけです。

è Match Tolerancesは、通常アパーチャー･ファイルを必要とするベクター･フォー
マット･ファイルをプロットする時に使用されます。しかし、PCBから作成され
るアパーチャーの場合、それらは必要ありません。Match Tolerancesが必要ない
場合、これらは、0.005milのデフォルト値のままにしてください。

Batch Mode

Separate File for Each Layerを選択して、各レイヤー毎にフィルムに作画するこ
とができます。一枚のフィルムにレイヤーを自動的にパネライズするにはPanel
Filesオプションを使用して下さい。また（上記で設定したFilm Sizeの設定に対し
て）レイヤーのスペースが不足している場合、システムは、プロットは複数のフ
ァイルに分けて作成されます。最初のファイルは、ファイル名.P01で次のファイ
ルは、ファイル名.P02となります。

The Plot Generation Process
以下の点が満足されていることを確認してから、ガーバー･ファイルを作成してくだ
さい。

1. 使用するプロッタが決まっており、その出力の能力やファイル･フォーマットの
仕様を理解している。
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2. Gerber Outputダイアログ･ボックスで適切なアパーチャー･リストが指定されてい
る。このリストは、使用するプロッタのアパーチャーファイルをロードしたもの
か、またはPCBファイルから直接作成されたものです。

3.  必要な layersがオンされている。

4.  Gerber Outputダイアログ･ボックスが正しく設定されている。

 これらのポイントで確認できないものがあれば、先の情報を再確認するか、フォ
トプロット業者またはPCB製造業者に問い合わせてください。プロッティング業
者や製造業者に問い合わせれば、コスト的な失敗等を防ぐための有効な設計アド
バイスを受けられることがよくあります。

Printer Setupダイアログ･ボックスでPrintボタンを押してガーバー･ファイルを作成し
てください。Photoplot Output Filenameダイアログ･ボックスが表示されます。拡張子
の無いファイル名を指定していることに注意して下さい。予め設定された拡張子が自
動的に追加されます。ファイル拡張子のリストについての詳細は ガーバー出力される
ファイルについての項を参照してください。

プロッティング･シーケンスが始まると、ボードはスクリーン全体に再描画されま
す。ガーバーの作成プロセスには多くの段階があり、これらの段階はステータス･バ
ーにメッセージとして表示されます。

Removing Duplicates – このオプション（Preferencesダイアログ･ボックスのOptions
タブ）がオンの場合、同じ位置に同じプリミティブがないかデザインの中が検索され
ます。このような重複は、ガーバー･ファイルに記述されません。使用するフォトプ
ロッタがベクター･プロッタの場合にこのオプションを使用してください。フォトプ
ロッタがラスター･プロッタの場合、このオプションは必要ありません。これらのプ
ロッタでは、自動的に重複が削除されます。Removing Duplicatesオプションをオンに
すると、特に大規模なデザインではガーバー作成に時間がかかるようになります。

Building the Shape List and Matching Apertures – このリストはボードファイルに含ま
れる形状に、どのアパーチャーが割り当てられたかを表わしており、その状況はその
行の左端に瞬間的に表示されます。

Checking Internal Pads and Vias – "Include Unconnected Mid Layer Pads"オプション
オフの場合、ミッド･レイヤーが検索され接続されないパッドとビアが削除されると
このメッセージが表示されます。

Sorting – ベクター･フォトプロットが作成されると、ソーティング･ルーチンが実行さ
れます。

ソートされると、各レイヤーのプロット･ファイルが作成されます。全てのプリミテ
ィブはスクリーン上に描画され、プロットされる順番と同じように表示されます。プ
ロセスの最後で”Photoplot is Finished"というプロンプトが表示されます。

è Advanced PCBのガーバー作成プロセスには、回転した四角の形状がありませ
ん。回転した四角の形状がデザインにある場合、ガーバー･ファイルが作成される
時に適当な丸いアパーチャーを使用してペイントされます。この状態は、これら
のオブジェクトを含むデザインからガーバーファイルを作成しインポートして確
認することができます。



PCB Design with Advanced PCB

ガガガガーーーーババババーーーー出出出出力力力力さささされれれれるるるるフフフファァァァイイイイルルルルににににつつつついいいいてててて
ガーバー･プロット･ファイル名には、レイヤーやプロット･タイプを識別するための
固有の拡張子が付けられます。例えば、"TEST"というファイルのトップ･レイヤーは
"TEST.GTL"という名前で保存されます。この拡張子は"Gerber-Top layer"であること
を表わします。各デザインはいろいろなプロットファイルを作成するので、これらの
タグにより出力ファイルを識別します。

è レイヤーやファイルタイプに固有の拡張子を使用することで、共通のファイル名
でも識別を簡単にできます。

業界で通常使用される形式に従って拡張子をつけることを推奨します。次のような
Advanced PCBのガーバー拡張子が、作成したガーバー･ファイルに付加されます。

Top Overlay .GTO
Bottom Overlay .GBO
Top Layer .GTL
Bottom Layer .GBL
Mid Layer 1, etc. .G1、G2
Power Plane 1, etc. .GP1
Mechanical Layer 1, etc. .GM1
Top Solder Mask .GTS
Bottom Solder Mask .GBS
Top Paste Mask .GTP
Bottom Paste Mask .GBP
Drill Drawing .GD1、GD2…GDD
Drill Guide .GG1、GG2…GGG
Pad Master, Top .GPT
Pad Master, Bottom.GPB
Keep Out Layer .GKO
Gerber Panels .P01, .P02, etc.
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NC ドドドドリリリリルルルル

Introduction

Advanced PCBでは、Excellonフォーマットの数値制御ドリル(NCドリル)装置の出力
ファイルを、現在のAdvanced PCBドキュメントウィンドウから直接作成することが
できます。NCドリルファイルはバイナリファイルで、ドリル装置から直接読まれま
す。このファイルには、PCBファイルの各穴の座標と穴開けツール割り付け情報が記
述されています。

Advanced PCBでは、ASCII形式のExcellonフォーマットのドリル･ファイルが作成さ
れます。デザインにスルーホールとノンスルーホールがある場合、それらは、異なる
ツールが割り付けられます。

NC Drill フフフファァァァイイイイルルルルににににつつつついいいいてててて

数値制御(NC）ドリル装置を使用すると、設計者や製造業者に対していくつか便利な
点があります。NCファイルを製造業者へ納入すると、穴開け工程をプログラムするコ
ストを減らすことができ、複雑な基板上の穴開けを間違える可能性が減ります。しか
し、NCドリルファイルを作成する前に考慮しなければならない問題があります。

NC装置を使用する場合、基板のアートワークは、正確で高品質にフォトプ
ロットされていなければなりません。NCホールは穴開け装置により正確に
位置決めされます。プロットの精度が悪いと、穴はパッドの中央に配置さ
れません。300mmの長さのプリント回路基板を考えると、プロッタに0.3%
のスケールエラーがある場合、基板上のエラーは最大で0.9mmになりま
す。プロットマスターからドリルが手動でプログラムされる場合、このエ
ラーはそれ程問題ではありません。なぜなら、コンポーネントの長さに比
べてその長さが非常に短いからです。ドリルが直接NCドリルから駆動され
る場合、0.9mmまでのエラーが累積される結果になります。

NC Drill フフフファァァァイイイイルルルルのののの作作作作成成成成

NCドリルファイルの作成についてはReportのトピックを参照してください。
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Reports
PCBエディタでは以下のレポートを出力することができます。

Selected Pins
選択されたピンはすべてSelected Pinsダイアログ･ボックスに一覧表示されます。こ
れによりネットの内部の接続関係の確認が簡単にできます。Maskを使用して表示され
たピンのリストを狭めることができます。OKボタンを押してレポート･ファイルを作
成してください。

Board Information

General Tab

このタブには、デザインの中で使用されるプリミティブ･タイプの数、基板の寸法(ワ
ークスペース内の最も離れたプリミティブを基にします)、パッドの総数、ビア穴、基
板のクリアランス･エラーの数があります。

Components Tab

トップ･レイヤーとボトム･レイヤーに配置されているコンポーネントをすべて一覧表
示します。表示させるには、デジグネータやコメントが必要です。

Nets Tab

現在、ロードされているネットの名前が一覧表示されます。

Pwr / Gnd

Pwr/Gndボタンを押すと、Internal Plane Informationダイアログ･ボックスが表示され
ます。各タブには、そのプレーンに接続されるネットが一覧表示されます。ネットを
選択すると、このプレーンに接続されるネットのピンが表示されます。

Bill of Materials
Reports » Bill of Materials メニュー（ショート･カット；R,I）選択すると、PCB
BOM Wizardが起動します。このウィザードは、アクティブなデザインのBill of
Materials(BOM)が作成され、これは自動的にSpread Sheet Editorにロードされます。
ウィザードが起動しない場合、PCBBOM Wizard Serverをインストールしてくださ
い。

Project Hierarchy
Reports » Project Hierarchy （ショートカット；R,I）により、現在開かれているドキ
ュメントのリストが作成され、それらはドキュメントの間でのプロジェクトの構成に
ついても反映しています。このレポートは以下のフォーマットのASCIIテキストで出
力されます。

Project Hierarchy Report For Z:\CLIENT\DESIGNS\RTD.PCB
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Z:\CLIENT\DESIGNS\RTD.PCB

Project Hierarchy Report For Z:\CLIENT\DESIGNS\RTD.PRJ

Z:\CLIENT\DESIGNS\RTD.PRJ

    Z:\CLIENT\DESIGNS\RTDADC.SCH

        Z:\CLIENT\DESIGNS\RTDINTA.SCH

        Z:\CLIENT\DESIGNS\RTDINTB.SCH

Reports » Project Hierarchy メニューが選択されると、Setup Run Optionsダイアロ
グ･ボックスで指定されるエディタを使用して自動的にレポートは開かれます。（デ
フォルトのテキスト･エディタはText Expertです）

Netlist Status
このレポートは各ネットの配線に使用されたレイヤーやネットの長さをレポートしま
す。

NC Drill
Advanced PCBでは、ASCIIフォーマットまたはExcellonフォーマットのドリル･ファ
イルが作成されます。Reports » NC Drill メニューを選択すると、アクティブPCBド
キュメント･ウィンドウのパッドやビアの現在の穴属性を使用してドリル･ファイルが
自動的に作成されます。デザインにスルーホールとノンスルーホールがある場合、そ
れらは、異なるツールが割り付けられます。ファイルは３種類作成されます。

1. .DRRファイルは、各レイヤー･ペアに作成されるファイルの一覧のレポート･フ
ァイルです。そのファイルには、使用されるツールや穴サイズ、穴の数、ツール
の移動量が記述されます。

2. Excellonフォーマット･ファイルには、拡張子.DRLが付きます。デザインがマル
チ･レイヤーでブラインドやバリード･ビアが使用されている場合、それぞれのレ
イヤーごとにドリル･ファイルが作成され拡張子DR1,DR2,....がつけられます。

3. Excellonフォーマット･ファイルのASCIIバージョンのファイルには、拡張
子.TXT、.TX1，TX2がつけられます。

これらのファイルすべてを.DRRをプリント･アウトしたものといっしょに基板製造業
者に渡してください。

上記のように、ブラインド･ビアやバリード･ビアがデザインにある場合、Advanced
PCBは、それぞれのレイヤーペアを示す拡張子の付いたドリル･ファイルを作成しま
す。例えば、４枚の信号レイヤーのある基板があり、ブラインド･ビアやバリード･ビ
アを使用している場合、３種類のNC Drillファイルが作成されます。これらのファイル
すべてと、レイヤー/ファイルの割り付けの説明、組み立て順序の説明を基板製造業者
に渡してください。

ドリル･コントロール･ファイル（拡張子DRL、DR1...）は、EXCELLON言語のEIAキ
ャラクター（バイナリ）･フォーマットで記述されます。データはmilsまたはmm単位
で指定されます。ドリル･ツールには、１から255までの番号がつけられます。
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Pick and Place
このレポートには、ピック＆プレイス･マシンで使用される情報が記述されます。テ
キストまたはCSVフォーマットで作成されます。レポートには、以下の情報が記述さ
れます。

Mid X, Mid Y

現在の原点で参照されるコンポーネントのミッド･ポイントの位置です。コンポ
ーネント･ミッド･ポイントは、一組になったコンポーネント･ピンの真ん中の点
として計算されます。

Ref X, Ref Y

現在の原点で参照されるコンポーネントのリファレンス･ポイントの位置です。

Pad X, Pad Y

現在の原点で参照されるコンポーネントのピン１の位置です。

TB

トップ(T)またはボトム(B)･レイヤーに取り付けられるレイヤー･コンポーネント
です。

Rotation

ライブラリ内での最初に設定した方向を基準としたコンポーネントの回転です。

Measure Distance
PCBワークスペースで正確な計測を行ないたい場合、この機能を使用してください。
Reports » Measure Distance  メニューを選択して、計測の最初の点を指定してくだ
さい。カーソルを置いて、マウスの左ボタンをクリックし、カーソルを終点まで移動
してマウスの左ボタンを再びクリックしてください。ダイアログに、Ｘ方向の距離と
Ｙ方向の距離が表示されます。必要な点を正確にポイントできない場合、スナップ･
グリッド(ショートカット;G)を変更してください。電気オブジェクトの中央にカーソ
ルのポイントをスナップしたい場合、一時的にエレクトリカルグリッドを無効にして
ください。

Measure Primitives
PCB設計において、2つのプリミティブ間のクリアランスがどれくらいあるのかを知
りたい場合があります。Measure Primitives機能は各プリミティブのエッジ間の距離を
計算し、表示させることができるため、簡単に2つのプリミティブの距離を確認する
ことができます。

Reports » Measure Primitives を選択し、最初のプリミティブをクリックし、次に2つ
めのプリミティブをクリックします。レポートされる内容は、各プリミティブのタイ
プと座標、レイヤーとそれらのプリミティブのエッジとエッジがもっとも接近してい
る距離が表示されます。
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Advanced Schematic ととととののののリリリリンンンンクククク

Netlists
スケマティックで作成されAdvanced PCBにロードされたネットリストは、Advanced
スケマティックからAdvanced PCBへのプライマリー･リンクです。このファイルによ
り、コンポーネント情報とネット情報がスケマティックからPCBデザイン環境へ渡さ
れます。そのため確実にスケマティック内容に基づいた基板のレイアウトや配線がで
きるようになります。

Protelデザインシステムは、Advanced ･スケマティックで変更されたデザインを
Advanced PCBへ反映することができます。ネットリストを更新するとPCBのデザイ
ンも変更されます。デザインの フォワード･アノテーションについての詳細は、ネッ
トリストに関する作業の項を参照してください。

Routing Directives
Protel２ネットリストを使用すると、トラック幅やビア･サイズのような特別なデザイ
ン情報をスケマティックからPCBへ伝えることができます。スケマティックでPCBレ
イアウト･ディレクティブをネットに付加し、これらの情報を追加します。ネットリ
ストがAdvanced PCBにロードされると、配線ディレクティブ情報は、デザイン･ルー
ルに変換されます。PCBレイアウト･ディレクティブについての詳細は、Advanced
Schematicユーザー･ガイドを参照してください。

Bi-directional Cross Probing
クロス･プロービングとは、異なるドキュメント間において、一致するオブジェクト
の位置を検索するテクニックです。例えば、スケマティックの中のネットで作業して
いる時に、PCB上でのそのネットがどこで配線されているかを検索する場合、スケマ
ティックからPCBへこのネットをクロス･プローブするには、Schematic Sheet Editor
メイン･ツールバーのクロス･プローブ･ボタンを押してください。スケマティック･シ
ートのネット名をクリックすると、PCBのネットがハイライト表示されます。ドキュ
メント･ウィンドウをタイル表示するとハイライト表示されたネットが見やすくなり
ます。

Advanced PCBはほとんどのオブジェクトのクロス･プローブをサポートしており、こ
れらには、ネットやAdvanced ･スケマティックからのピンやパーツがあります。テキ
スト･エディタなどのその他のEDA/Client Editorで開かれているドキュメントへクロ
ス･プローブすることもできます。テキスト･レポートからクロス･プローブするに
は、レポート内のアイテムを選択し、メイン･ツールバーのCross Probeボタンを押し
てください。
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è リソースの関する内容はEDA/Client の項目を参照してください。

Re-Annotation
Advanced PCBでは、ボード上のコンポーネントの位置を基準としてデジグネータの
再割り付けすることができます。変更された全てのデジグネータはWAS/ISファイル
に書き込まれます。このファイルは、単純なASCIIファイルで各デジグネータが現在
どのようになっているかがリストされます。

PCBをリアノーテートするには、Tools » Re-Annotate メニューを選択します。
Positional Re-Annotateダイアログ･ボックスが表示されます。このダイアログ･ボック
スで開始点とアノテーションの方向を指定してください。以下に４種類の指示オプシ
ョンを示します。

1.  左下からスタートし、下から上へ番号を付けます。

2.  左上からスタートし、上から下へ番号を付けます。

3.  左下からスタートし、左から右へ番号を付けます。

4.  左上からスタートし、左から右へ番号をつけます。

アノーテーション･ルーチンは50milsの”バンド幅”を使用し、それぞれのオプション
で指定をもとにバンド幅毎にアノテーションが行われます。例えば、最初のオプショ
ンは”Ｘを増やしてＹを増やす”という名前が付けられます。このオプションによ
り、Ｘ方向の次のバンドが設定され、再びＹ方向にバンドが下から上へ検索されま
す。それからＸ方向の次のバンドが設定され再びＹ方向へ下から上へ検索されます。
コンポーネント本体の中央は、その位置の参照として使用されます。

è 基板がリ･アノーテートされると、デジグネータの割り付けが変更され、一連のデ
シグネーションに飛びが無くなります。

リ･アノーテーションは、ファイル名 .WASというASCIIファイルに記述されます。

PCBでリ･アノーテーションの実行後は、修正したデジグネータを反映させるために
スケマティックで バック･アノテートを行なわなければなりません。スケマティック
のバック･アノーテートは、Advanced Schematicユーザー･ガイドを参照してくださ
い。

è スケマティックがバック･アノーテートされると、ネットリストはスケマティック
またはPCBと一致しなくなります。確定したデジグネータ情報が記述された３つ
のファイルを常に保存しておくのが良いでしょう。Advanced PCBでリアノーテ
ーションを行なった後は、すぐにAdvanced ･スケマティックでバック･アノーテ
ーションを行い、新しいネットリストを作成して下さい。

Advanced スケマティックでバック･アノーテートを行なわずに、Advanced PCB
で何度もリアノーテートをしないでください。そのままリアノテートを行なう
と、WAS/ISファイルの中のデジグネータ･リストがスケマティック･デジグネータ
のリスト、およびPCBのデジグネータと一致しなくなります。デジグネータが一
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致しないところはマニュアルで復旧しなければならなくなります。Advanced
PCBでリアノーテートした結果が思わしくない場合、Undoを実行してください。
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