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出力は、カスタム のドキュメントを生成します。PDF PDF OutputJob 
がサポートするあらゆる出力、回路図、 、Editor PCB PCB 

、 、部品表（ ） 出力も含まれます。3D OpenBus BOM  
各出力、および対応するコンポーネント、ネット、ピン、ポートのすべてについて PDF 
のブックマークが作成されます。  

 

 
Publish to PDF では、OutputJob エディタからカスタムの PDF 文書を作成できます。 回路図、OpenBus、PCB、PCB 3D、部

品表（BOM）、組み立て図面などが含まれた、いくつもの出力を PDF として並べることができます。出力には、Output Job 
エディタの Output Generators を使用します。  

 
図 1 PDF への出力機能によって、さまざまなソースファイルから PDF ドキュメントを出力することができます 

OutputJob エディタ 
設計用出力の設定と、それを出力するプロセスは、OutputJpb エディタで操作します。 OutputJob エディタでは、Output Job 
Configuration ファイル（*.Outjob）の定義と管理を既存のデザインプロジェクトに対して行います。  

 
図 2 OutputJob エディタと Output Media 欄にある PDF 出力メディアにリンクした Output のセット 

OutJpb ファイルには、以下の 2 つで構成されています。 

• Outputs （出力） - 組立て用、ドキュメント用、製造用、ネットリスト、レポート用の各 Output 

• Output Media （出力メディア） – PDF、直接プリント、ファイル出力の中から、出力先を選べます。 

希望の出力に応じて、複数の、異なる出力メディアを生成できます。 出力メディアには、お互いを区別するためのカスタム名

をつけることもできます。 緑色の矢印 （図 2 内）は、出力と出力メディアとのリンクを表しています。 
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新しい出力の追加  
新しい Output Job ファイルを生成すると、プロジェクトに関連する出力だけがファイルに追加され、デフォルト設定で構成さ

れます。 以下のいずれかの方法で、新しい出力はファイルに追加されます。 

• 関連する Edit » Add Outputs のメニューアイテムで、必要な出力を選びます。 

• 各カテゴリの下にある関連する Add New のエントリをクリックし、必要な出力を表示されるポップアップメニューから選

びます. 

出力メディアの追加 
Output Media 欄には Publish to PDF、Print、File Generation の各リストを含めることができます。 

新しい出力メディアを追加するには、Output Media カラムで下記のいずれかの操作を行います。 

• [Add New Output Medium] フィールドをクリックし、表示されるポップアップメニューから出力メディアを選びます。 

• Outputs セクションから、Output Media 欄に、出力をドラッグ＆ドロップします。 

• Outputs セクションから、Output Media 欄に、出力をコピー＆ペーストします。 

出力メディアの名前をカスタマイズするには、出力メディアを一回クリック。さらにもう一度クリックするか、F2 を押します。

プロジェクトに必要な名前に変更してください。. 

出力メディアへの出力の割り当て 
出力の有効性は、Output Media 欄から選ばれる出力メディアのタイプに依存しています。 すべての出力が PDF やファイルに

出力できるわけではありません。 これは、Enabled フィールドの状態で表示されます。 

指定の出力メディアへの割り当てによって、出力の内容を定義します。 緑のラインは、どの出力がどの出力メディアにアサイ

ンされているのかを示しています。 

 
図 3 Documentation Outputs の中にある ”Composite Drawing"、"PCB 3D Prints"、"PCB Prints"、"Schematic Print" （2 ファイル）。これらが
PDF メディアへの出力としてアサインされています。 

準備ができ次第、順に出力できます。 出力メディアから、ある出力を削除すると、順番が再び調整されます。 出力の順番を変

えたい場合は、番号をダブルクリックして、ドロップダウンから番号を選ぶか、最初から番号を付け直してください。 

出力する 
選択した出力メディアに出力を行います。Output Media 欄のトップボタンをクリックするか、F9 ショートカットキーを押し

てください。 

OutJob ファイル中から出力を追加したい場合や出力メディアを編集したい場合についての詳細は、Output Job Editor 
Reference を参照してください。 
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PDFに出力 
Outoput Job を利用できるかどうかは、選択した出力メディアごとに決まっています。 Publish to PDF メディアでは、その

PDF メディアにリンクできる出力だけに Enabled フィールドが表示されます。  

PDF 出力メディアに割付できる出力タイプは以下のとおりです。 

アセンブリ出力  
• 組み立て図面です。カスタムベースの Assembly Variant を含みます。 
ドキュメント出力 
• 回路図プリント - プロジェクトのフィジカルプリント（カスタムベースの Assembly Variant を含みます) 
• 回路図ドキュメント - ロジックのプリント、または指定のプリント 

• PCB プリント 

• PCB 3D プリント 

• OpenBus プリント 

• Logic Analyzer プリント 

• SimView プリント 

• 波形プリント 

• WaveSim プリント 

• コンポジット図面 

製造工程用のプリント 

• ドリル図面/ガイド 

• 最終アートワーク印刷 

• 電源プレーンのプリント  

• ハンダ/ペーストのマスクプリント 

• コンポジットドリル図面 

レポート出力 
• 部品表（BOM）。カスタムベースの Assembly Variant を含む。 

出力がいったん構成され、PDF メディアへの出力に割り付けられると、出力に先立って、Publish to PDF settings ダイアログ

を設定できるようになります。 
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PDFメディアの構成 
PDF Setup で、PDF 出力メディアを出力に先立って構成します。 

PDF 設定の構成は、PDF 出力メディアを右クリックし、PDF Setup をポップアップメニューから選んでて行います。  

 
図 4 Publish to PDF 設定ダイアログ 

Publish to PDF Settings ダイアログは、4 つの異なるグループに分けられています。 

出力ファイルのパス（Output File Path） 
このフィールドは、PDF を生成する際の出力ファイルのパスとファイル名を定義するのに使用します。 出力ファイルのパスは

場所を参照することができます。 デフォルトでは、PDF は プロジェクトオプション（Project » Project Options）の 
Options タブで指定される出力パスに保存されます。 

追加の出力設定 
• Open PDF file after export – ボックスをチェックすると、出力後にその PDF が開きます。 

• Prompt if file already exists – ボックスをチェックすると、既存の PDF を上書きする際に注意が表示されます。 

• Generate a separate PDF file for each output – ボックスをチェックすると、選択した各出力ごとに一つの PDF が作成さ

れます。Name で、出力される各 PDF にファイル名をつけることもできます。 

PDF のファイル名はカスタマイズでき、フォルダを指定することができます。OutJob ファイルの Name フィールドを使用し

ます。 FOLDER\FILENAME のフォーマットを使用すると、ファイル名と、生成した PDF の置き場所について最大限のコント

ロールができます。  

例えば、Schematic Prints の名前はSch\Schematic Prints に、 PCB Prints の名前は PCB\PCB Prints に置き換え

ることができます。図 5をご覧ください。 Generate a separate PDF file for each output option を有効にしておくと、回路

図出力、PCB出力のPDFは、回路図とPCBのフォルダにそれぞれ作成されます。 
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図 5 Publish to PDF  ダイアログの Generate a separate PDF file for each output option を有効にして、カスタムフォルダ内に生成された
PDF  

ズーム 
ズームのスライドバーで、コンポーネント、ネット、ポートを見る PDF ビューアで使うズームのレベルを設定します。 

追加のブックマーク 
Additional Bookmark options を使用して、PDF 内にネット情報を作成するか、しないか、選べます。 IGenerate nets 
information のチェックボックス有効にすると、追加のブックマーク、Pins, Net Labels と Ports をネット用に作成すること

ができます。 オブジェクト（ピン、ネットラベル、ポート）が利用できるブックマークが PDF 内に作成されます。 

ページサイズとページの向き 
ページサイズとページの向きの設定は、Page Setup ダイアログ、または 回路図ページと PCB ページの Source Document か
ら設定できます。  

ページサイズと向きは回路図ごとに設定できます。 

• 回路図エディタから Design » Document Options コマンドを使用します（Source Document を選んで、これらの設定を

PDF に適用）。 

• 回路図エディタから File » Page Setup  コマンドを使用します（Page Setup Dialog を選んで、これらの設定を PDF に適

用）。 

• OutputJob エディタで選択した出力を右クリックし、Page Setup コマンドを表示されるポップアップメニューから選びま

す。 （Page Setup Dialog を選んで、これらの設定を PDF に適用）。 

 
ページサイズは、以下の操作で PCB デザインに適用できます。 

• PCB エディタから Design » Board Options コマンドを使用します（Source Document を選んで、これらの設定を PDF
に適用）。 

• あらかじめ定義されたページサイズで新しい PCB デザインをテンプレートから作成します（Source Document を選んで、

これらの設定を PDF に適用）。 

ページサイズと向きは PCB ごとに設定できます。 

• PCB エディタから File » Page Setup  コマンドを使用します（Page Setup Dialog を選んで、これらの設定を PDF に適

用）。 

• OutputJob エディタで選択した出力を右クリックし、Page Setup コマンドを表示されるポップアップメニューから選びま

す。 （Page Setup Dialog を選んで、これらの設定を PDF に適用）。 

PDFに出力 
選択した PDF の出力メディアを設定したオプションで出力するに以下の方法があります。 

• ボタンをクリックします。 ボタンは Output Media 欄の中の選択した出力メディア名の PDF アイコンに関連付けられてい

ます。  

• 右クリックして、Publish to PDF オプションを Output Media 欄のポップアップメニューから選択します。 

• キーボードショートカット F9 を押します。 
• Publish to PDF コマンドを選択します（Tools » Publish to PDF）。 

OG0109 (v1.3) May 27, 2008 5 



Publish to PDF 

 
図 6 PDF への出力メディアに関連付けられた Output Generators の画面。Output Medium (F9) ボタンのクリックで出力できます。 

生成されたPDFの閲覧 
生成した PDF を見るには、Open PDF file after export のチェックボックスを有効にします。Publish to PDF Settings ダイア

ログ、または、出力ファイルのパスをたどって PDF を開いてください。 

生成された PDF ドキュメントは選択した全出力がグループ化されています。 ブックマークが提供されているので、ドキュメ

ントを自由に検索することができます。ブックマークは Additional Bookmarks の設定によります。 ソースとなる回路図は階

層構造です。階層は、PDF のブックマークに反映されています。 

 
図 7 PDF 出力の結果。出力に関連付けられた出力メディアからの PDF。ソースドキュメントは OutJob エディタ。 
コンポーネント、ネット、ピン、ポート、ネットラベルのブックマークをクリックすると、オブジェクトが常駐するエリアが

ズームされ、ハイライト表示されます。ズームが適用されるのレベルは、Publish to PDF Settings ダイアログ内のズームセッ
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トで設定されます。 ハイライト表示はコンポーネント、ネット、ピン、ポート、ネットラベルのブックマークを閲覧する場合

に適用され、参照が楽になります。 
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スクリプトを利用してPDFに出力 
Output Job の出力を自動化するため、スクリプトを作成して Publish to PDF Settings ダイアログをパス、PDF ドキュメントを

すばやく簡単に生成することができます。 Altium Designer のインストールに含まれている PublishToPDFScript のスクリ

プトは、以下のディレクトリで提供されています。PDF の出力ジョブが開かれた OutJob ファイルから、どのように起動され

るか確認してください。 

スクリプトのプロジェクトには、PublishToPDFScript が含まれています。Altium Designer がインストールされている

フォルダの \Examples\Scripts\Delphiscript Scripts\Processes\Process_Scripts.PrjScr ディレクトリ

を参照してください。 

PublishToPDFScriptスクリプトを使用したPDF出力の方法 
PDF の出力を提供されている PublishToPDFScript のスクリプトを使用して行うには、PDF への出力メディアとともに、

OutJob ファイルをロード、または作成しなくてはなりません。 

どの出力メディアが OutJob ファイルに設定されているか、とは無関係に、

PublishToPDF_AssemblyDrawingsAndSchematicPrints の手続きをスクリプトから起動した場合は、PDF ファイルが

既存の組み立て図面や回路図とともに生成されます。 

PDF を既存の組み立て図面や回路図とともに、生成 OutJob ファイルから出力するには、以下の方法があります。 

• 複数の組み立て図面や回路図の出力が定義されている OutJpb ファイルがあるデザインプロジェクトをロードします。 例え

ば、Mixer プロジェクト用の Default Assembly Outputs.OutJob は、Altium Designer の\Examples\Reference 
Designs\ Multi-Channel Mixer フォルダから開くことができます。 

• PublishToPDFScript のスクリプトがある Process_Scripts.PrjScr を\Examples\Scripts\Delphiscript 
Scripts\Processes\Process_Scripts.PrjScr フォルダからロードします。 

• DXP » Run Script コマンドを選択してと、Select Item To Run ダイアログが表示させます。 Process_Scripts のプロジ

ェクトがダイアログに表示されます。 

• PublishToPDF_AssemblyDrawingsAndSchematicPrints の手続きを PublishToPDFScript.pas のスクリプトエ

ントリの下から選択し、OK をクリックします。 

 
組み立て図面、回路図のプリント出力とともに、スクリプトによって、PDF が Default Assembly Ouputs.OutJob ファ

イル上に自動的に出力されます。 この AssemblyAndSchematic.PDF ファイルは、C:\ フォルダに生成されます。 スクリプ

トの内容は、Altium Designer の PublishToPDFScript.pas ファイルを開いて確認することができます 
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スクリプトをカスタマイズする方法 
スクリプトから PDF を出力するのに必要な Workspacemanager:Print プロセスで使用できるパラメータとその値は以下の

とおりです。 

パラメータ名 値 デフォルト 内容 必要？ 

Action ストリング PublishToPDF Action が、 PublishToPDF 
に設定されている場合は、この表内にある他のパラメータを使用して

ドキュメントの生成方法をカスタマイズすることができます。PDF  

Yes 

ObjectKind OutputSelected / 
OutputBatch 

OutputSelected ObjectKind が  OutputSelected 
に設定されている場合は、 （Output OutJob 
ファイル上で青色にハイライトされたセル） をあらわすSelected
NameX パラメー タを設定する必要があります。  
ObjectKind が  OutputBatch 
に設定されている場合は、 （Outputs OutJob 
ファイル上で緑色の矢印） を生成することができます。  

No 

SelectedNameX ストリング  が数字のとき。 は、X  SelectedNameX OutJob 
だいるの フィールドにある既存のName  Output 
に対応しています。Output Media 
欄で選択されている出力メディアとは無関係です。  
なお、ObjectKind パラメータは、 OutputSelected に
設定されている必要があります。 
例えば、組み立て図面や回路図を生成したい場合、以下のように指定

します。  
�AddStringParameter( SelectedName1’, 

� 組み立て図面’) または  
�AddStringParameter( SelectedName2’, 

� 回路図プリント’) をスクリプトに記述します  

No 

DisableDialog True / False False パラメータが True 
に設定され、他のパラメータが設定されていない場合、Publish to 
PDF Settings ダイアログからのデフォルト値が PDF 
の生成に使用されます。  
DisableDialog パラメータが  
Falseに設定されている場合に、Publish To PDF Settings 
ダイアログが呼び出され、いったん閉じられると、 はその設定でPDF
出力されます。  

No 

OpenOutput True / False * パラメータが True 
に設定されている場合、生成後に が開きますPDF  
このパラメータは、Publish To PDF Settings ダイアログの  
Open PDF file after export オプショ ンで無効になります。  

No 

ZoomLevel 整数 * 設定できる値は、 から までです。1 (far)  100 (near)  
値が より小さい場合、デフォルトで が設定されます。 より大き1 1 100
い場合はデフォルトで になります。100  ZoomLevel 
パラメータは、Publish To PDF Settings 
ダイアログのズームスライドバーでも調整できます。  

No 

FitSchPrintSizeTo
Doc 

True / False * このパラメータは、Publish To PDF Settings 
ダイアログのSchematic Page Size and Orientation 
Sourceで調整できます。  Trueの値は Source Document 
設定に対応し、Falseの値はPage Setup 
設定に対応しています。  

No 

FitPCBPrintSizeTo
Doc 

True / False * このパラメータは、Publish To PDF Settings 
ダイアログのPCB Page Size and Orientation 
Sourceで調整できます。  Trueの値は Source Document 
設定に対応し、Falseの値はPage Setup 

No 
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パラメータ名 値 デフォルト 内容 必要？ 
設定に対応しています。  

GenerateNetsInfo True / False * このパラメータは、Publish To PDF Settings ダイアログの  
Generate nets informationで調整できます。  
GenerateNetsInfo が True 
に設定されている場合は、追加の 、 、Pins Net Labels Ports 
のブックマークが作成されます。  

No 

MarkPins True / False * このパラメータは、Publish To PDF Settings 
ダイアログのPins のブックマークで調整できます。 デフォルトは   
True です。 この設定を有効にするには、 GenerateNetsInfo 
オプショ ンを True にする必要があります。  

No 

MarkNetLabels True / False * このパラメータは、Publish To PDF Settings 
ダイアログのNet Labels のブックマークで 調整できます。  
この設定を有効にするには、GenerateNetsInfo オプショ ンを  
True にする必要があります。  

No 

MarkPorts True / False * このパラメータは、Publish To PDF Settings 
ダイアログのPorts のブックマークで調整できます。  
この設定を有効にするには、GenerateNetsInfo オプショ ンを  
True にする必要があります。   

No 

OutputMedium ストリング  このパラメータは、 のAltium Designer 既存のOutJob 
ファイル用の 出力メディアをターゲットにしています。PDF  
OutputMedium 
パラメータが指定されていない場合は、Output Media 
リスト内の最初の 出力メディアで出力されます（PDF OutJob 
ファイルの緑の矢印は、この設定を反映して更新されます） 。  

出力メディアが存在しない場合は、何も起こりません。PDF  

No 

PublishMethod 0 / 1 * このパラメータはOutput 
を単一のファイル（ PublishMethod ） で出力するか、 = 0  
複数のファイル（ PublishMethod = 
） で出力するかを決定します。 このパラメータは、1  Publish To 

PDF Settings ダイアログの Generate a separate PDF 
file for each outputで調整できます。  OutputFilepath 
パラメータも指定する必要があります。  

No 

OutputFilepath ストリング PDF 
拡張子つきのOutJob 
ファイルのパスです。

PublishMethod なら、= 0 OutputFilepath 
にはパスとファイルのフルネームが必要です。  
PublishMethod なら、= 1 OutputFilepath 
にはフォルダ名が必要です。  
OutputFilepath が指定されていない場合、 OutJob 
ファイルのパスが の拡張子付で代わりに使用されます。PDF  

No 

注記 

1. 表中の Default 欄のアスタリスク * マークは、Publish to PDF settings ダイアログのデフォルト設定に対応しています。 

2. Publish to PDF Settings ダイアログのデフォルト値は、OutJob ファイルの出力メディアから引用されたものです。 出力メ

ディアを構成し、OutJob ファイルを保存するたびごとに、出力メディア用の新しい設定が OutJob ファイルに保存されます。 
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スクリプトのサンプル - 特定のPDF出力メディアを使用してPDFに出力 
下記のサンプルスクリプトは、PDF に出力可能なあらゆる Output を出力できるようになっています。 スクリプトを実行する

前に、DocoPDF という名前の PDF 出力メディアのある OutJob ファイルが必要になります。 

出力される PDF ファイルの内容を定義するには、DocoPDF 出力メディアからのデフォルト設定が使用されます。 Publish to 
PDF Settings ダイアログで設定を変更するか、有効なパラメータを上記の表から利用してスクリプトに書き込み、Publish to 
PDF Settings ダイアログを調整するか、選ぶことができます。 
Procedure PublishToPDF_DocoPDF_Medium; 
Begin 
    ResetParameters; 

AddStringParameter ('Action'         ,'PublishToPDF'); 
 
// Select an existing PDF Output Medium. If not found, first PDF Medium will be used. 
AddStringParameter ('OutputMedium'   ,'DocoPDF'); 
 
// Publish all the selected Output Jobs  
AddStringParameter ('ObjectKind'     ,'OutputBatch'); 
 
// Don’t display the Publish to PDF Settings dialog 
AddStringParameter ('DisableDialog'  ,'True'); 
 
//Publish selected Output Jobs in a single PDF file 
AddIntegerParameter('PublishMethod'  , 0); 
 
// Override the Output File path setting in the Publish to PDF Settings dialog 

    AddStringParameter ('OutputFilePath'       ,'C:\Doco.pdf'); 
 
    RunProcess('WorkspaceManager:Print'); 

End; 

このスクリプトには、AddStringParameter と AddIntegerParameter のさまざまなコールとともに、

Workspacemanager:Print のプロセスが含まれており、 C:\ フォルダに DocoPDF.PDF ファイルを生成します。 

このスクリプトは、Process_Scripts.PrjScr プロジェクトの PublishToPDFScript.pas ファイル内に追加することが

でき、PublishToPDF_DocoPDF_Medium の手続きを OutJob エディタの Select Item To Run ダイアログから実行することが

できます。 

 
スクリプトについての詳細は、Getting Started with Scripting を参照してください。  

スクリプトプロジェクトのビルドについての詳細は、Building Script Projects を参照してください。 

新しいショートカットを作成する方法、Altium Designerのリソースを更新する方法についての詳細は、Customizing the 
Altium Designer Resources を参照してください。 

スクリプトの利点、スクリプトの研究例については、Altium Designer をインストールしたフォルダの 
/Examples/Scripts  ディレクトリを参照してください。 
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更新履歴 

Date Version No. Revision 

19-Oct-2007 1.0 Altium Designer 6.8 Release 

25-Jan-2008  1.1 Added information for new feature, Batch Publish to PDF 

21-Apr-2008 1.2 Updated Page Size to A4 

27-May-2008 1.3 Added information for new features, Output Media column and multiple 
PDF generation. 
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