Troubleshooting NanoBoard 3000 Connection Problems

Frozen Content

If, after completing the NanoBoard 3000 setup and installation procedures, the Devices view shows that the system cannot connect to the NanoBoard or cannot detect the presence of its User FPGA, go through the following steps to try to correct the problem:

  1. Ensure that your 3000-series NanoBoard is switched on.
     
  2. Ensure that the connecting USB cable between the NanoBoard 3000 and the PC is correctly plugged in at both ends.
     
  3. Check that the 'PWR' LED (LED1) to the right of the TFT LCD panel is lit (Green) and that the 'STATUS 1' LED (LED16) to the left of 'User Header A', is also lit (Red).
     
  4. With the Devices view active, ensure that the Live option is enabled, and select Tools»Refresh All from the menu (shortcut F5).
     
  5. From the Devices view, select Tools»Scan NanoBoard Chain from the main menus. This forces a manual scan of the NanoBoard JTAG chain. A dialog will appear and, if successfully detected, should list the 3000-series NanoBoard you are using.
     

    Manually interrogating the NanoBoard JTAG chain.
     
  6. If the NanoBoard is detected correctly, from the Devices view select Tools»Scan Hard Chain from the main menus. This forces a manual scan of the Hard Devices JTAG chain. A dialog will appear and, if successfully detected, should list the physical, User FPGA device on the NanoBoard 3000.
     

    Manually interrogating the Hard Devices JTAG chain.

If, after completing all the above steps, the system still cannot establish a connection with the NanoBoard 3000 and/or User FPGA device, then please contact your local Altium Sales & Support Center, or Reseller.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: